ThermalEngine not defined/active yet?

Asked by Yaniv Fogel on 2019-09-14

Hello,

I was trying to play with the ThermalEngine [1]. Now, I understand that it might still be an experimental engine and still under development, but I see it appears in the documentation, and FlowEngine (and the rest FlowEngines) currently does have the ability to activate thermalEngine [2] within them... (plus, Thermal.cpp and Thermal.hpp do exist in the trunk version...)

Am I missing something here?
I'm running on Ubuntu 19.04 with yade 2019.01a, installed with apt-get install.

If I try to activate the engine, I get the following error message:

Traceback (most recent call last):
  File "/usr/bin/yade", line 241, in runScript
    execfile(script,globals())
  File "temp_engine.py", line 61, in <module>
    ThermalEngine(advection=False, # Activates advection
NameError: name 'ThermalEngine' is not defined

Thanks in advance,
Yaniv

P.S.
I noticed this past question -
https://answers.launchpad.net/yade/+question/679769
I hoped with the thermal c++ files already existing that it might have been implemented...

[1] https://yade-dem.org/doc/yade.wrapper.html?highlight=thermalengine#yade.wrapper.ThermalEngine
[2] https://yade-dem.org/doc/yade.wrapper.html?highlight=thermalengine#yade.wrapper.FlowEngine.thermalEngine

Question information

Language:
English Edit question
Status:
Solved
For:
Yade Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Caulk
Solved:
2019-09-15
Last query:
2019-09-15
Last reply:
2019-09-15
Yaniv Fogel (yanivfgl) said : #1

OK, just noticed this remark in the installation documents [1] -
"Installation from source code is reasonable, when you want to add or modify constitutive laws, engines, functions etc. **Installing the latest trunk version allows one to use newly added features, which are not yet available in packaged versions."**

I guess I'll have to install from source code...

[1] https://yade-dem.org/doc/installation.html?highlight=install

Best Robert Caulk (rcaulk) said : #2

Hello,

ThermalEngine was released after yade2019.01a, so it is not available in that version. The packaged yadedaily should have it but at the moment yadedaily is not being updated for technical reasons [1]. Once that is fixed, the ThermaEngine will be accessible therein.

If you want to use it sooner than that, yes, compilation of the source code is going to be the quickest way.

Cheers,

Robert

[1]https://yade-dem.org/doc/installation.html?highlight=install

Yaniv Fogel (yanivfgl) said : #3

Thanks Robert Caulk, that solved my question.