Installation YADE, Source Code, Compilation

Asked by ehsan benabbas on 2019-07-17

Hi folks,
I'm very new with YADE and linux and have a problem with installation of YADE source code on my Ubuntu 18 which has been installed on VMware software (my host windows is windows 10).
I've wen through installation instruction linke below

https://yade-dem.org/doc/installation.html

I hope i've done everything correcty by now, I have no idea about "Compilation" section. From the very frist sentence, does it mean to creat new folders like myYade, and 3 others inside it or it has another meaning? Even about the "cmake" commands, I don't know what are those clearly since I'm pretty new in Linux.

The thing I do is that, I use "cd ......./trunk" and then try to use CMake commands like "cmake -DCMAKE_INSTALL_PREFIX=........./myYade/build" the problem is I get the following Error:

-- The C compiler identification is GNU 7.4.0
-- The CXX compiler identification is GNU 7.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Version is set to 2019-07-08.git-e27605e
-- GCC Version >= 4.8. Adding -ftrack-macro-expansion=0
-- GCC Version >= 4.8. Adding -save-temps
-- GCC Version >= 4.9. Adding -fstack-protector-strong
Loop on the following python versions and check available dependencies:3.8;3.7;3.6;3.5;3.4;3.3;3.2;3.1;3.0;2.7;2.6
-- Found PythonInterp: /usr/bin/python (found version "2.7.15")
-- Found PythonInterp: /usr/bin/python3.6 (found version "3.6.8")
Python version 3.6.8 found, try to import dependencies...
CMake Warning at /usr/share/cmake-3.10/Modules/FindBoost.cmake:1626 (message):
  No header defined for python-py36; skipping header check
Call Stack (most recent call first):
  cMake/YadePythonHelpers.cmake:62 (FIND_PACKAGE)
  CMakeLists.txt:179 (FIND_PYTHON_PACKAGES)

Failed to import dependencies for Python version 3.6.8. NOT FOUND:numpy
-- Found PythonInterp: /usr/bin/python (found version "2.7.15")
-- Found PythonInterp: /usr/bin/python2.7 (found version "2.7.15")
Python version 2.7.15 found, try to import dependencies...
-- Found NumPy: version "1.16.4" /usr/local/lib/python2.7/dist-packages/numpy/core/include
-- Found IPython: /usr/lib/python2.7/dist-packages/IPython
-- Could NOT find matplotlib (missing: PY_matplotlib)
Failed to import dependencies for Python version 2.7.15. NOT FOUND:matplotlib
-- Found PythonInterp: /usr/bin/python (found version "2.7.15")
CMake Error at CMakeLists.txt:188 (MESSAGE):
  No python version with all dependencies was found.

-- Configuring incomplete, errors occurred!
See also "/home/ehsan/trunk/CMakeFiles/CMakeOutput.log".
See also "/home/ehsan/trunk/CMakeFiles/CMakeError.log".

What should I do?

Thanks for you help

Question information

Language:
English Edit question
Status:
Answered
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
2019-07-17
Last reply:
2019-07-18
Robert Caulk (rcaulk) said : #1

Forget compilation, just type:

sudo apt-get install yade

into the terminal.

You now have yade fully installed on your computer. You can test it by typing:

yade

into a terminal.

ehsan benabbas (ehsanben) said : #2

Thank you Robert

the thing is I've installed the package version. But I need the source code to develop it and make some changes for my research. That's why I need to compile the source code.

Chareyre (bruno-chareyre-9) said : #3

Hi, the answer is in your question: matplotlib not found.
Bruno

Le mer. 17 juil. 2019 18:32, ehsan benabbas <
<email address hidden>> a écrit :

> Question #682120 on Yade changed:
> https://answers.launchpad.net/yade/+question/682120
>
> Status: Answered => Open
>
> ehsan benabbas is still having a problem:
> Thank you Robert
>
> the thing is I've installed the package version. But I need the source
> code to develop it and make some changes for my research. That's why I
> need to compile the source code.
>
> --
> You received this question notification because your team yade-users is
> an answer contact for Yade.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~yade-users
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~yade-users
> More help : https://help.launchpad.net/ListHelp
>
>
>

Jérôme Duriez (jduriez) said : #4

In terms of cmake errors, which relate to missing dependencies (external packages) you should read carefully https://yade-dem.org/doc/installation.html#prerequisites and check you've installed everything that's listed there. It seems it's not the case.

In terms of general YADE using, and if you're new to all this Linux stuff, it's highly worth to spend some time gaining confidence in the field, before aiming to YADE results...

Actually YADE research is a good opportunity to train and gain confidence in Linux and computers, but do not expect your YADE progress to be fast in a first phase...

ehsan benabbas (ehsanben) said : #5

Thank you all for your comments. I went through my error by considering your comments and found out my issue belonged to VTK package and its configuration. After solving that issue, I get a new one which is about gts. The error message is:

-- Could NOT find gts (missing: PY_gts)
-- Use embedded version of gts. Please, consider installing the corresponding package
CMake Error at CMakeLists.txt:677 (IF):
  if given arguments:

    "GREATER" "5"

  Unknown arguments specified

-- Configuring incomplete, errors occurred!

So, I know I have already installed the latest version of PY-gts . What is the solution?

Thank you so much for your help

Can you help with this problem?

Provide an answer of your own, or ask ehsan benabbas for more information if necessary.

To post a message you must log in.