How to run Yade simulation using HPC when GPU command line does not work?

Asked by Nicholas Ng on 2019-07-05

Hi all,

I'm currently trying to run Yade simulation in HPC, to test whether this can reduce down the time taken for my Yade simulation run using normal PC. I had seek the help from the administrator of HPC to install Yade onto it, he managed to help me do that, but he said the the GPU command line does not work for the Yade in HPC, so the computational capacity of this Yade in HPC is still about the same as normal PC.

After that, the administrator of the HPC sent another email to me, ask me to add something into my Yade script to enable usage of allocated GPU. The email is as follow:

===================================================================================================

Here is the actual yadeLauncher.sh . You will need to use the allocated GPU with yade . In the example below, it will have to be put inside DST_parametric_M1c_Layer1.py. As I am not a yade expert, I cannot tell you how this can be done.

cat yadeLauncher.sh

#! /bin/bash

#load the anaconda tensorflow environment
module load anaconda/5.3.1py3
source activate tensorflow-gpu
###echo $CUDA_VISIBLE_DEVICES
###GPUNUM=`echo $CUDA_VISIBLE_DEVICES`

#navigate to Your directory
##cd /export/home/s123456/pbs/singularity/yade/

#run the code
yade /export/home/s123456/pbs/singularity/yade/DST_parametric_M1c_Layer1.py

=============================================================================================

I would like to ask for some help and advice on how to add the things as advised by the administrator of HPC to enable GPU usage for Yade in HPC?

Do I just copy and paste those lines from the HPC administrator into my Yade script?

I really appreciate to get some response on this issue of mine.

Thank you and Regards,
Nicholas Ng

Question information

Language:
English Edit question
Status:
Answered
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
2019-07-05
Last reply:
2019-07-05

Hi,
Yade is not using GPU (exception for a very specific flow solver not mentioned in your question, so I guess it's out of scope).
Therefore there is nothing to enable.
Bruno

Nicholas Ng (nngyongjie) said : #2

Hi Bruno,

Thanks for your reply.

Regards,
Nicholas Ng

Can you help with this problem?

Provide an answer of your own, or ask Nicholas Ng for more information if necessary.

To post a message you must log in.