Unable to install yade on Ubuntu 18.04.2

Asked by jamespaul on 2019-03-01

Hi,

I can install yade in any ubuntu version in mainland China. However, in Hong Kong, when I input sudo apt-get install yade/yadedaily, the error will be: Unable to locate package yade. When I input sudo apt-get install, the error will be: Some index files failed to download.They have been ignored,or old ones used instead.

1. Is it the problem of network permission?

2. What is the difference between yade and yadedaily?

James

Question information

Language:
English Edit question
Status:
Solved
For:
Yade Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Caulk
Solved:
2019-03-03
Last query:
2019-03-03
Last reply:
2019-03-01
Best Robert Caulk (rcaulk) said : #1

Try locating "Software & Updates", in the first tab "Ubuntu Software", confirm that "Download from:" is set to "Main Server".

After setting this, please verify that you are using this exact command:

sudo apt-get install yade

and report any errors you encounter.

>> What is the difference between yade and yadedaily?

yade is a stable version that is updated once per year. yadedaily is updated "regularly"[1], and therefore might contain bugs.

[1] https://yade-dev.gitlab.io/trunk/installation.html#packages

jamespaul (jamespauljames) said : #2

Thanks Robert,

You're amazing!

jamespaul (jamespauljames) said : #3

Thanks Robert Caulk, that solved my question.