yadedaily- broken packages

Asked by ozge on 2018-06-25

Hello, I tried to install yadedaily on ubuntu 18.04. However, I received the errors showed in the following lines :

ozge@inside-65-93-6:~$ sudo apt-get install yadedaily
[sudo] password for ozge:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 yadedaily : Depends: libyadedaily (= 2018.02b-15189a57e8~xenial-1) but it is not going to be installed
             Depends: python-yadedaily (= 2018.02b-15189a57e8~xenial-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I saw a posted question about a similar problem to mine, but it was not clearly responded.
So, is there anyone who can help me on this problem?

thanks a lot,

ozge

Question information

Language:
English Edit question
Status:
Answered
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
2018-06-25
Last reply:
2018-06-26
Manfred Hampl (m-hampl) said : #1

What output do you receive for the commands

uname -a
lsb_release -crid
sudo apt-get udapte
sudo apt-get install yadedaily
apt-cache policy yadedaily libyadedaily python-yadedaily

ozge (osge) said : #2

These are what I received:

ozge@inside-65-93-6:~$ uname -a
Linux inside-65-93-6.wireless.utoronto.ca 4.15.0-23-generic #25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
ozge@inside-65-93-6:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic
ozge@inside-65-93-6:~$ sudo apt-get update
[sudo] password for ozge:
Hit:1 http://archive.canonical.com bionic InRelease
Hit:2 http://linux.teamviewer.com/deb stable InRelease
Hit:3 http://linux.teamviewer.com/deb preview InRelease
Get:4 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]
Hit:5 http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Get:6 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease [83.2 kB]
Hit:7 http://www.yade-dem.org/packages xenial/ InRelease
Get:8 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Get:9 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Get:10 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [162 kB]
Get:11 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [2,456 B]
Get:12 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [148 kB]
Get:13 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [113 kB]
Get:14 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [25.1 kB]
Get:15 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [44.5 kB]
Get:16 http://ca.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [105 kB]
Get:17 http://ca.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [105 kB]
Get:18 http://ca.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [122 kB]
Get:19 http://ca.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [121 kB]
Get:20 http://ca.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [200 kB]
Get:21 http://ca.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5,100 B]
Fetched 1,395 kB in 1s (1,124 kB/s)
Reading package lists... Done
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:53
W: Target Translations (en_CA) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:53
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:53
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:56
W: Target Translations (en_CA) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:56
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:56
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:57
W: Target Translations (en_CA) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:57
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:57
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:58
W: Target Translations (en_CA) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:58
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:58
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:53
W: Target Translations (en_CA) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:53
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:53
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:56
W: Target Translations (en_CA) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:56
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:56
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:57
W: Target Translations (en_CA) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:57
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:57
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:58
W: Target Translations (en_CA) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:58
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list:58
ozge@inside-65-93-6:~$ sudo apt-get install yadedaily
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 yadedaily : Depends: libyadedaily (= 2018.02b-15189a57e8~xenial-1) but it is not going to be installed
             Depends: python-yadedaily (= 2018.02b-15189a57e8~xenial-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
ozge@inside-65-93-6:~$ apt-cache policy yadedaily libyadedaily python-yadedaily
yadedaily:
  Installed: (none)
  Candidate: 2018.02b-15189a57e8~xenial-1
  Version table:
     2018.02b-15189a57e8~xenial-1 500
        500 http://www.yade-dem.org/packages xenial/ Packages
libyadedaily:
  Installed: (none)
  Candidate: 2018.02b-15189a57e8~xenial-1
  Version table:
     2018.02b-15189a57e8~xenial-1 500
        500 http://www.yade-dem.org/packages xenial/ Packages
python-yadedaily:
  Installed: (none)
  Candidate: 2018.02b-15189a57e8~xenial-1
  Version table:
     2018.02b-15189a57e8~xenial-1 500
        500 http://www.yade-dem.org/packages xenial/ Packages
ozge@inside-65-93-6:~$

Anton Gladky (gladky-anton) said : #3

> 2018.02b-15189a57e8~xenial-1)

18.04 is the "bionic"-release. You have xenial (16.04) in /etc/apt/sources.list

Anton

ozge (osge) said : #4

So should I work on ubuntu 16.04 ?

Thanks a lot for your quick reply.

Manfred Hampl (m-hampl) said : #5

The yadedaily package for xenial does not work on bionic.

I see two possibilities:
Either use Ubuntu xenial with the yadedaily package from www.yade-dem.org
or
Use the yade package from the standard repositories for Ubuntu bionic.

Additional remark:
You seem to have redundant lines in your /etc/apt/sources.list configuration file causing warnings for the apt-get update command.
I assume that the lines 53, 56, 57 and 58 are identical to line 52 and should be deleted.

Just to avoid useless trouble I would put Manfred's possibilities in a different order:
Use the yade package from the standard repositories for Ubuntu bionic.
or
Either use Ubuntu xenial with the yadedaily package from www.yade-dem.org

That is:
Install the right package for your OS (reading the install page again should be enough)
or
Reinstall linux if you see an error message ;)

mohsen (agha-mohsena) said : #7

Hi every one
I encountered the same problem, However in Ubuntu 16.04.
Any other option else than reinstalling Linux?

Manfred Hampl (m-hampl) said : #8

@mohsen:
Please do not piggyback on somebody else's question, but create a question document of your own.
If possible add the output of the commands listed in the first response of this question document.

> Any other option else than reinstalling Linux?

It was just a joke in #6... sorry. Don't reinstall linux to fix a problem, never.

Can you help with this problem?

Provide an answer of your own, or ask ozge for more information if necessary.

To post a message you must log in.