Yade on ubuntu18.04

Asked by Henry on 2018-06-19

Hi all,
   Is there anyone who successfully compiled the Yade on Ubuntu 18.04?
Thanks a lot!
Best regards,
Henry

Question information

Language:
English Edit question
Status:
Expired
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
2018-06-21
Last reply:
2018-07-07
Klaus Thoeni (klaus.thoeni) said : #1

Yes, I did just recently. I am planning to update the doc at some stage,
just need some time. A few package names changed, other than that it was
straightforward. However, I should mention not all versions compile
smoothly, so you have to be careful which version you check out.

Any particular issues you are facing?

Klaus

On Wed, Jun 20, 2018 at 1:03 AM, Henry <<email address hidden>
> wrote:

> New question #670318 on Yade:
> https://answers.launchpad.net/yade/+question/670318
>
> Hi all,
> Is there anyone who successfully compiled the Yade on Ubuntu 18.04?
> Thanks a lot!
> Best regards,
> Henry
>
> --
> You received this question notification because your team yade-users is
> an answer contact for Yade.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~yade-users
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~yade-users
> More help : https://help.launchpad.net/ListHelp
>

Henry (wenjiexu) said : #2

Thanks a lot!
There is some errors when I install the "libqglviewer-dev" directly.

Henry

Klaus Thoeni (klaus.thoeni) said : #3

You need to install libqglviewer-dev-qt5

On Wed, Jun 20, 2018 at 11:27 PM, Henry <
<email address hidden>> wrote:

> Question #670318 on Yade changed:
> https://answers.launchpad.net/yade/+question/670318
>
> Status: Answered => Open
>
> Henry is still having a problem:
>
> Thanks a lot!
> There is some errors when I install the "libqglviewer-dev" directly.
>
> Henry
>
> --
> You received this question notification because your team yade-users is
> an answer contact for Yade.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~yade-users
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~yade-users
> More help : https://help.launchpad.net/ListHelp
>

Henry (wenjiexu) said : #4

Thanks a lot!
 Furthermore, there is also some problems on "python-imaging".
Thanks a lot!
Henry

Manfred Hampl (m-hampl) said : #5

python-imaging is an obsolete package (no more available in Ubuntu 18.04) and has been replaced by python-pil (but I do not know whether this satisfies the dependency of Yade)

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.