yade compiled installation in a redhat cluster

Asked by hanzj on 2017-01-09

Hello,all:
I want to compiled the yade trunk version( yade-2016.06a.tar.gz) to install in a redhat cluster, whose version is redhat AS 5.5 server.
now my problem is :
1)how can i install the prerequisites with "yum" command not with apt-get command( because the school's system can not use apt-get command)? or i can just compile to install one by one? is there any reference for me to refer to ?

2)Supposed that i have installed the prerequisites, how can i install the yade version?i have ever compiled it with cmake, make, make install to install it in ubuntu system successfully, but i am wondering if there exists difference to install in redhat cluster.

anyone has ever experienced kind of thing? sincerely appreciate your help.Thank you.

Best regards,
han zhijian

Question information

Language:
English Edit question
Status:
Answered
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
2017-01-21
Last reply:
2017-01-23
Anton Gladky (gladky-anton) said : #1

Hi,

you just need to find the same RPM-packages. Their name
can differ from DEB-names. After that you should follow
instructions from "install" section of documentation.

If I remember correctly, somebody used Yade on similar
platform. You can search in questions.

Best regards

Anton

hanzj (hanzj14) said : #2

Dear Anton Gladky:
Thank you for your help. I will try that later.

发自我的 iPhone

> 在 2017年1月10日,上午2:47,Anton Gladky <email address hidden> 写道:
>
> Your question #432848 on Yade changed:
> https://answers.launchpad.net/yade/+question/432848
>
> Status: Open => Answered
>
> Anton Gladky proposed the following answer:
> Hi,
>
> you just need to find the same RPM-packages. Their name
> can differ from DEB-names. After that you should follow
> instructions from "install" section of documentation.
>
> If I remember correctly, somebody used Yade on similar
> platform. You can search in questions.
>
> Best regards
>
> Anton
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/yade/+question/432848/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/yade/+question/432848
>
> You received this question notification because you asked the question.

Klaus Thoeni (klaus.thoeni) said : #3

Hi,

we have yade running on our RH cluster. The installation/compilation is not as straight forward as for debian/ubuntu. As Anton mentioned you need to find the RPM-packages for all pre-required libraries [1]. The important thing here is that you have to check if the minimal required version is available with yum. Sometimes it will not be the case hence you cannot install it with yum but you need to download the sources and compile the package/library yourself. And yes, the make process is exactly the same using cmake [2]. Again, make sure you have at least cmake version 2.8.11 installed.

I cannot remember all steps but I strongly recommend you to only install the packages you really need and compile yade with the corresponding options. For example, I did not bother installing optional packages (e.g., required for fluid coupling) and the graphical mode (e.g., use cmake option -DENABLE_GUI=0). This should make things much easier.

HTH
Klaus

[1] https://yade-dem.org/doc/installation.html#prerequisites
[2] https://yade-dem.org/doc/installation.html#compilation

hanzj (hanzj14) said : #4

Hello,all,
hello,Anton and Klaus Thoeni,
Sorry for reply so late. I have tried to install the pre-required libraries as your recommendation, I am now facing the problem is
the installation of minieigen. I have download the minieigen-0.5.3.tar.gz from http://eudoxos.github.io/minieigen
and I tried to install it using the comand python setup.py install
 but
(1) I came across the error:
  File "setup.py", line 23
    libraries=['boost_python-py3%d'%sys.version_info[1] if py3k else 'boost_python']
                                                         ^
SyntaxError: invalid syntax

(2)also ,I can not understand the command in the README.txt as follows:

To compile by hand under Linux, run something like

    g++ -ansi src/miniEigen.cpp src/double-conversion/*.cc -o minieigen.so -shared -fPIC `pkg-config python --cflags` -lboost_python -I/usr/include/eigen3

and the whole README.txt as follows:
This is miniEigen, small wrapper for the http://eigen.tuxfamily.org library.
Home of this project is at http://www.launchpad.net/minieigen/. The code is
licensed under the LGPLv3. The author is Václav Šmilauer <email address hidden>.

Documentation is uploaded to http://eudoxos.github.io/minieigen.

Run `python setup.py install` to build & install this module. You will need the
boost_python library to be installed, and Eigen (in /usr/include/eigen3, or
somewhere where the compiler finds it).

Windows is experimentally supported, but paths must be tweaked in setup.py
to match your system. Suggestions for a better way are welcome.

To compile by hand under Linux, run something like

    g++ -ansi src/miniEigen.cpp src/double-conversion/*.cc -o minieigen.so -shared -fPIC `pkg-config python --cflags` -lboost_python -I/usr/include/eigen3

Enjoy.

(3)If I am not going to install the minieigen, could I comply yade to install? must I install it? I have tried without it, but complied failed.

Any suggestions?
Thanks a lot.

Han Zhijian

At 2017-01-11 05:44:24, "Klaus Thoeni" <email address hidden> wrote:
>Your question #432848 on Yade changed:
>https://answers.launchpad.net/yade/+question/432848
>
> Status: Open => Answered
>
>Klaus Thoeni proposed the following answer:
>Hi,
>
>we have yade running on our RH cluster. The installation/compilation is
>not as straight forward as for debian/ubuntu. As Anton mentioned you
>need to find the RPM-packages for all pre-required libraries [1]. The
>important thing here is that you have to check if the minimal required
>version is available with yum. Sometimes it will not be the case hence
>you cannot install it with yum but you need to download the sources and
>compile the package/library yourself. And yes, the make process is
>exactly the same using cmake [2]. Again, make sure you have at least
>cmake version 2.8.11 installed.
>
>I cannot remember all steps but I strongly recommend you to only install
>the packages you really need and compile yade with the corresponding
>options. For example, I did not bother installing optional packages
>(e.g., required for fluid coupling) and the graphical mode (e.g., use
>cmake option -DENABLE_GUI=0). This should make things much easier.
>
>HTH
>Klaus
>
>[1] https://yade-dem.org/doc/installation.html#prerequisites
>[2] https://yade-dem.org/doc/installation.html#compilation
>
>--
>If this answers your question, please go to the following page to let us
>know that it is solved:
>https://answers.launchpad.net/yade/+question/432848/+confirm?answer_id=2
>
>If you still need help, you can reply to this email or go to the
>following page to enter your feedback:
>https://answers.launchpad.net/yade/+question/432848
>
>You received this question notification because you asked the question.

hanzj (hanzj14) said : #5

dear all:
at the make stage, It came across the error as follows: can you help me?
[ 98%] Built target _packSpheres
In file included from /apps/lib/python/Python-2.7.2/lib/python2.7/site-packages/numpy/core/include/numpy/ndarraytypes.h:1781:0,
                 from /apps/lib/python/Python-2.7.2/lib/python2.7/site-packages/numpy/core/include/numpy/ndarrayobject.h:18,
                 from /home/luxy/Yade/trunk/py/_utils.hpp:14,
                 from /home/luxy/Yade/trunk/py/_utils.cpp:1:
/apps/lib/python/Python-2.7.2/lib/python2.7/site-packages/numpy/core/include/numpy/npy_1_7_deprecated_api.h:15:2: warning: #warning "Using deprecated NumPy API, disable it by " "#defining NPY_NO_DEPRECATED_API NPY_1_7_API_VERSION" [-Wcpp]
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp: In function 鈜oid termHandlerNormal(int)?
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:474:73: error: 釹IGTERM?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:474:80: error: 鈘aise?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp: In function 鈜oid termHandlerError(int)?
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:475:71: error: 釹IGTERM?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:475:78: error: 鈘aise?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp: In member function 鈜oid pyOmega::disableGdb()?
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:731:10: error: 釹IGSEGV?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:731:18: error: 釹IG_DFL?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:731:25: error: 鈙ignal?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:732:10: error: 釹IGABRT?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp: In member function 鈜oid pyOmega::exitNoBacktrace(int)?
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:735:24: error: 釹IGSEGV?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:735:49: error: 鈙ignal?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:736:15: error: 釹IGSEGV?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:736:39: error: 鈙ignal?was not declared in this scope
make[2]: *** [py/CMakeFiles/wrapper.dir/wrapper/yadeWrapper.cpp.o] Error 1
make[1]: *** [py/CMakeFiles/wrapper.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 99%] Linking CXX shared library lib64/_customConverters.so
[ 99%] Built target _customConverters
[ 99%] Linking CXX shared library lib64/_utils.so
[ 99%] Built target _utils
make: *** [all] Error 2

[luxy@ln1 build]$ make install
[ 89%] Built target yade
[ 90%] Built target boot
[ 91%] Built target WeightedAverage2d
[ 92%] Built target _customConverters
[ 93%] Built target _packObb
[ 94%] Built target _packPredicates
[ 96%] Built target _packSpheres
[ 97%] Built target _polyhedra_utils
[ 98%] Built target _utils
[ 99%] Building CXX object py/CMakeFiles/wrapper.dir/wrapper/yadeWrapper.cpp.o
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp: In function 鈜oid termHandlerNormal(int)?
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:474:73: error: 釹IGTERM?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:474:80: error: 鈘aise?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp: In function 鈜oid termHandlerError(int)?
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:475:71: error: 釹IGTERM?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:475:78: error: 鈘aise?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp: In member function 鈜oid pyOmega::disableGdb()?
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:731:10: error: 釹IGSEGV?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:731:18: error: 釹IG_DFL?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:731:25: error: 鈙ignal?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:732:10: error: 釹IGABRT?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp: In member function 鈜oid pyOmega::exitNoBacktrace(int)?
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:735:24: error: 釹IGSEGV?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:735:49: error: 鈙ignal?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:736:15: error: 釹IGSEGV?was not declared in this scope
/home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp:736:39: error: 鈙ignal?was not declared in this scope
make[2]: *** [py/CMakeFiles/wrapper.dir/wrapper/yadeWrapper.cpp.o] Error 1
make[1]: *** [py/CMakeFiles/wrapper.dir/all] Error 2
make: *** [all] Error 2

flomine (flomine) said : #6

Hi Hanzj,
I had a similar issue on archlinux.
Try to had
   #include <csignal>
at the beginning of /home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp

hanzj (hanzj14) said : #7

hello,flomine and all,

thank you for your reply,It works,it can make install and finished well , but after install I can not use yade
the error as follows:
[luxy@ln1 bin]$ ./yade
Welcome to Yade 2016.06a
Traceback (most recent call last):
  File "./yade", line 129, in <module>
    import yade
  File "/home/luxy/Yade/install/lib64/yade/py/yade/__init__.py", line 65, in <module>
    import boot
ImportError: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /home/luxy/Yade/install/lib64/yade/py/yade/boot.so)

have you come across that?

At 2017-01-19 18:57:52, "flomine" <email address hidden> wrote:
>Question #432848 on Yade changed:
>https://answers.launchpad.net/yade/+question/432848
>
> Status: Open => Answered
>
>flomine proposed the following answer:
>Hi Hanzj,
>I had a similar issue on archlinux.
>Try to had
> #include <csignal>
>at the beginning of /home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp
>
>--
>You received this question notification because your team yade-users is
>an answer contact for Yade.
>
>_______________________________________________
>Mailing list: https://launchpad.net/~yade-users
>Post to : <email address hidden>
>Unsubscribe : https://launchpad.net/~yade-users
>More help : https://help.launchpad.net/ListHelp

Anton Gladky (gladky-anton) said : #8

Hi,

missing header was added. Thanks. It would be good to get
a feedback from people, using different OSs and (better)
pull request.

It looks like the you have some path problems. There are some
info here [1].

[1] http://stackoverflow.com/questions/5216399/usr-lib-libstdc-so-6-version-glibcxx-3-4-15-not-found

Regards

Anton

2017-01-19 13:57 GMT+01:00 hanzj <email address hidden>:
> Question #432848 on Yade changed:
> https://answers.launchpad.net/yade/+question/432848
>
> Status: Answered => Open
>
> hanzj is still having a problem:
> hello,flomine and all,
>
> thank you for your reply,It works,it can make install and finished well , but after install I can not use yade
> the error as follows:
> [luxy@ln1 bin]$ ./yade
> Welcome to Yade 2016.06a
> Traceback (most recent call last):
> File "./yade", line 129, in <module>
> import yade
> File "/home/luxy/Yade/install/lib64/yade/py/yade/__init__.py", line 65, in <module>
> import boot
> ImportError: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /home/luxy/Yade/install/lib64/yade/py/yade/boot.so)
>
> have you come across that?
>
>
>
> At 2017-01-19 18:57:52, "flomine" <email address hidden> wrote:
>>Question #432848 on Yade changed:
>>https://answers.launchpad.net/yade/+question/432848
>>
>> Status: Open => Answered
>>
>>flomine proposed the following answer:
>>Hi Hanzj,
>>I had a similar issue on archlinux.
>>Try to had
>> #include <csignal>
>>at the beginning of /home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp
>>
>>--
>>You received this question notification because your team yade-users is
>>an answer contact for Yade.
>>
>>_______________________________________________
>>Mailing list: https://launchpad.net/~yade-users
>>Post to : <email address hidden>
>>Unsubscribe : https://launchpad.net/~yade-users
>>More help : https://help.launchpad.net/ListHelp
>
> --
> You received this question notification because your team yade-users is
> an answer contact for Yade.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~yade-users
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~yade-users
> More help : https://help.launchpad.net/ListHelp

hanzj (hanzj14) said : #9

Hello,Anton and all,
I adjust my LD_LIBRARY_PATH by "export LD_LIBRARY_PATH=/apps/lib/gcc-4.7.1/lib64:/usr/lib64:$LD_LIBRARY_PATH"
and then I run ./yade, error occurred:

Welcome to Yade 2016.06a
Segmentation fault

How to debug?
any ideas?

best regards
Han Zhijian

At 2017-01-20 02:22:53, "Anton Gladky" <email address hidden> wrote:
>Question #432848 on Yade changed:
>https://answers.launchpad.net/yade/+question/432848
>
> Status: Open => Answered
>
>Anton Gladky proposed the following answer:
>Hi,
>
>missing header was added. Thanks. It would be good to get
>a feedback from people, using different OSs and (better)
>pull request.
>
>It looks like the you have some path problems. There are some
>info here [1].
>
>[1] http://stackoverflow.com/questions/5216399/usr-lib-libstdc-so-6
>-version-glibcxx-3-4-15-not-found
>
>Regards
>
>Anton
>
>
>2017-01-19 13:57 GMT+01:00 hanzj <email address hidden>:
>> Question #432848 on Yade changed:
>> https://answers.launchpad.net/yade/+question/432848
>>
>> Status: Answered => Open
>>
>> hanzj is still having a problem:
>> hello,flomine and all,
>>
>> thank you for your reply,It works,it can make install and finished well , but after install I can not use yade
>> the error as follows:
>> [luxy@ln1 bin]$ ./yade
>> Welcome to Yade 2016.06a
>> Traceback (most recent call last):
>> File "./yade", line 129, in <module>
>> import yade
>> File "/home/luxy/Yade/install/lib64/yade/py/yade/__init__.py", line 65, in <module>
>> import boot
>> ImportError: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /home/luxy/Yade/install/lib64/yade/py/yade/boot.so)
>>
>> have you come across that?
>>
>>
>>
>> At 2017-01-19 18:57:52, "flomine" <email address hidden> wrote:
>>>Question #432848 on Yade changed:
>>>https://answers.launchpad.net/yade/+question/432848
>>>
>>> Status: Open => Answered
>>>
>>>flomine proposed the following answer:
>>>Hi Hanzj,
>>>I had a similar issue on archlinux.
>>>Try to had
>>> #include <csignal>
>>>at the beginning of /home/luxy/Yade/trunk/py/wrapper/yadeWrapper.cpp
>>>
>>>--
>>>You received this question notification because your team yade-users is
>>>an answer contact for Yade.
>>>
>>>_______________________________________________
>>>Mailing list: https://launchpad.net/~yade-users
>>>Post to : <email address hidden>
>>>Unsubscribe : https://launchpad.net/~yade-users
>>>More help : https://help.launchpad.net/ListHelp
>>
>> --
>> You received this question notification because your team yade-users is
>> an answer contact for Yade.
>>
>> _______________________________________________
>> Mailing list: https://launchpad.net/~yade-users
>> Post to : <email address hidden>
>> Unsubscribe : https://launchpad.net/~yade-users
>> More help : https://help.launchpad.net/ListHelp
>
>--
>You received this question notification because your team yade-users is
>an answer contact for Yade.
>
>_______________________________________________
>Mailing list: https://launchpad.net/~yade-users
>Post to : <email address hidden>
>Unsubscribe : https://launchpad.net/~yade-users
>More help : https://help.launchpad.net/ListHelp

Klaus Thoeni (klaus.thoeni) said : #10

Have you tried to compile with cmake option -DDEBUG=1?

HTH
Klaus

hanzj (hanzj14) said : #11

hello ,Thoeni and all:
Yeah,
I try that.
1)here is my cmake
cmake -DCMAKE_INSTALL_PREFIX=../install ../trunk -DNOSUFFIX=ON -DCMAKE_C_COMPILER=/apps/lib/gcc-4.7.1/bin/gcc -DCMAKE_CXX_COMPILER=/apps/lib/gcc-4.7.1/bin/g++ -DDEBUG=1 -DENABLE_GUI=OFF -DENABLE_CGAL=OFF -DENABLE_GTS=OFF -DBOOST_ROOT=/apps/lib/boost_1_54_0 -Dboost_INCLUDE_DIRS=/apps/lib/boost_1_54_0/include -Dboost_LIBRARY_DIRS=/apps/lib/boost_1_54_0/lib -DENABLE_GTS=OFF -DENABLE_GL2PS=OFF -DENABLE_GUI=OFF -DEIGEN3_INCLUDE_DIR=/apps/lib/eigen/eigen-eigen-36fd1ba04c12 -DENABLE_VTK=OFF

is the -DDEBUG=1, right?

2)Another information is that I comment the cmakelist.txt minieigen and tkinter to make the compilation succeed. can I do that ?

3)and the make stage as follows:
-- Version is set to 2016.06a
-- GSL using pkgconfig
-- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig
-- PKGCONFIG() indicates that gts is not installed (install the package which contains gts.pc if you want to support this feature)
FindGTS.cmake: gts-config/pkg-config gts not found. Please set it manually. GTS_CONFIG=GTS_CONFIG-NOTFOUND
-- ERROR: GTS was not found.
-- Could NOT find GL2PS (missing: GL2PS_LIBRARY GL2PS_INCLUDE_DIR)
-- CGAL not found.
-- Boost version: 1.54.0
-- Found the following Boost libraries:
-- python
-- thread
-- filesystem
-- iostreams
-- regex
-- serialization
-- system
-- date_time
-- Boost_VERSION: 105400
-- Boost_LIB_VERSION: 1_54
-- Boost_INCLUDE_DIRS: /apps/lib/boost_1_54_0/include
-- Boost_LIBRARIES: /apps/lib/boost_1_54_0/lib/libboost_python.so/apps/lib/boost_1_54_0/lib/libboost_thread.so/apps/lib/boost_1_54_0/lib/libboost_filesystem.so/apps/lib/boost_1_54_0/lib/libboost_iostreams.so/apps/lib/boost_1_54_0/lib/libboost_regex.so/apps/lib/boost_1_54_0/lib/libboost_serialization.so/apps/lib/boost_1_54_0/lib/libboost_system.so/apps/lib/boost_1_54_0/lib/libboost_date_time.so
-- Found Eigen3, version: 3.2.3
-- Disable vectorization
-- Found OpenMP
-- PFVFLOW depends on CGAL, attempting to turn ENABLE_CGAL ON
-- GMP libs: /usr/lib64/libgmp.so /usr/lib64/libgmpxx.so
-- CGAL not found.
-- GMP libs: /usr/lib64/libgmp.so /usr/lib64/libgmpxx.so
-- CGAL NOT found
-- CGAL NOT found: PFVFLOW disabled
-- Could NOT find Cholmod (missing: CHOLMOD_LIBRARIES CHOLMOD_INCLUDE_DIR AMD_LIBRARY CAMD_LIBRARY COLAMD_LIBRARY CCOLAMD_LIBRARY)
-- Could NOT find OpenBlas (missing: OPENBLAS_LIBRARY)
-- Could NOT find Metis (missing: METIS_INCLUDE_DIR METIS_LIBRARY)
-- Missing dependency for LINSOLV, disabled
LBMFLOW is still experimental, building and running LBM engine are at your own risk!
Yade will be installed to /home/luxy/Yade/install
-- Suffix is set to
-- LIBRARY_OUTPUT_PATH is set to lib64
-- runtimePREFIX is set to /home/luxy/Yade/install
-- ===========================================================
-- Yade configured with following features: Odeint OpenMP LBMFLOW
-- Disabled features: VTK GTS GUI CGAL PFVFLOW LINSOLV SPH LIQMIGRATION GL2PS MASK_ARBITRARY PROFILING PotentialParticles
-- Debug build
-- ===========================================================
-- Configuring done
-- Generating done
-- Build files have been written to: /home/luxy/Yade/build

is the build stage, ok?

4)after build and installation I try ./yade -h I can not find how to use debug mode.
like:
--no-gdb Do not show backtrace when yade crashes (only effec-
tive with –debug)
and try ./yade it occurred :segmentation fault.
[luxy@ln1 bin]$ ./yade -h
usage: yade [options] [ simulation.xml[.bz2] | script.py [script options]]

Yade: open-source platform for dynamic compuations. It is an extensible open-
source framework for discrete numerical models, focused on Discrete Element
Method. The computation parts are written in c++ using flexible object model,
allowing independent implementation of new algorithms and interfaces. Python
is used for rapid and concise scene construction, simulation control,
postprocessing and debugging. Available features: ['Odeint', 'OpenMP',
'LBMFLOW']. Homepage http://www.yade-dem.org, code hosted at
http://www.launchpad.net/yade.

optional arguments:
  -h, --help show this help message and exit
  -v, --version Print version and exit.
  -j THREADS, --threads THREADS
                        Number of OpenMP threads to run; defaults to 1.
                        Equivalent to setting OMP_NUM_THREADS environment
                        variable.
  --cores CORES Set number of OpenMP threads (as \-\-threads) and in
                        addition set affinity of threads to the cores given.
                        Please provide a string with comma-separated core-ids.
  --update UPDATESCRIPTS [UPDATESCRIPTS ...]
                        Update deprecated class names in given script(s) using
                        text search & replace. Changed files will be backed up
                        with ~ suffix. Exit when done without running any
                        simulation.
  --nice NICE Increase nice level (i.e. decrease priority) by given
                        number.
  -x Exit when the script finishes
  -n Run without graphical interface (equivalent to
                        unsetting the DISPLAY environment variable)
  --test Run regression test suite and exit; the exists status
                        is 0 if all tests pass, 1 if a test fails and 2 for an
                        unspecified exception.
  --checks Run a series of user-defined check tests as described
                        in /yade/scripts/checks-and-tests/checks/README
  --performance Starts a test to measure the productivity
  -l IMPLIBRARIES import libraries at startup before importing yade
                        libs. May be used when the ordering of imports matter
                        (see e.g. https://bugs.launchpad.net/yade/+bug/1183402
                        /comments/3). The option can be use multiple times, as
                        in "yade -llib1 -llib2"

I find somebody else come across kind of thing ,like:
[1]https://answers.launchpad.net/yade/+question/294790

I do not have the total administrator privilege so I have to set the path. It is a bit tough for me.
So if bother you, I feel sorry.
Thank you very much.

Han Zhijian

At 2017-01-20 10:03:49, "Klaus Thoeni" <email address hidden> wrote:
>Your question #432848 on Yade changed:
>https://answers.launchpad.net/yade/+question/432848
>
> Status: Open => Answered
>
>Klaus Thoeni proposed the following answer:
>Have you tried to compile with cmake option -DDEBUG=1?
>
>HTH
>Klaus
>
>--
>If this answers your question, please go to the following page to let us
>know that it is solved:
>https://answers.launchpad.net/yade/+question/432848/+confirm?answer_id=9
>
>If you still need help, you can reply to this email or go to the
>following page to enter your feedback:
>https://answers.launchpad.net/yade/+question/432848
>
>You received this question notification because you asked the question.

Anton Gladky (gladky-anton) said : #12

Debug mode just means that the debug-symbols will not
be stripped. So, before the crash you should get some
stacktrace in the console. There is no special command
line option for debugging.

Anton

hanzj (hanzj14) said : #13

hello,Anton,
I can not see anything but directly segmentation fault and Yade crashed soon,it is weird.is there something like error.log for me to refer to after it crashed?

> 在 2017年1月21日,上午1:17,Anton Gladky <email address hidden> 写道:
>
> Question #432848 on Yade changed:
> https://answers.launchpad.net/yade/+question/432848
>
> Status: Open => Answered
>
> Anton Gladky proposed the following answer:
> Debug mode just means that the debug-symbols will not
> be stripped. So, before the crash you should get some
> stacktrace in the console. There is no special command
> line option for debugging.
>
> Anton
>
> --
> You received this question notification because your team yade-users is
> an answer contact for Yade.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~yade-users
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~yade-users
> More help : https://help.launchpad.net/ListHelp

Hi,
You are probably not running the debug build if you don't see more output.
Bruno

Can you help with this problem?

Provide an answer of your own, or ask hanzj for more information if necessary.

To post a message you must log in.