on capillary triaxial test

Asked by wangxiaoliang on 2011-11-28

Hello all:

I have tested the code Capillary-Phys-example.py in http://bazaar.launchpad.net/~yade-dev/yade/trunk/files/head:/examples/;

However, yade tells me that Law2_ScGeom_CapillaryPhys_Capillarity(CapillaryPressure=10000,hertzOn=False),#for linear model only
AttributeError: No such attribute: hertzOn.

I found hertzOn is false in default, so I delete "hertzOn=false",

however, yade tells me that " WARNING: cannot open files used for capillary law, all forces will be null. Instructions on how to download and install them is found here : https://yade-dem.org/wiki/CapillaryTriaxialTest."
by the way, I have already extracted the 10 m files into my yade/bin folder.

what's problem

Question information

Language:
English Edit question
Status:
Solved
For:
Yade Edit question
Assignee:
No assignee Edit question
Solved by:
wangxiaoliang
Solved:
2011-11-30
Last query:
2011-11-30
Last reply:
2011-11-28
wangxiaoliang (wangxiaoliang) said : #1

By the way, I am using yade0.70

Christian Jakob (jakob-ifgt) said : #2

1.) i think this hertzOn bool is not included in yade 0.7, not sure
2.) you have to execute yade from the folder where the 10 files are, so cd to this directory and try to execute again.

christian

wangxiaoliang (wangxiaoliang) said : #3

Which version of yade has the option of hertzOn?

Second one, if delete the hertzOn, and copy the 10 files into my Python script, it runs. thanks , Christian

Christian Jakob (jakob-ifgt) said : #4

hertzOn was implemented in trunk version bzr-2956, but it is better to use the new version (bzr-2971).
Use

bzr checkout lp:yade

to download the newest trunk version.
You can find installation details for source code version here:

https://yade-dem.org/doc/installation.html

christian

Jérôme Duriez (jduriez) said : #5

" Which version of yade has the option of hertzOn? "

See http://bazaar.launchpad.net/~yade-dev/yade/trunk/revision/2955#pkg/dem/Law2_ScGeom_CapillaryPhys_Capillarity.hpp (reached from http://bazaar.launchpad.net/~yade-dev/yade/trunk/view/head:/pkg/dem/Law2_ScGeom_CapillaryPhys_Capillarity.hpp, then little search beginning by "View changes to this file")

=> revisions >= 2955 !

Bzr and launchpad are wonderful, isn't it ? ;-)

wangxiaoliang (wangxiaoliang) said : #6

Thanks , Christian, when I tried your advice, I found install error below
scons: Reading SConscript files ...

scons: *** Error writing options to file: scons.current-profile
[Errno 13] Permission denied: 'scons.current-profile'
File "/home/michael/yade2971/yade/SConstruct", line 64, in <module>

How can I deal with that, Thanks

Christian Jakob (jakob-ifgt) said : #7

The problem is, that you downloaded the code as root, so you (as user) have no permissions on that folder.

Type as root:

chmod -R 777 ~/yade2971/

then try to install yade again as user, not as root!

wangxiaoliang (wangxiaoliang) said : #8

thanks, Christian, my problem is solved