QGLViewer qt4 problem debian

Asked by Christian Jakob on 2011-04-16

Hello again,

 Now I try to install yade on debian lenny.
 This time I get an error with qglviewer and qt4 while compiling yade.

me@debian $ scons
 scons: Reading SConscript files ...
 @@@ Using profile default (scons.profile-default) @@@
 Eigen 3 math library will be used
 Yade version is `bzr2818' (bzr2818), installed files will be suffixed with
 `-bzr2818'.
 All intermediary files will be in
 `/home/eumel/neu-reingekommen/build-bzr2818'.
 Checking whether c++ compiler "g++" works...yes
 Finding libstdc++ library... (cached) /usr/lib/libstdc++.so.6
 Checking for pthread_exit(NULL) in C library pthread... yes
 Checking for Python development files... ok
 Checking for C++ header file numpy/ndarrayobject.h... yes
 Checking for required python modules... (cached) all ok
 Checking boost libraries... all ok
 Checking for C++ header file boost/foreach.hpp... yes
 Checking for C++ header file Eigen/Core... yes
 Checking for C++ header file loki/NullType.h... yes
 Checking for glutGetModifiers() in C++ library glut... yes
 Checking for QGLViewer() in C++ library qglviewer-qt4... no
 Checking for QGLViewer() in C++ library libQGLViewer... no

 ERROR: Unable to compile with optional feature `qt4'.

 If you are sure, remove it from features (scons
 features=featureOne,featureTwo for example) and build again.
 Note: Building with Qt4 implies the QGLViewer library installed (package
 libqglviewer-qt4-dev package in debian/ubuntu, libQGLViewer in RPM-based
 distributions)

root@debian # find /usr/lib -name *glviewer*
 /usr/lib/libqglviewer.a
 /usr/lib/libqglviewer.so.2.2
 /usr/lib/libqglviewer.prl
 /usr/lib/libqglviewer.so.2
 /usr/lib/libqglviewer.so
 /usr/lib/libqglviewer.so.2.2.6

root@debian # aptitude search libqgl
 i libqglviewer-dev
 i A libqglviewer2

 config.log said:

 /usr/bin/ld: error: cannot find -lQGLViewer

 To solve this problem I tried this:

root@debian # ln -s /usr/lib/libqglviewer.so /usr/lib/libQGLViewer.so
root@debian # ln -s /usr/lib/libqglviewer.so /usr/lib/libQGLViewer-qt4.so
root@debian # ln -s /usr/lib/libqglviewer.so /usr/lib/libqglviewer-qt4.so

 But it doesn't solve the problem. It only changed the error message in
 config.log to:

 error: undefined reference to 'QGLViewer::QGLViewer(QWidget*, QGLWidget
 const*, QFlags<Qt::WindowType>)'

 Cheers,

 Christian.

Question information

Language:
English Edit question
Status:
Answered
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-16
Last reply:
2011-04-18
Anton Gladky (gladky-anton) said : #1

Hi,

libqglviewer-dev and libqglviewer2 are QT3-oriented [1] and [2], but Yade uses QT4. That is why you have to use libqglviewer-qt4-dev and libqglviewer-qt4-2 instead, which are not in repos of Lenny [3] and [4]. You can try to install it separately.

> Eigen 3 math library will be used
Do you have eigen3 in your system?

Anton

[1] http://packages.debian.org/lenny/libqglviewer-dev
[2] http://packages.debian.org/lenny/libqglviewer2
[3] http://packages.debian.org/search?keywords=libqglviewer-qt4-dev
[4] http://packages.debian.org/search?keywords=libqglviewer-qt4-2

Christian Jakob (jakob-ifgt) said : #2

root@debian # dpkg -i libqglviewer-qt4-2_2.3.4-4_i386.deb

(Reading database ... 218004 files and directories currently installed.)
Preparing to replace libqglviewer-qt4-2 2.3.4-4 (using libqglviewer-qt4-2_2.3.4-
4_i386.deb) ...
Unpacking replacement libqglviewer-qt4-2 ...
Setting up libqglviewer-qt4-2 (2.3.4-4) ...

... everthing seems ok ...

root@debian # dpkg -i libqglviewer-qt4-dev_2.3.4-4_i386.deb
Selecting previously deselected package libqglviewer-qt4-dev.
(Reading database ... 218004 files and directories currently installed.)
Unpacking libqglviewer-qt4-dev (from libqglviewer-qt4-dev_2.3.4-4_i386.deb) ...
dpkg: dependency problems prevent configuration of libqglviewer-qt4-dev:
 libqglviewer-qt4-dev depends on libqglviewer-dev-common (= 2.3.4-4); however:
  Package libqglviewer-dev-common is not installed.
 libqglviewer-qt4-dev depends on libqt4-dev; however:
  Package libqt4-dev is not installed.
 libqglviewer-qt4-dev depends on libqt4-opengl-dev; however:
  Package libqt4-opengl-dev is not installed.
dpkg: error processing libqglviewer-qt4-dev (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libqglviewer-qt4-dev

... not nice, but ok, let's try install some more packages ...

root@debian # aptitude install libqglviewer-dev-common libqt4-dev libqt4-opengl-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
The following packages are BROKEN:
  libqglviewer-dev-common
The following NEW packages will be installed:
  libphonon4{a} libpulse-mainloop-glib0{a} libqt4-assistant{a} libqt4-dev
  libqt4-help{a} libqt4-multimedia{a} libqt4-opengl-dev
  libqt4-scripttools{a} libqt4-svg{a} libqt4-test{a} libqt4-webkit{a}
  libqt4-xmlpatterns{a} qt4-qmake{a}
The following packages will be REMOVED:
  python-qt4-common{u}
The following packages will be upgraded:
  libpulse0
The following partially installed packages will be configured:
  libqglviewer-qt4-dev
1 packages upgraded, 14 newly installed, 1 to remove and 1397 not upgraded.
Need to get 7154kB/18.7MB of archives. After unpacking 65.1MB will be used.
The following packages have unmet dependencies:
  libqglviewer-dev-common: Conflicts: libqglviewer-dev (< 2.3.1-4~) but 2.2.6-3-
3 is installed and it is kept back.
The following actions will resolve these dependencies:

Remove the following packages:
libqglviewer-dev

Score is 119

Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
  libphonon4{a} libpulse-mainloop-glib0{a} libqglviewer-dev-common
  libqt4-assistant{a} libqt4-dev libqt4-help{a} libqt4-multimedia{a}
  libqt4-opengl-dev libqt4-scripttools{a} libqt4-svg{a} libqt4-test{a}
  libqt4-webkit{a} libqt4-xmlpatterns{a} qt4-qmake{a}
The following packages will be REMOVED:
  libaudio-dev{u} libcups2-dev{u} libcupsys2-dev{u} libfontconfig1-dev{u}
  libfreetype6-dev{u} libgcrypt11-dev{u} libgnutls-dev{u}
  libgpg-error-dev{u} libjpeg62-dev{u} liblcms1-dev{u} libmng-dev{u}
  libpng12-dev{u} libqglviewer-dev{a} libqglviewer2{u}
  libqt3-compat-headers{u} libqt3-headers{u} libqt3-mt-dev{u}
  libtasn1-3-dev{u} libxcursor-dev{u} libxfixes-dev{u} libxft-dev{u}
  libxi-dev{u} libxinerama-dev{u} libxrandr-dev{u} libxrender-dev{u}
  python-qt4-common{u} qt3-dev-tools{u} x11proto-fixes-dev{u}
  x11proto-xinerama-dev{u}
The following packages will be upgraded:
  libpulse0
The following partially installed packages will be configured:
  libqglviewer-qt4-dev
1 packages upgraded, 14 newly installed, 29 to remove and 1372 not upgraded.
Need to get 7154kB/18.7MB of archives. After unpacking 36.3MB will be used.
Do you want to continue? [Y/n/?] n
Abort.

... No this is not really a good solution!

Maybe I should upgrade to Squeeze?! ...

Anyone another idea?

Regards,

Christian.

Anton Gladky (gladky-anton) said : #3

Hi,

I think the better solution would be to install yade at least on
Debian Squeeze. Better on "testing".

Probably libqglviewer-qt4-2 has some dependency problems with Lenny.

Anton

On Sun, Apr 17, 2011 at 1:59 PM, Christian Jakob
<email address hidden> wrote:
> Question #153100 on Yade changed:
> https://answers.launchpad.net/yade/+question/153100
>
> Christian Jakob posted a new comment:
> root@debian # dpkg -i libqglviewer-qt4-2_2.3.4-4_i386.deb
>
> (Reading database ... 218004 files and directories currently installed.)
> Preparing to replace libqglviewer-qt4-2 2.3.4-4 (using libqglviewer-qt4-2_2.3.4-
> 4_i386.deb) ...
> Unpacking replacement libqglviewer-qt4-2 ...
> Setting up libqglviewer-qt4-2 (2.3.4-4) ...
>
> ... everthing seems ok ...
>
> root@debian # dpkg -i libqglviewer-qt4-dev_2.3.4-4_i386.deb
> Selecting previously deselected package libqglviewer-qt4-dev.
> (Reading database ... 218004 files and directories currently installed.)
> Unpacking libqglviewer-qt4-dev (from libqglviewer-qt4-dev_2.3.4-4_i386.deb) ...
> dpkg: dependency problems prevent configuration of libqglviewer-qt4-dev:
>  libqglviewer-qt4-dev depends on libqglviewer-dev-common (= 2.3.4-4); however:
>  Package libqglviewer-dev-common is not installed.
>  libqglviewer-qt4-dev depends on libqt4-dev; however:
>  Package libqt4-dev is not installed.
>  libqglviewer-qt4-dev depends on libqt4-opengl-dev; however:
>  Package libqt4-opengl-dev is not installed.
> dpkg: error processing libqglviewer-qt4-dev (--install):
>  dependency problems - leaving unconfigured
> Errors were encountered while processing:
>  libqglviewer-qt4-dev
>
> ... not nice, but ok, let's try install some more packages ...
>
> root@debian # aptitude install libqglviewer-dev-common libqt4-dev libqt4-opengl-dev
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Reading extended state information
> Initializing package states... Done
> Writing extended state information... Done
> The following packages are BROKEN:
>  libqglviewer-dev-common
> The following NEW packages will be installed:
>  libphonon4{a} libpulse-mainloop-glib0{a} libqt4-assistant{a} libqt4-dev
>  libqt4-help{a} libqt4-multimedia{a} libqt4-opengl-dev
>  libqt4-scripttools{a} libqt4-svg{a} libqt4-test{a} libqt4-webkit{a}
>  libqt4-xmlpatterns{a} qt4-qmake{a}
> The following packages will be REMOVED:
>  python-qt4-common{u}
> The following packages will be upgraded:
>  libpulse0
> The following partially installed packages will be configured:
>  libqglviewer-qt4-dev
> 1 packages upgraded, 14 newly installed, 1 to remove and 1397 not upgraded.
> Need to get 7154kB/18.7MB of archives. After unpacking 65.1MB will be used.
> The following packages have unmet dependencies:
>  libqglviewer-dev-common: Conflicts: libqglviewer-dev (< 2.3.1-4~) but 2.2.6-3-
> 3 is installed and it is kept back.
> The following actions will resolve these dependencies:
>
> Remove the following packages:
> libqglviewer-dev
>
> Score is 119
>
> Accept this solution? [Y/n/q/?] y
> The following NEW packages will be installed:
>  libphonon4{a} libpulse-mainloop-glib0{a} libqglviewer-dev-common
>  libqt4-assistant{a} libqt4-dev libqt4-help{a} libqt4-multimedia{a}
>  libqt4-opengl-dev libqt4-scripttools{a} libqt4-svg{a} libqt4-test{a}
>  libqt4-webkit{a} libqt4-xmlpatterns{a} qt4-qmake{a}
> The following packages will be REMOVED:
>  libaudio-dev{u} libcups2-dev{u} libcupsys2-dev{u} libfontconfig1-dev{u}
>  libfreetype6-dev{u} libgcrypt11-dev{u} libgnutls-dev{u}
>  libgpg-error-dev{u} libjpeg62-dev{u} liblcms1-dev{u} libmng-dev{u}
>  libpng12-dev{u} libqglviewer-dev{a} libqglviewer2{u}
>  libqt3-compat-headers{u} libqt3-headers{u} libqt3-mt-dev{u}
>  libtasn1-3-dev{u} libxcursor-dev{u} libxfixes-dev{u} libxft-dev{u}
>  libxi-dev{u} libxinerama-dev{u} libxrandr-dev{u} libxrender-dev{u}
>  python-qt4-common{u} qt3-dev-tools{u} x11proto-fixes-dev{u}
>  x11proto-xinerama-dev{u}
> The following packages will be upgraded:
>  libpulse0
> The following partially installed packages will be configured:
>  libqglviewer-qt4-dev
> 1 packages upgraded, 14 newly installed, 29 to remove and 1372 not upgraded.
> Need to get 7154kB/18.7MB of archives. After unpacking 36.3MB will be used.
> Do you want to continue? [Y/n/?] n
> Abort.
>
> ... No this is not really a good solution!
>
> Maybe I should upgrade to Squeeze?! ...
>
> Anyone another idea?
>
>
> Regards,
>
> Christian.
>
> --
> You received this question notification because you are a member of
> yade-users, which is an answer contact for Yade.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~yade-users
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~yade-users
> More help   : https://help.launchpad.net/ListHelp
>

Can you help with this problem?

Provide an answer of your own, or ask Christian Jakob for more information if necessary.

To post a message you must log in.