Capillay triaxial test

Asked by Latifa El Ghezal on 2011-03-03

Hello,

I'm trying to use Capillary triaxial test on yade 0.50, with generating sample. I affected a value to Capillary Pressure, but no capillary forces were generated.
I want ask you, what should I do to generate capillary forces within the sample ?

Best regards,

Question information

Language:
English Edit question
Status:
Solved
For:
Yade Edit question
Assignee:
No assignee Edit question
Solved by:
Bruno Chareyre
Solved:
2011-03-04
Last query:
2011-03-04
Last reply:
2011-03-04
Emanuele Catalano (catalano) said : #1

Hello Latifa,
did you visit https://yade-dem.org/wiki/CapillaryTriaxialTest ?

There you'll find some instructions to make capillary forcs be computed:
[...]
To run the simulations, you have to download this File:Capillary.gz and extract the content to your yade/bin folder (where the yade executable is). You should end with 10 text files in /bin. CapillaryLaw will read those files once at startup and use the data to interpolate capillary forces for arbitrary cases.

Cordially.

Hello Emanuele,

Thank you for reply
I followed this instructions, I generated a sample using CapillaryTriaxialTest, but reading the Capillarystresses file, there is no capillary stresses generated. Do you think, that can be due to the grain size. Should I use small grains.

Best regard,

Hi,

If the capillary stress and output succion are null, it is because
either the input succion (capillaryPressure) is too high (liquid bonds
are all broken) or too low (the sample is almost saturated).
With the particles sizes we have in the default example, it needs a very
low succion to get meniscii. I just tried with 100Pa, it works. It also
means you get a very small capillary stress (~1Pa!) and negligeable
effect on stress-strain behaviour. Although it is physicaly correct with
spheres diameters of 5cm, it is probably not what you want.
So, yes, you should generate smaller grains.

... and I'll change the default size eventually...

Bruno

It is always interesting to know when one finds someone else's work
usefull. Please send us an email to yade-users if you plan to use the
capillary law, so we can get your email and discuss more.

Bruno

Hi, thank you for your answer. I will try it.

Could I have an e-mail to send you details about my work.

My e-mail is : <email address hidden> or <email address hidden>

Hello,

I opened a generator file, I kept everything by default. I changed only, Capillary Pressure (set equal to 100 Pa) and made internalcompaction True. A sample was generated, ans when simulation was stopped, in the Capillarystresses all values of stresses are equal to zero an same thing for uc and Sr. Are these results normal ?

Best regards

No, it is not normal. Did you look at the end of the file? (the recorder
is appending, not overwriting files)

Yes, I wait for the end of the simulation, and I checked until the last line of the file.

That is strange. I reproduced your procedure here with yade-0.60,
yade-0.50, yade-bzr2766, and it worked in all cases.
Are you sure you have the unzipped capillary files in the working directory?
Thanks for info!

Hello,
I did the same thing with yade-bzr2747, in the bin directory I have the 10 files and when I generate the sample, I have this warning :"WARNING: cannot open files used for capillary law, all forces will be null. Instructions on how to download and install them is found here : https://yade-dem.org/wiki/CapillaryTriaxialTest."
I had this warning with yade0.50 but depending on capillary pressure value and grain size.

Best regards,

Are you in the bin directory when you start yade? It should look like:
.../bin$ ./yade-bzr2747
If you start yade from a different directory, then the files should be in this working dir.

Thanks Chareyre, that solved my question.