not working on 64-bit

Asked by Sadi Yumuşak on 2012-10-08

I have installed Y PPA Manager on a 32-bit Ubuntu, which has been working very well, and recently on a 54-bit Ubuntu, which refuses to work, starting with "Search in all Launchpad PPAs" which is my most frequently used command.
For example, when I enter "chromium" I get a long list in 32-bit Ubuntu, but a blank window in 64-bit Ubuntu.
Error messages in the Terminal screen are:

grep: +ppas?name_filter=chromium: No such file or directory
grep: +ppas?name_filter=chromium: No such file or directory
grep: +ppas?name_filter=chromium: No such file or directory
paste: .y_ppas_status_regular: No such file or directory

I wonder if I'm missing something or if this indicates a bug.

Question information

Language:
English Edit question
Status:
Solved
For:
Y PPA Manager Edit question
Assignee:
No assignee Edit question
Solved by:
Sadi Yumuşak
Solved:
2012-10-09
Last query:
2012-10-09
Last reply:
Alin Andrei (nilarimogard) said : #1

I'm using 64bit too and it's working just fine for me, it doesn't have anything to do with 64bit. Unfortunately, I can't reproduce this, maybe there was something wrong with your Internet connection or Launchpad was down? Does this still occur?

Alin Andrei (nilarimogard) said : #2

If it still occurs, please post the output of these commands:

wget -q https://launchpad.net/ubuntu/+ppas?name_filter=chromium
grep -A2 ppa_batch_row +ppas\?name_filter\=chromium | grep href | cut -c 18- | cut -d ">" -f 2 | sed -e 's/<\/a//g' -e 's/$/)/g' -e 's/^/(/g'
grep -A2 ppa_batch_row +ppas\?name_filter\="$SEARCH_PPA" | grep href | cut -c 18- | cut -d "\"" -f 1 | sed -e 's/\/+archive//g'

Sadi Yumuşak (sa-yu) said : #3

Thanks.
Here's the output:

sadi@SeS:~$ wget -q https://launchpad.net/ubuntu/+ppas?name_filter=chromium
sadi@SeS:~$ grep -A2 ppa_batch_row +ppas\?name_filter\=chromium | grep href | cut -c 18- | cut -d ">" -f 2 | sed -e 's/<\/a//g' -e 's/$/)/g' -e 's/^/(/g'
grep: +ppas?name_filter=chromium: No such file or directory
sadi@SeS:~$ grep -A2 ppa_batch_row +ppas\?name_filter\="$SEARCH_PPA" | grep href | cut -c 18- | cut -d "\"" -f 1 | sed -e 's/\/+archive//g'
grep: +ppas?name_filter=: No such file or directory

However, if I enter "https://launchpad.net/ubuntu/+ppas?name_filter=chromium" in the address bar I get a good list of relevant PPAs.

Alin Andrei (nilarimogard) said : #4

How about:
cat +ppas\?name_filter\=chromium

I think wget doesn't work for you. Do you use a proxy or are on a restricted network or something like that? That might be why it isn't working...

Sadi Yumuşak (sa-yu) said : #5

You're right!
The problem is with the command "wget -q https://launchpad.net/ubuntu/+ppas?name_filter=chromium"
I also tried it enclosing the URL between quotes, but nothing is downloaded!
I don't think there's a problem with wget because it manages to download with this command, for example:
wget -q http://www.ismeh.com/HOSTS
Or does it have a problem with https?

Sadi Yumuşak (sa-yu) said : #6

Yes, I've found it!
It will only work with the option "--no-check-certificate"
Why and what do I do now?

Sadi Yumuşak (sa-yu) said : #7

So this is a secure certification problem with https://launchpad.net (no problem with some other https site).
And I don't have this problem with my 32-bit Ubuntu system.
This is odd...

Sadi Yumuşak (sa-yu) said : #8

Yes, the problem has been solved now.
Apparently the certificate file "/usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt" had disappeared from my system with only 2 symlinks left in "/etc/ssl/certs".
Copying the file "ValiCert_Class_2_VA.crt" from the working system solved the problem.
Thanks for the guidance...

Sadi Yumuşak (sa-yu) said : #9

Yes, the problem has been solved now.
Apparently the certificate file "/usr/share/ca-certificates/mozilla/ValiCert_Class_2_VA.crt" had disappeared from my system with only 2 symlinks left in "/etc/ssl/certs".
Copying the file "ValiCert_Class_2_VA.crt" from the working system solved the problem.
Thanks for the guidance...

Alin Andrei (nilarimogard) said : #10

Thanks for the answer! To make sure nobody else bumps into this issue, I'll add "--no-check-certificate" in the next version!