Xpad not starting in Ubuntu 16.04

Asked by David Nagy on 2017-05-03

Have had Xpad (latest?) installed on Ubuntu 16.04 for a while. After some event (updates?), Xpad will no longer start. I run the Cinnamon desktop and have Xpad on my quick launch row at the bottom and clicking the icon (or starting from the menu) appears to be starting the application but nothing is showing on the screen or in the status area (where I used to see a yellow icon for Xpad).

If I have the system monitor running, I can see the program start but then it simply ends. I do not see any messages in the system log - Is there a log I should be checking for any messages relating to this?

This issue is still with me after reboot.

I have checked that my user has full r/w permission on ~/.config and ~/.config/xpad

Any suggestions on where to look for a cause of this will be appreciated.

If any additional info is requested, please ask!

Thanks,
Dave

Question information

Language:
English Edit question
Status:
Solved
For:
Xpad Edit question
Assignee:
No assignee Edit question
Solved by:
David Nagy
Solved:
2017-05-04
Last query:
2017-05-04
Last reply:
2017-05-04

Hi David,

Does Xpad start normally if you empty (or temporarily move all files from) the ~/.config/xpad folder ?

David Nagy (dalexnagy) said : #2

Hi, Arthur!

Yes, and to isolate which of the files in ~/.config/xpad was causing the problem, I moved them one-by-one, trying to start Xpad after each move, and found that a file called 'default-style' was the culprit. When removed, Xpad is running fine.

Here's the content of 'default-style':

decorations 1
height 200
width 200
confirm_destroy 1
edit_lock 0
sticky_on_start 0
tray_enabled 1
tray_click_configuration 1
back rgb(255,238,153)
use_back 1
text rgb(0,0,0)
use_text 1
fontname Sans 9
toolbar 1
auto_hide_toolbar 1
scrollbar 1
buttons New, Delete, Close, Properties, Undo
autostart_wait_systray 1
autostart_delay 0
autostart_new_pad 0
autostart_display_pads 1

If there's anything else I can provide to help solve whatever was causing the Xpad failure when this file was in the directory, please notify me.

Dave Nagy

Glad you have found the culprit.
Enjoy Xpad!