xpad trunk requires gtk+ 3.0

Asked by Mumia W. on 2014-01-09

During the configure, I get this:

> configure: error: Package requirements (gtk+-3.0 gio-2.0) were not met:
> No package 'gtk+-3.0' found
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
> Alternatively, you may set the environment variables GTK_CFLAGS
> and GTK_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> make: *** [config.status] Error 1

I am running Debian oldstable (Squeeze) which has gtk+ 2.0. How can I build xpad trunk without installing gtk+ 3.0?

Question information

English Edit question
Xpad Edit question
Arthur Borsboom Edit question
Solved by:
Mumia W.
Last query:
Last reply:

This question was reopened

Hi Mumia,

Xpad v4.3 is based on GTK3, so to build this version you do need GTK3. If you want to build with GTK2, you can use v4.2 which is based on GTK2.

Does this help you sufficiently?

Mumia W. (mumia-w-18) said : #2

Thanks Arthur Borsboom, that solved my question.

Mumia W. (mumia-w-18) said : #3

How do I get xpad 4.2 using bazaar?

I don't have bazaar at my disposal (I'm in Bolivia with a reeeeeeally slow Internet connection), but you might want to try this.

First look up the revision you want.
I believe xpad 4.2 is revision 669.

Then at the command line, try this:
bzr branch lp:xpad -r 669

Does this work for you?

Mumia W. (mumia-w-18) said : #5

Unfortunately no. Xpad also requires glib-2.0 >= 2.38 , but I have 2.24

Well, apparantly you were (somehow) able to get v4.2, but as you said correctly there is a dependency on glib v2.38.

Please let me know, if I can help you more.
If not, I will close this question as answered (though not solved for you).


Mumia W. (mumia-w-18) said : #7

The problem is solved--thank you.