Do not minimize XPad windows when doing "Show Desktop"

Asked by KARTHIK on 2013-10-14

One of the main reasons I do "Show Desktop" (by pressing Ctrl+Win+D in Ubuntu), is to be able to immediately access the XPad notes on the Desktop.

But, unfortunately even XPad windows get minimized by this. Is there a way to prevent this?

Question information

English Edit question
Xpad Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

Hi Karthik,

As for as I know, that is currently not an option.
However, we can design, realise and implement new features.

How would you suggest to fit this new feature in Xpad?


KARTHIK (kannankarthik1992) said : #2

I can only think of ways where we can change the functionality of "Show Desktop". For example when we do "Show Desktop", we can use xdotool or something similar to select XPad windows and and maximize them again.

But, this is of course not a general solution.

Honestly, I have no ideas at this moment, however, what I will do is the following.

We will dive into this wish when we are building version 4.3. By that time, we shall investigate if it is (reasonably) possible to implement a configuration option called "Prevent minimizing of notes".

If you have an idea in the meantime, don't hesitate to post them here.

In fact, I have created a new blueprint (to startup the discussion/design) process.

Any help would be appreciated.

KARTHIK (kannankarthik1992) said : #5

When Window Decorations are diabled for the XPad windows, the following procedure prevents XPad windows from minimizing when doing Show Desktop. But the procedure won't work if Window decorations are enabled

In CompizConfig Settings Manager, deselect General > General Options > Hide Skip Taskbar Windows

Hi Karthik,

Thanks for sharing this information. I have added this to the blueprint.
When the moment comes we start working on the design and specifications, this might be helpful.