systray

Asked by Alexander Moshel on 2011-12-14

I read that there was some system tray functionality. After make and make install, I ran xpad and didn't see any xpad icon on my systray. Notes work fine though. Is there something that I am doing wrong perhaps?

Question information

Language:
English Edit question
Status:
Solved
For:
Xpad Edit question
Assignee:
No assignee Edit question
Solved by:
Alexander Moshel
Solved:
2012-02-16
Last query:
2012-02-16
Last reply:
2011-12-20
Siergiej Riaguzow (riaguzov) said : #1

What DE/WM do you use? xpad uses:

http://developer.gnome.org/gtk/2.24/GtkStatusIcon.html

it said there that:

On X11, the implementation follows the freedesktop.org "System Tray" specification. Implementations of the "tray" side of this specification can be found e.g. in the GNOME and KDE panel applications.

So at least on KDE and GNOME you should see the systray icon. Maybe your problem has something to do with new KDE designs, some googling give links like:

http://kubuntuforums.net/forums/index.php?topic=3110000.0

Anyway, you need to specify what DE/WE you are using to get any help.

Alexander Moshel (pj-moshel) said : #2

Sorry for the really late reply. I was using LXDE with Openbox as the Window manager on OpenSUSE 12.1 for this. So LXPanel for my taskbar. Anways, it ended up working later on. Not sure why it didn't before, but oh well. Thanks for a great little program.