How do I get the latest version from trunk?

Asked by Mumia W. on 2011-05-15

I've never used launchpad to download code before.
I hope I can get a .tar.gz file, but there is no link to do
that. Even if I installed bazaar, I wouldn't know what
url to extract from.

Question information

Language:
English Edit question
Status:
Solved
For:
Xpad Edit question
Assignee:
No assignee Edit question
Solved by:
Siergiej Riaguzow
Solved:
2011-06-04
Last query:
2011-06-04
Last reply:
2011-05-25
Siergiej Riaguzow (riaguzov) said : #1

You have to use bazaar and download the source code:

bzr branch lp:xpad

Then you need to compile it using ./configure && make.

Mumia W. (mumia-w-18) said : #2

Thanks. I tried that, but it failed with some error messages:

bzr: ERROR: bzrlib.errors.SHA1KnitCorrupt: Knit <bzrlib.knit._VFContentMapGenerator object at 0xa44adec> corrupt: sha-1 of reconstructed text does not match expected sha-1. key ('285@450b8d32-3a50-448c-8665-1199223f163b:trunk:xpad%2Fscripts%2Fconfig.guess', 'svn-v3-trunk0:450b8d32-3a50-448c-8665-1199223f163b:trunk:285') expected sha 831db445a8ae31d1f773fce85e14c16c8677417d actual sha 3ea2e9aa511a6fb58c979a8ff053c5135199084e
 [...]
bzr 2.1.2 on python 2.6.6 (Linux-2.6.32-5-686-i686-with-debian-6.0.1)
arguments: ['/usr/bin/bzr', 'branch', 'lp:xpad']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'en_US.UTF-8'
plugins:
  bzrtools /usr/lib/python2.6/dist-packages/bzrlib/plugins/bzrtools [2.1.0]
  launchpad /usr/lib/python2.6/dist-packages/bzrlib/plugins/launchpad [2.1.2]
  netrc_credential_store /usr/lib/python2.6/dist-packages/bzrlib/plugins/netrc_credential_store [2.1.2]
  news_merge /usr/lib/python2.6/dist-packages/bzrlib/plugins/news_merge [2.1.2]

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

Best Siergiej Riaguzow (riaguzov) said : #3

Worked for me. Just checked:

bash-3.2$ bzr branch lp:xpad
bzr: warning: unsupported locale setting
  bzr could not set the application locale.
  Although this should be no problem for bzr itself, it might
  cause problems with some plugins. To investigate the issue,
  look at the output of the locale(1p) tool.
You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data. See "bzr help launchpad-login".
Branched 628 revision(s).

Maybe try upgrading bzr? Here's some bug about it:

https://bugs.launchpad.net/bzr/+bug/674270

Not sure about the details though, sorry.

BTW, I really wanted to release another stable version, but then got a lot of troubles on me and had no time. Sorry for that. Will try to find some time and do it but I really don't know when.

Mumia W. (mumia-w-18) said : #4

Thanks Sergei Riaguzov, that solved my question.