MySQL Error: Access denied for user 'some'@'thing.dk' (using password: YES)

Asked by snot

I can connect to my host using phpmyadmin and from command line using the mysql client. However the xibo installer returns access denied.

I do have a long and complicated password with special characters. But I'm unable to change it since other services depend on it.

I'm wondering if this is a problem with the installer and I'm wondering if I can manually update a conf file somewhere? The db_config.php under config/ doesn't contain any comments about the format. Any suggestions about what to do?

Question information

Language:
English Edit question
Status:
Answered
For:
Xibo Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Dan Garner (dangarner) said :
#1

The username/password combination isn't stored anywhere until the installer has successfully connected to it at least once (so changing code in this case wont be that useful).

The best thing you could do is manually create a database and user for Xibo and then use the "existing database" option.

Revision history for this message
snot (sebastianthegreatful) said :
#2

>The best thing you could do is manually create a database and user for Xibo and then use the "existing database" option.

That is actually what I'm doing.

I don't get this. I'm copy and pasting everything... it works just fine with phpmyadmin and the command line client. But not with Xibo. How can I debug this?

Revision history for this message
Dan Garner (dangarner) said :
#3

If you have manually created a user for Xibo in MySQL, can you make the password for that user simple for the installation and then change it once installed (and edit settings.php)?

The install script for 1.6 series is a little hard to read, but the bit you are getting hung up on is rather simple - I can only imagine the field validation is playing with your password somehow.

Can you help with this problem?

Provide an answer of your own, or ask snot for more information if necessary.

To post a message you must log in.