1.7 alpha render as error trying to upgrade from 1.6.4

Asked by N.S. Stratton

An error occurred running the upgrade. Please take a screen shot of this page and seek help. Statement number: 80. Error Message = [SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name 'render_as']

trying to upgrade from 1.6.4 to 1.7 alpha 2 to check it out.

Question information

Language:
English Edit question
Status:
Answered
For:
Xibo Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Dan Garner (dangarner) said :
#1

You are now the second person to report this issue - BUT oddly that column isn't ever added in 1.6.4...

Have you had any failed upgrades or any custom work done to your CMS?

Revision history for this message
N.S. Stratton (nsstratton) said :
#2

no custom work, I started xibo around 1.4 maybe little earlier. and its been upgraded.

i went into phpmyadmin and deleted the column from modules then restarted the upgrade. it looks like the upgrade starts / adds the column then hangs up and complains the column is there. i checked and it is not on my backup of 1.6.4

Revision history for this message
Dan Garner (dangarner) said :
#3

I really cant explain it - its very odd... render_as is only added in 80.sql, line #2.

Perhaps you could open 80.sql, delete that line and then run the upgrade again and see if it goes in, and then see if the column is there in the DB.

Revision history for this message
Dan Garner (dangarner) said :
#4

Sorry - the path is /install/database/80.sql/

Revision history for this message
N.S. Stratton (nsstratton) said :
#5

isn't alpha2 db 82 not 80? I can't remember what it said now.

Revision history for this message
N.S. Stratton (nsstratton) said :
#6

I just tried to upgrade to rc1 1.7

An error occurred running the upgrade. Please take a screen shot of this page and seek help. Statement number: 80. Error Message = [SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '9' for key 'PRIMARY']

Revision history for this message
N.S. Stratton (nsstratton) said :
#7

solved - I found copy of 1.7 and tried upgrade with that and it worked..

somewhere theres link still pointing to rc-1 check all the links i don't remember which one I followed to download it but I think it was to launchpad.

Revision history for this message
Dan Garner (dangarner) said :
#8

Dan Garner suggests this article as an answer to your question:
FAQ #2666: “We have moved to Github”.

Can you help with this problem?

Provide an answer of your own, or ask N.S. Stratton for more information if necessary.

To post a message you must log in.