can't login into xibo

Asked by kieran on 2014-10-10

Hey,

wondering if anyone can help me.

I've got the logging issue where after inputting the xibo_admin username and password the screen just refreshes and doesn't log me in.

I've tried clearing the cache and closing the browser and re trying it then, didn't work.
Also cleared out the session table, reset my xibo_admin password to password and tried it then but still no joy.

I thought I'd try and upgrade from 1.63 to 1.64 see if that fixed it but now it's stuck on the upgrade page cos again I have to input the admin user password which fails again on this upgrade screen

I see a lot of posts with the same issue but none of the solutions work for me.

Any one got any other ideas how this issue can e fixed?

Question information

Language:
English Edit question
Status:
Solved
For:
Xibo Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Harrington
Solved:
2014-10-13
Last query:
2014-10-13
Last reply:
2014-10-13
kieran (kierangray) said : #1

Oh sorry, should've added in the log the first message from today is:

Form token incorrect from: 89.101.254.82 with token [fdb4003e656328b4d89cd217c2ecbebe] for session_id [f0699fee07ce15559e4ac993bdb6f6d8]

And then every message since is :

<errormsg>Token does not match</errormsg>
<errornum>1024</errornum>
<errortype>User Notice</errortype>
<scriptname>/usr/local/pem/vhosts/165695/webspace/httpdocs/<server>/lib/pages/index.class.php</scriptname>
<scriptlinenum>48</scriptlinenum>

kieran (kierangray) said : #2

Also just to add some more information, originally when i installed the product it worked, logged in uploaded content and everything seemed fine.

I left it for a few hours came back to it and then all the above happened.

I'd really appreciate any ideas anyone has of a possible solution to this?

I'm on shared hosting, I presume that has something to do with this, is xibo confirmed to work on shared hosting or is it a case you have to use a dedicated server to achieve stability?

This can happen sometimes if your browser upgrades while you're logged in.
Try a different browser or truncating the session table in the database.

We don't recommend Xibo in shared hosting environments as they are often
setup in ways which make it difficult for us to offer you support.

There are paid hosting options from the project sponsors, and other
companies available - which are preferable

kieran (kierangray) said : #4

yea I tried truncating the session table the other day when it first happned and tried it in 3 different browsers and 3 different computers and networks to confirm that wasn't the issue.

I tried everything I could find on the issue that was posted in threads on the forums, that's why I thought I'd try and post here.

I guess I have to sign up for the spring signage hosting then if I want to get it working, I'm gonna sign up there with a trial account and see if that works.

Thanks for getting back to me even if there wasn't a possible resoltuion

You could try resetting your admin password. Instructions are in the FAQ

kieran (kierangray) said : #6

yea I did that also, set it to password and it appears as the '5f4dcc3b5aa765d61d8327deb882cf99' in the database, I basically did everyting that was sujested in the launchpad questions and answers related to this issue but none of the things worked for me

You changed CSPNG value too? If you don't do that the password reset won't
work.

kieran (kierangray) said : #8

Thanks Alex Harrington, that solved my question.

kieran (kierangray) said : #9

doh, thanks alex, I missed that bit, works now, my bad.