Admin Password don´t work?

Asked by Stefan on 2014-07-19

I tried to update xibo at my Server.

If I enter my admin-password it always says "Password incorrect. Please try again."
I am 100% sure that I use the right admin-password.

Now I tried to reset it by using this command:

UPDATE `user` set `UserPassword` = MD5('password') WHERE `UserID` = 1 LIMIT 1;

If I try to login with password message with Password incorrect still appear!

Whats wrong??? :-(

Question information

Language:
English Edit question
Status:
Solved
For:
Xibo Edit question
Assignee:
No assignee Edit question
Solved by:
Stefan
Solved:
2014-07-20
Last query:
2014-07-20
Last reply:
2014-07-20
Stefan (syberstef) said : #1

The command works because I can see it in the table user.

If I reset it to

UPDATE `user` set `UserPassword` = MD5('test') WHERE `UserID` = 1 LIMIT 1;

UserPassword = 098f6bcd4621d373cade4e832627b4f6

if i reset it to

UPDATE `user` set `UserPassword` = MD5('password') WHERE `UserID` = 1 LIMIT 1;

UserPassword = 5f4dcc3b5aa765d61d8327deb882cf99

It seems to be a bug!!!

I changed the admin-username after the installation from xibo_admin to admin!

Can you fix it?

You'd need to log in to the server as xibo_admin once before the upgrade
will work

Stefan (syberstef) said : #3

There is no way to login because always goes to upgrade.php if i try to go to index.php.

A workaroud shoud be to change username from admin back to xibo_admin but a real bugfix is to change update assistent to fill in username and password manually!!!

Stefan (syberstef) said : #4

It still don´t work!!! :-(((

I changed admin to xibo_admin manually in the SQL-Database and changed the password to "test" but still Password incorrect. Please try again.

What can I do? :-(((

Stefan (syberstef) said : #5

I realy don´t know why this workaround don´t work because now the username is as "standard".

Do you have a solution to fix this issue? :-(

Stefan (syberstef) said : #6

And If I delete upgrade.php from webspace and try to open index.php

Incompatible database version detected. Please ensure your database and website versions match. You have database 69 and website 70

I also tried to rename username from xibo_admin back to admin in the SQL-Database and change also the update.php from xibo_admin to xibo!

The result:

Password incorrect. Please try again.

Right. You need to restore your original cms files, then log in once, then
upgrade again. The cms uses a new password format so you need to log in
once to convert what you're putting in the database before you'll be able
to log in

Stefan (syberstef) said : #8

OH NOOOOOOOOOOOOO! I only saved the settings.php

No other way???

Stefan (syberstef) said : #9

Or can I restore the original 1.6.1? Are there all changes during work in the Database?

Stefan (syberstef) said : #10

It don´t work! :-(

I uploades all the old 1.6.1 files and restored my settings.php!

If I open index.php then HTTP 500: Interner Serverfehler

Stefan (syberstef) said : #11

A solution should be that I replace all files to 1.6.2 and you give me combination out of passwordfield entry and the real password.

Am I right? :-)

You need to delete the existing files, then extract the a fresh version of
the CMS the same as you already have installed then put settings.php back.
Then log in, then upgrade

NO

Please read what I said carefully.

Get whatever version you had previously. Delete your existing CMS
installation (except your library and settings.php). Restore the old cms
version and the settings.php, delete install.php and upgrade.php and then
log in.

Then upgrade following the instructions and actually take a full backup
this time!

Then once

Stefan (syberstef) said : #14

I did exactly this but it don´t work!

HTTP 500 Server Error.
I realy don´t know why! ;-(

Now I delete all files and repace it with the new 1.6.2 and it shows me the updater but still (what a wonder) wrong password!

But it should also work if I manualy add a new password in the new format to the SQL-Database field UserPassword !?
I think this should be the simplest way at the moment or isn´t it as easy as my thoughts?

Stefan (syberstef) said : #15

I tried again to delete all files, replace it with 1.6.1 (was installed before) deleted install.php and upgrade.php restore old settings.php and try to loungh my CMS by entering URL.

Firefox shows empty white page, IE the same but in tab it shows HTTP 500 Error!

hmmmmm... I realy don´t know what to do!

Stefan (syberstef) said : #16

I wonder that I am the only one with this problems...

1. I think that I am not the only one who renamed the admin-account from standard "xibo_admin" to custom!

2. I think that I am not the only one who don´t login before update!?

It would be very nice to create a running solution with a field to fill in admin username and not a hardcoded standard name in upgrade.php. :-)

And perhaps you have a solution for me how to login without getting HTTP 500 Error to my old CMS if I replaced a files with old 1.6.1! :-(

Now I will go to bed and hope you can create a wonder :-)

Very very very thank you!!! :-)

You cannot rename the xibo_admin account.

If you want to use a different name, then create a second user and use that
for your normal day to day use.

You need to reinstate your old system, put the user account back as it was,
then upgrade

Stefan (syberstef) said : #18

My workaround works perfect! :-)

Goto SQL-Database and manualy set UserName: xibo_admin and UserPassword: sha256:1000:Esc7pZh80TUmGinVHAzw1BYkP0v5aI7j:RHogrqbK8cmKL/rLP0wTX7XSAKG2jj2/

So I can login with password during the upgrade-assistent ask me for! :-)