Xibo upload limit doesn't change after editing php.ini

Asked by Nazareno Chiaravalloti on 2014-06-26

Hello, I'm using the latest version of Xibo, installed on an Ubuntu server, and I have a big problem.
I edited both the php.ini files, setting -upload_max_filesize and -post_max_size at 900M, but nothing changed: the upload limit on xibo is always 16MB (which is rather unusual I think?)
So, what should I do? Any suggestions? I'm not used to this sort of things so please don't be complicated xD

Question information

Language:
English Edit question
Status:
Solved
For:
Xibo Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Harrington
Solved:
2014-06-26
Last query:
2014-06-26
Last reply:
2014-06-26

You need to restart Apache after editing php.ini

Note you need to change more than just those two parameters. There's a full
list in the FAQ

Yeah I know, I changed all the parameters listed in the FAQ and I also restarted Apache by command line (-sudo service apache2 restart), but the 16MB upload limit still remains, I don't know what to do

Can't have edited the correct file then. It's /etc/php5/apache2/php.ini on
recent versions of Ubuntu

on /etc/php5/apache2, the parameters on the php.ini file are as reported here:

file_uploads = On

upload_max_filesize = 900M

max_input_time = 60

memory_limit = 900M

max_execution_time = 30

post_max_size = 900M

am I doing something wrong?

can it be my browser? I'm using firefox and trying to upload a 30MB video, but still nothing. 16MB limit

What size is shown on the upload form

"This form accepts: wmv, avi, mpg, mpeg, webm, mp4 files up to a maximum size of 16M "

I don't think you can have edited the file correctly or restarted the
webserver correctly. That's all that is required

administrator@web-server:~$ sudo service apache2 restart
[sudo] password for administrator:
no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
 * Restarting web server apache2
AH00112: Warning: DocumentRoot [/var/www/html] does not exist
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message

maybe because of these errors? I don't know what they exactly mean

I've never seen those errors before

Thanks Alex Harrington, that solved my question.