Xibo Open Source Digital Signage

Setting up Server and Client Display - Registering Display Problem

Asked by Barry Wood on 2012-05-09

I am trying to test a configuration of a Server (Windows XP Pro) with XAMPP/Xibo Server installed (& working OK), to a Client (Windows XP Pro) with Xibo Client installed. I've connected the 2 with a network cable and set their IP addresses to 168.192.1.2 (Server) and 168.192.1.1 (Client).

I can see the Client drives from the Server OK, and it pings the IP address OK. I've setup the Client to see the Server as http://168.192.1.2/xibo/xmds.php (Xibo Service URL), but when I try to register the display I get an error message: Unable to connect to the Remote Server.

Any thoughts on how I can figure what isn't working as it should be?

Question information

Language:
English Edit question
Status:
Solved
For:
Xibo Edit question
Assignee:
No assignee Edit question
Solved by:
Barry Wood
Solved:
2012-05-09
Last query:
2012-05-09
Last reply:
2012-05-09

You just need:

http://168.192.1.2/xibo

In your client options - you don't want xmds.php on the end.

Alex

Barry Wood (barry-x8) said : #2

Alex,
I think I figured it out - maybe I should think more before asking for help! What it was is the address. When I installed Apache I had to change the port from 80 to 8888 to get it working.

So the address in the client should be http://168.192.1.2:8888/xibo (I was reading wrong line before - that with the xmds.php name).

Afre I changed it picked up right away!