Installation Issue - Please Help

Asked by Wasif Khan on 2010-10-16

Hi, new to this product.

downloaded. installed on CentOS, followed directions. Went on browser.. First step showed green on all dependencies. Step two asks for creating of MySQL database. I provide all information including mysql admin username and password.. but i get error.

Could not connect to MySQL with the administrator details. Please check and try again.

MySQL Error:
Access denied for user 'root'@'localhost' (using password: YES)

I get the same error if I go and create empty database on mysql using PHPadmin and then comeback and put that information.

please guide me

WK

Question information

Language:
English Edit question
Status:
Answered
For:
Xibo Edit question
Assignee:
No assignee Edit question
Last query:
2010-10-23
Last reply:
2010-10-24

The password you've entered is wrong. Xibo doesn't have great Unicode support so make sure you're using only characters a-z 0-9

Wasif Khan <email address hidden> wrote:

New question #129717 on Xibo:
https://answers.launchpad.net/xibo/+question/129717

Hi, new to this product.

downloaded. installed on CentOS, followed directions. Went on browser.. First step showed green on all dependencies. Step two asks for creating of MySQL database. I provide all information including mysql admin username and password.. but i get error.

Could not connect to MySQL with the administrator details. Please check and try again.

MySQL Error:
Access denied for user 'root'@'localhost' (using password: YES)

I get the same error if I go and create empty database on mysql using PHPadmin and then comeback and put that information.

please guide me

WK

--
You received this question notification because you are a member of Xibo
Developers, which is an answer contact for Xibo.

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

Wasif Khan (wasifkhan007) said : #2

thanks for yoru answer... still not working... i did nto have any special characters...

i even created a user xibo with password xibo for the database which has all access level... any ideas?

Wasif Khan

> To: <email address hidden>
> From: <email address hidden>
> Subject: Re: [Question #129717]: Installation Issue - Please Help
> Date: Sat, 16 Oct 2010 08:27:25 +0000
>
> Your question #129717 on Xibo changed:
> https://answers.launchpad.net/xibo/+question/129717
>
> Status: Open => Answered
>
> Alex Harrington proposed the following answer:
> The password you've entered is wrong. Xibo doesn't have great Unicode
> support so make sure you're using only characters a-z 0-9
>
> Wasif Khan <email address hidden> wrote:
>
> New question #129717 on Xibo:
> https://answers.launchpad.net/xibo/+question/129717
>
> Hi, new to this product.
>
> downloaded. installed on CentOS, followed directions. Went on browser..
> First step showed green on all dependencies. Step two asks for creating
> of MySQL database. I provide all information including mysql admin
> username and password.. but i get error.
>
> Could not connect to MySQL with the administrator details. Please check
> and try again.
>
> MySQL Error:
> Access denied for user 'root'@'localhost' (using password: YES)
>
>
> I get the same error if I go and create empty database on mysql using PHPadmin and then comeback and put that information.
>
> please guide me
>
> WK
>
> --
> You received this question notification because you are a member of Xibo
> Developers, which is an answer contact for Xibo.
>
> This email carries a disclaimer, a copy of which may be read at
> http://learning.longhill.org.uk/disclaimer
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/xibo/+question/129717/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/xibo/+question/129717
>
> You received this question notification because you are a direct
> subscriber of the question.

Can you definitely access mysql from the command line tool? Eg mysql -u root -p

That installer has worked on thousands of systems so I'm pretty confident its some problem with your MySQL install or the accounts you're using.

Alex

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

Wasif Khan (wasifkhan007) said : #4

Alex,

you are right. when execute below commands... both user root and xibo i created.. i get access denied... how can i fix that..?

Wasif Khan

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #129717]: Installation Issue - Please Help
> Date: Sat, 16 Oct 2010 15:36:28 +0000
>
> Your question #129717 on Xibo changed:
> https://answers.launchpad.net/xibo/+question/129717
>
> Status: Open => Answered
>
> Alex Harrington proposed the following answer:
> Can you definitely access mysql from the command line tool? Eg mysql -u
> root -p
>
> That installer has worked on thousands of systems so I'm pretty
> confident its some problem with your MySQL install or the accounts
> you're using.
>
> Alex
>
> This email carries a disclaimer, a copy of which may be read at
> http://learning.longhill.org.uk/disclaimer
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/xibo/+question/129717/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/xibo/+question/129717
>
> You received this question notification because you are a direct
> subscriber of the question.

I'm not familiar with Centos. Perhaps start with whatever their official support site is?

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

Wasif Khan (wasifkhan007) said : #6

ok.. i have troubleshooted few things.. I created as follows:

1. created empty database xibo
2. created user xibo
3. assigned password to user xibo
4. xibo user has all privilages for xibo database
5. rebooted server
6. was successfully able to connect to mysql using xibo at command line
7. started xibo installation on web.
8. selected "Use existing database"
9. entered xibo database name, user and password.

got error message

Could not connect to MySQL with the Xibo User account details. Please check and try again.

MySQL Error:
Access denied for user 'xibo'@'localhost' (using password: YES)

Wasif Khan

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #129717]: Installation Issue - Please Help
> Date: Sat, 16 Oct 2010 15:51:24 +0000
>
> Your question #129717 on Xibo changed:
> https://answers.launchpad.net/xibo/+question/129717
>
> Status: Open => Answered
>
> Alex Harrington proposed the following answer:
> I'm not familiar with Centos. Perhaps start with whatever their official
> support site is?
>
> This email carries a disclaimer, a copy of which may be read at
> http://learning.longhill.org.uk/disclaimer
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/xibo/+question/129717/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/xibo/+question/129717
>
> You received this question notification because you are a direct
> subscriber of the question.

Did you flush privileges in the database?

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

Wasif Khan (wasifkhan007) said : #8

yes...even rebooted server.

Wasif Khan

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #129717]: Installation Issue - Please Help
> Date: Sun, 17 Oct 2010 09:21:27 +0000
>
> Your question #129717 on Xibo changed:
> https://answers.launchpad.net/xibo/+question/129717
>
> Status: Open => Answered
>
> Alex Harrington proposed the following answer:
> Did you flush privileges in the database?
>
> This email carries a disclaimer, a copy of which may be read at
> http://learning.longhill.org.uk/disclaimer
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/xibo/+question/129717/+confirm?answer_id=6
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/xibo/+question/129717
>
> You received this question notification because you are a direct
> subscriber of the question.

I don't have any other suggestions then.

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

Wasif Khan (wasifkhan007) said : #10

its a shame.. I really want to use this product... is there any other way to configure this besides the wizard? what could be causing this... frustating :)

Wasif Khan

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #129717]: Installation Issue - Please Help
> Date: Sun, 17 Oct 2010 15:27:21 +0000
>
> Your question #129717 on Xibo changed:
> https://answers.launchpad.net/xibo/+question/129717
>
> Status: Open => Answered
>
> Alex Harrington proposed the following answer:
> I don't have any other suggestions then.
>
> This email carries a disclaimer, a copy of which may be read at
> http://learning.longhill.org.uk/disclaimer
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/xibo/+question/129717/+confirm?answer_id=8
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/xibo/+question/129717
>
> You received this question notification because you are a direct
> subscriber of the question.

If you want to give me access to the server I'll take a look at it.

The problem is that you're saying that the user you've setup can connect but the software can't.

Given the thousands of installs we have I'm pretty confident its not the software.

Alex

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

You can email the details to <email address hidden>

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

You've not given me any credentials for MySQL. I've sent you an email direct.

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

Wasif Khan (wasifkhan007) said : #14

do you have msn messenger ... we can chat as well. if you lke

Wasif Khan

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #129717]: Installation Issue - Please Help
> Date: Sun, 17 Oct 2010 16:54:26 +0000
>
> Your question #129717 on Xibo changed:
> https://answers.launchpad.net/xibo/+question/129717
>
> Alex Harrington proposed the following answer:
> You've not given me any credentials for MySQL. I've sent you an email
> direct.
>
> This email carries a disclaimer, a copy of which may be read at
> http://learning.longhill.org.uk/disclaimer
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/xibo/+question/129717/+confirm?answer_id=12
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/xibo/+question/129717
>
> You received this question notification because you are a direct
> subscriber of the question.

Nothing wrong with the software. MySQL user account didn't have access to the database and the admin account given didn't have access to anything either.

Wasif Khan (wasifkhan007) said : #16

Xibo server running fine...

xibo client crashes right after you invoke it. In client options I have all settings. On Management page, license key dislay is yes.. default layout is used.. but when you click on xebo client and it tries to come up it crashes.

Client software is installed on windows 7 that has .net 4 . your guidance will be appreciated.

Wasif Khan

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #129717]: Installation Issue - Please Help
> Date: Sun, 17 Oct 2010 18:53:21 +0000
>
> Your question #129717 on Xibo changed:
> https://answers.launchpad.net/xibo/+question/129717
>
> Status: Open => Answered
>
> Alex Harrington proposed the following answer:
> Nothing wrong with the software. MySQL user account didn't have access
> to the database and the admin account given didn't have access to
> anything either.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/xibo/+question/129717/+confirm?answer_id=14
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/xibo/+question/129717
>
> You received this question notification because you are a direct
> subscriber of the question.

As this is a new issue please could you start a new question.

Thanks

Alex

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

Try deleting cachemanager.xml from application data/xibo/2.0.0.0 folder.

This email carries a disclaimer, a copy of which may be read at http://learning.longhill.org.uk/disclaimer

Can you help with this problem?

Provide an answer of your own, or ask Wasif Khan for more information if necessary.

To post a message you must log in.