WXBanker Not Opening

Asked by Randy on 2009-10-02

Is there a way to find out if I have all necessary files to be sure wxbanker will work? My issue is, after clicking on it in office, it simply doesn't open.

I have tried to uninstall/reinstall many times, many different versions and I can't seem to get it to work.

Any suggestions?

Thanks,
Randy

Question information

Language:
English Edit question
Status:
Solved
For:
wxBanker Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Rooney
Solved:
2009-10-05
Last query:
2009-10-05
Last reply:
2009-10-05
Michael Rooney (mrooney) said : #1

I am very sorry to hear that Randy! Try running it from a terminal and seeing if it produces any output. To do this, instead of going into "Office" choose "Accessories" then "Terminal". From here type "wxbanker --debug" without the quotes, hit enter, and let me know what output you get. Also, what version are you using?

Randy (rjcayea) said : #2

Michael Rooney wrote:
> Your question #84573 on wxBanker changed:
> https://answers.edge.launchpad.net/wxbanker/+question/84573
>
> Status: Open => Needs information
>
> Michael Rooney requested for more information:
> I am very sorry to hear that Randy! Try running it from a terminal and
> seeing if it produces any output. To do this, instead of going into
> "Office" choose "Accessories" then "Terminal". From here type "wxbanker
> --debug" without the quotes, hit enter, and let me know what output you
> get. Also, what version are you using?
>
>
Hi Michael,

Thanks for replying so quick. I tried the newest release and the one
before it. Here is the output from the debug command...

rcayea@rcayeaubuntu:~$ wxbanker --debug
Traceback (most recent call last):
  File "/usr/bin/wxbanker", line 2, in <module>
    from wxbanker import wxbanker
  File "/usr/lib/python2.6/dist-packages/wxbanker/wxbanker.py", line 29,
in <module>
    from menubar import BankMenuBar
  File "/usr/lib/python2.6/dist-packages/wxbanker/menubar.py", line 26,
in <module>
    from currencies import CurrencyStrings
  File "/usr/lib/python2.6/dist-packages/wxbanker/currencies.py", line
215, in <module>
    curr().float2str(1000)
  File "/usr/lib/python2.6/dist-packages/wxbanker/currencies.py", line
99, in float2str
    raise ValueError("Currency formatting is not possible using "
ValueError: Currency formatting is not possible using the 'C' locale.

thanks again,
Randy

Michael Rooney (mrooney) said : #3

Ah I see, for some reason your system locale is the "C" locale. Is this a stock Ubuntu system? The solution is to specify it manually. Assuming you want English, you can run wxBanker with the command "LC_ALL=en_US.utf8 wxbanker" without the quotes, which will make wxBanker run with an actual locale. I am interested in what might cause this, and I also should handle this better on the application side, popping up a dialog for this error and explaining the solution, so I will open a bug for this. Thanks and let me know if that works for you. If so, you should be able to edit /usr/share/applications with a text editor and change the "exec" option to the full command.

Randy (rjcayea) said : #4

Michael Rooney wrote:
> Your question #84573 on wxBanker changed:
> https://answers.edge.launchpad.net/wxbanker/+question/84573
>
> Status: Open => Answered
>
> Michael Rooney proposed the following answer:
> Ah I see, for some reason your system locale is the "C" locale. Is this
> a stock Ubuntu system? The solution is to specify it manually. Assuming
> you want English, you can run wxBanker with the command
> "LC_ALL=en_US.utf8 wxbanker" without the quotes, which will make
> wxBanker run with an actual locale. I am interested in what might cause
> this, and I also should handle this better on the application side,
> popping up a dialog for this error and explaining the solution, so I
> will open a bug for this. Thanks and let me know if that works for you.
> If so, you should be able to edit /usr/share/applications with a text
> editor and change the "exec" option to the full command.
>
>
Michael,

The LC_ALL=en_US.utf8 wxbanker command did not work. This is a standard
ubuntu install 64bit. I will try the usr/share option you suggest. I am
kind of bummed because I have all my family finances using this
application.

Michael Rooney (mrooney) said : #5

Hm, adding it in the .desktop file would only be a shortcut for the command. So, you were using it successfully for some time and then it stopped working? Can you think of any specific change that made it stop happening? Can you provide the output of running the command "locale -a" in a terminal? I am sure we will figure this out :)

Randy (rjcayea) said : #6

Michael Rooney wrote:
> Your question #84573 on wxBanker changed:
> https://answers.edge.launchpad.net/wxbanker/+question/84573
>
> Status: Open => Needs information
>
> Michael Rooney requested for more information:
> Hm, adding it in the .desktop file would only be a shortcut for the
> command. So, you were using it successfully for some time and then it
> stopped working? Can you think of any specific change that made it stop
> happening? Can you provide the output of running the command "locale -a"
> in a terminal? I am sure we will figure this out :)
>
>
Yes, it was working fine. I have had .drmc issues that I fixed. This may
or may not help, but a lot of documents or apps seemed to be checked as
executables. I was tinkering with permissions when I was trying to
install ootp10.

Here is the output of locale -a:

C
POSIX

Thanks for continuing to look into this. I would hate to have to move to
homebank or another program, because I love how wxb has the layout and
it is nice and simple.

Randy

Randy (rjcayea) said : #7

Michael Rooney wrote:
> Your question #84573 on wxBanker changed:
> https://answers.edge.launchpad.net/wxbanker/+question/84573
>
> Status: Open => Needs information
>
> Michael Rooney requested for more information:
> Hm, adding it in the .desktop file would only be a shortcut for the
> command. So, you were using it successfully for some time and then it
> stopped working? Can you think of any specific change that made it stop
> happening? Can you provide the output of running the command "locale -a"
> in a terminal? I am sure we will figure this out :)
>
>
Michael,

For now, is there any other way I can convert or import the wxbanker
data into another one of the finance managers available in linux? It is
the beginning of the month and as you may guess, I need to update my
financial information.

thanks,
Randy

Best Michael Rooney (mrooney) said : #8

It appears that somehow all of your language packs have been deleted. Without a locale, your system doesn't have the concept of a locale. I am surprised that no other applications are having problems! Try installing "language-pack-en-base" (sudo apt-get install language-pack-en-base), then seeing if you have something like en_US in your "locale -a" list. Then wxBanker should run fine normally; it may require the LC_ALL=en_US.utf8 before the command but, hopefully not.

If that doesn't work or in the mean time, you should be able to run wxBanker on another computer if you copy your ~/.wxbanker directory over.

Karel Kolman (kolmis) said : #9

Try running this:

sudo locale-gen en_US.utf8

Randy (rjcayea) said : #10

THANK YOU! Installing the language pack did it. I appreciate this kind of help and constant problem solving to help some unknown guy (me).

Thanks again,
Randy