password upon launch?

Asked by Alex Rybicki on 2009-02-17

Hi Michael, i saw your entry on planet ubuntu, and i agree, one app that desperately needs to be included on a default install is a personal finance application. ive been employed as a bank teller, and ive seen how a lot of people manage their finances. personally ive never used a finance app, mostly because i cant stand the bloat of MS money or Quicken. i would love to use one however if it was simple and very easy to use. so far im very impressed by wxBanker. thanks for the project, ill keep a very interested eye on it :)

One question however. perhaps im just not looking close enough, but i would love to have a way of creating a password prompt to access an account, or to make changes. is that currently implemented? or is it something you have in the works? i dont want to give access to my computer to someone, fearing they might see my personal finances, or even worse make changes. just relying on a session login seems less than ideal.

also, my gdk2 theme color choices makes the transaction entries near impossible to see. i realize that it is solely my fault because of my non default color scheme (im currently using dust https://wiki.ubuntu.com/Artwork/Incoming/DustTheme?action=show&redirect=Artwork%2FIncoming%2FIntrepid%2FDustTheme) but i would love to see a way of selecting font color within the application, if that is at all possible.

I would also love to see an easy way to backup and restore the data too, within the app. perhaps these are more suggestions instead of questions.

again, thank you for the project, Michael

Question information

Language:
English Edit question
Status:
Solved
For:
wxBanker Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Rybicki
Solved:
2009-02-17
Last query:
2009-02-17
Last reply:
2009-02-17
Alex Rybicki (alex-rybicki) said : #1

update:
Ive noticed some screenshots of wxbanker using QT. i have QT installed, however, it seems to be running GDK2 instead. here is a screenshot:
http://i44.tinypic.com/i6ebly.png

You can see how this can be a problem for me. any help or input will be greatly appreciated :) thanks.

Michael Rooney (mrooney) said : #2

Hi Alex, thanks for the feedback! I too use Dust (all these screenshots are Dust: https://wiki.ubuntu.com/wxBanker), but don't experience those problems anymore. I believe that is actually a bug in an older version of Dust, have you upgraded to the latest version?

As far as your questions, there is no way to password protect it ATM. I would love to add this feature in, but to be useful it would need to encrypt and decrypt the bank file. What you may want to use, in the interim, is an encrypted private directory http://tombuntu.com/index.php/2008/09/23/encrypted-private-directory-in-ubuntu-810/ . Move your ~/.wxbanker directory into ~/Private and symlink it back (ln -s ~/Private/wxbanker ~/.wxbanker). Then your information will be available when that directory is mounted, and not when you aren't logged in or it is unmounted. Pretty secure.

There is no automated backup mechanism either, but a good approach is to do something like this: "cp ~/.wxbanker/bank.db ~/.wxbanker/bank.db`date +%s`". That will back up your data to a file with a timestamp. Or, I just email myself the db every week.

However I would love to have these features implemented. If you wouldn't mind taking a minute and filing a blueprint for both of those (password, backup) at https://blueprints.launchpad.net/wxbanker, then I can triage them appropriately. I should probably make FAQs out of all three issues you raise here as well.

Thanks again and let me know if an updated Dust fixes your display issue.

Alex Rybicki (alex-rybicki) said : #3

Thanks for your quick reply Michael.
I will file blueprints within 24 hours on the backup/password, I dont have the time right now unfortunately. Personally I use and love truecrypt, so i will probably go that route, thank you for your suggestions though. ill take a look at using ~/Private.

As for the theme issue, I am running the latest version of dust, however, i have made a few minor changes by hand to my ~/.themes/Dust/gtk-2.0/gtkrc file. i believe that is the problem. i haven't run into any similar problems with other apps though. i can attach my ~/.themes/Dust/gtk-2.0/gtkrc file if you are feeling ambitious.
the problem does not persist when i use a clean install of dust theme 3.2. I am going to mark this as solved, because its pretty much my own fault for creating the issue. you would essentially spend your time patching only my one machine. It may be something you run across in the future though. If i find a solution on my own i will post it here.
Again, thanks for your help Michael.

Antonio Barone (airsix) said : #4

Hello,
I'm new to this so i apologise in advance if it's the wrong section,
I'm experiencing the same color problem,it's very hard to read the entries,
I also tried to change theme but it doesn't seem to work, the changes affect the menu, the bar, everything except the entries. I also tried to upgrade to the latest version but nothing changed,
any help would be appreciated, thanks!

Michael Rooney (mrooney) said : #5

Hi Antonio! Would you mind filing a bug at https://bugs.launchpad.net/wxbanker/+filebug and including a screenshot of wxBanker with the theme, and where I might obtain the theme to play around with it myself? Thanks!