Where is the Edit menu and particularly the Undo button?

Asked by DanFoxDavies on 2010-03-25

There is no way to undo a change that has messed up my accounts.
Attempted to modify the date, hit a bug, no way to undo. Annoyed, very.

Question information

Language:
English Edit question
Status:
Answered
For:
wxBanker Edit question
Assignee:
No assignee Edit question
Last query:
2010-03-25
Last reply:
2010-03-25
Michael Rooney (mrooney) said : #1

Ah sorry, that's true, there is no undo functionality. What was the bug you ran into, the Norwegian locale issue? I actually figured Undo would be useful but as I am the only primary developer, I try to only implement things once someone asks for them, to make sure I am only implementing features someone actually wants. I've created a blueprint for this at https://blueprints.launchpad.net/wxbanker/+spec/undo-redo.

Sorry you are running into problems so early. Did you have any other feedback on wxBanker? Useful things, usability issues, other problems? Particularly, did you have any trouble figuring out how to add accounts and transactions?

DanFoxDavies (danfox) said : #2

Yeah, there seems to be an issue with attempting to delete or edit transactions further back in the timeline than the most recent - they keep coming back. I found this problem while already using the en_GB locale. Also, when I tried to edit any fields of a transaction, and clicked away from the edit box rather than hitting enter, it became impossible to change - the backspace and delete did nothing with whatever I had first edited it to.
I have worked around this for now by very carefully avoiding repeating what I did wrong, fortunately the autosave hadn't saved beyond the bug occurring.

Can you help with this problem?

Provide an answer of your own, or ask DanFoxDavies for more information if necessary.

To post a message you must log in.