Dopo aggiornamento non parte più

Asked by Giulianoc76 on 2009-11-24

dopo aver scaricato questa sera diversi aggiornamenti di ubuntu, mi ha chiesto di riavviare, ho scelto di riavviare in seguito, e quando l'ho riavviato non è più partito. Mi appare la seguente schermata:
GNU GRUB version 1.97 beta 4
[minimal BASH-LIKE line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device/file completions]
SH:GRUB>

Cosa devo Fare?

Grazie

Question information

Language:
Italian Edit question
Status:
Solved
For:
Wubi Edit question
Assignee:
No assignee Edit question
Solved by:
Sergio Zanchetta
Solved:
2009-12-18
Last query:
2009-12-18
Last reply:
2009-12-18

Sembra che ci sia un problema sul tuo bootloader grub2

Ci dici a grandi linee come è installato il tuo Ubuntu se in dual-boot (Windows + Ubuntu) o tramite Wubi, quanti dischi hai e come sono partizionati...

Inoltre hai modo di masterizzare: potrebbe servire, il disco live di installazione di Ubuntu 9.10...?

Grazie

Giulianoc76 (giuliano) said : #2

è installato in dual-boot ho un disco solo e ubunto è stato installato dall'interno di Windows. Riesco tranquillamente a far partire windows e quindi sono in grado di masterizzare. Il cd di installazione di ubuntu 9.10 l'ho qui con me.
Grazie

Giulianoc76 (giuliano) said : #3

è installato in dual-boot ho un disco solo e ubunto è stato installato
dall'interno di Windows. Riesco tranquillamente a far partire windows e
quindi sono in grado di masterizzare. Il cd di installazione di ubuntu
9.10 l'ho qui con me.
Grazie
> Your question #91579 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/91579
>
> Status: Open => Needs information
>
> marcobra (Marco Braida) requested for more information:
> Sembra che ci sia un problema sul tuo bootloader grub2
>
> Ci dici a grandi linee come è installato il tuo Ubuntu se in dual-boot
> (Windows + Ubuntu) o tramite Wubi, quanti dischi hai e come sono
> partizionati...
>
> Inoltre hai modo di masterizzare: potrebbe servire, il disco live di
> installazione di Ubuntu 9.10...?
>
> Grazie
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/91579
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Cattini Giuliano

<email address hidden>

www.cattini.eu

CATTINI Oleopneumatica S.r.l.
Via Edison, 18/31/35 - 42040 Calerno di S.Ilario d'Enza - Reggio Emilia -
ITALY
ph. +39 0522 909750 - Fax +39 0522 909875 - Export office ph. +39 0522 334224

***************************************************************************
Le informazioni contenute nella presente comunicazione e i relativi allegati
possono essere riservate e sono, comunque, destinate esclusivamente alle
persone o alla Società sopraindicati. La diffusione, distribuzione e/o
copiatura del documento trasmesso da parte di qualsiasi soggetto diverso
dal destinatario è proibita, sia ai sensi dell'art. 616 c.p. , che ai sensi
del D.Lgs. n. 196/2003. Se avete ricevuto questo messaggio per errore, vi
preghiamo di distruggerlo e di informare immediatamente il mittente.
***************************************************************************
The information in this e-mail (which includes any files transmitted with it)
is confidential and may also be legally privileged. It is intended for the
addressee only. Access to this e-mail by anyone else is unauthorised. It is
not to be relied upon by any person other than the addressee, except with
our prior written approval. If no such approval is given, we will not accept
any liability (in negligence or otherwise) arising from any third party
acting. Unauthorised recipients are required to maintain confidentiality.
If you have received this e-mail in error please notify us immediately,
destroy any copies and delete it from your computer system. Any use,
dissemination, forwarding, printing or copying of this e-mail is
prohibited.
***************************************************************************

Hai da poco installato Ubuntu, hai spazio su disco...( sulla partizione Windows ) ? aggiungi che se vorrai disinstalleremo completamente la copia di Ubuntu installata tramite Wubi... perciò ritengo che spazio a sufficienza lo dovresti avere, però dai indicazioni grazie.

Ti va' di installare Ubuntu in modo permanente su una partizione dedicata in modo che se salta Windows riesci sempre ad usare Ubuntu e a tirare fuori i dati che ti servono...?

Se la risposta è si, controlliamo che gli "strumenti" con i quali installerai (il cd live di Ubuntu) siano verificati, ovvero:

Hai verificato la somma md5 dell'iso scaricata prima di effettuare la masterizzazione...?
Hai imposto una velocità bassa e la verifica dei dati durante la masterizzazione del cd...?

Se non lo hai fatto puoi verificarla adesso...

Qui i riferimenti ufficiali in lingua inglese https://help.ubuntu.com/community/BurningIsoHowto

Per la verifica dell'md5 da windows https://help.ubuntu.com/community/HowToMD5SUM#MD5SUM%20on%20Windows

Se ti serve aiuto chiedi qui.

Grazie

Giulianoc76 (giuliano) said : #5

E' circa un mese che ho installato Ubunt. Non ho problemi di spazio. Al momento preferirei mantenere l'installazione attuale, in futuro, se vedo che ubuntu è stabile e non ho problemi, potrei decidere di formattare il tutto e tenere solo ubuntu. Per quanto riguarda i dati si trovano comunque sempre da un'altra parte e mai in locale.
Ho comunque verificato l'MD5 e in fase di masterizzazione ho utilizzato una velocità bassa e ho utilizzato il software Infrarecorder, facendo poi anche la verifica.
Esiste qualche possibilità al momento di farlo ripartire senza doverlo reinstallare? Esistono delle utility che mi possono risolvere il problema? Se in qualche modo si dovesse riuscire, c'è la possibilità di fare una sorta di backup delle impostazioni e di altro, in modo da non dover perdere poi tempo in fase di reinstallazione?
Grazie

Antonio Marino (anto-marino) said : #6

ho lo stesso identico problema da quando ieri ho installato gli aggiornamenti.
Come posso risolvere?

P.S: anch'io ho installato con wubi, il cd è quello inviatomi da canonical, ubuntu 9.10

Antonio Marino (anto-marino) said : #7

ho lo stesso identico problema da quando ieri ho installato gli aggiornamenti.
Come posso risolvere?

P.S: anch'io ho installato con wubi, il cd è quello inviatomi da canonical, ubuntu 9.10

Sergio Zanchetta (primes2h) said : #8

Quando ti compare il menu di scelta all'avvio, prova a selezionare
un'altro kernel al posto dell'ultimo installato con gli aggiornamenti.
L'ultimo dovrebbe essere il 2.6.31-15, tu prova il 2.6.31-14 o 13.

Antonio Marino (anto-marino) said : #9

Non posso, ovvero a me compare il menu di scelta di win (devo scegliere windows o ubuntu) e scegliendo ubuntu mi compare l'errore senza darmi la possibilità di scegliere quale kernel caricare.

Sergio Zanchetta (primes2h) said : #10

Allora, per risolvere il problema dovrete lanciare alcuni comandi che vi darò in seguito.
Fate attenzione a farli corretti, sono operazioni un po' delicate.
Per evitare qualsiasi problema vi consiglio anzi di fare un backup dei dati che avete in win.
Prima di tutto ho bisogno di sapere se Ubuntu è stato installato con Wubi nel disco C: o da un'altra parte, e quante partizioni avete nel vostro computer.

Antonio Marino (anto-marino) said : #11

ubuntu è installato in C: con wubi, ho un'altra partizione, ma è quella di recovery della hp, che non dovrei toccare...
quali comandi andreamo ad eseguire? c'è il rischio che si danneggi win?

Sergio Zanchetta (primes2h) said : #12

Il 26 novembre 2009 16.09, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino posted a new comment:
> ubuntu è installato in C: con wubi, ho un'altra partizione, ma è quella di recovery della hp, che non dovrei toccare...
> quali comandi andreamo ad eseguire? c'è il rischio che si danneggi win?
>

Se i comandi sono inseriti correttamente non c'è problema, servono a
ripristinare Ubuntu.
Per adesso ti indicherò solamente dei comandi che riportano
informazioni utili, quindi non c'è problema.
Per prima cosa per sapere come sono configurate le partizioni devi
riportarmi l'output dei due comandi:
ls
root

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Antonio Marino (anto-marino) said : #13

ls:
(loop0) (hd0) (hd0,2) (hd0,1)

root:
(loop0) : Filesystem is ext2.

Sergio Zanchetta (primes2h) said : #14

Allora, direi che ci sono due soluzioni se volete.

La prima è la + semplice però comporta la rimozione dell'installazione esistente di Ubuntu e la reinstallazione sempre tramite Wubi con un comando da eseguire dopo l'aggiornamento.
Se non avete dati importanti (magari l'avete appena installato) è la soluzione migliore.
Dovete disinstallare Ubuntu da Windows, che la gestisce come applicazione di Windows stesso.
Reinstallate Karmic tramite wubi, riavviate, entrate in Ubuntu, fate tutti gli aggiornamenti ma prima di riavviare aprite un terminale (Applicazioni->Accessori->Terminale) e digitate:
sudo update-grub2
Quando riavvierete non riscontrerete + il problema.

La seconda soluzione è quella + complessa e delicata di cui parlavo precedentemente, ma se fatta nella maniera giusta non comporta problemi, ed è quella che vi permetterebbe di recuperare l'installazione attuale.
Non la riporto ancora qui perchè preferisco prima capire se volete usare la prima.
In caso contrario ditelo che vi darò le indicazioni da seguire passo passo.

Ho messo il bug come critical e nel bug stesso il creatore di Wubi sta già raccogliendo informazioni per capirne la causa per poi arrivare a un fix.
Il problema di base deriva dal fatto che Karmic usa il nuovo grub2 al posto del vecchio e collaudato grub per gestire il boot.
Come tutte le cose nuove portano moltissimi vantaggi con il rischio di qualche piccolo (o grande) problema.
Probabilmente un aggiornamento ha inibito l'update di grub2 stesso nell'installazione di Ubuntu tramite Wubi (in una installazione normale il problema non si verifica).

Antonio Marino (anto-marino) said : #15

in ubuntu non ho dati perchè li tengo tutti in windows, però reinstallare mi seccherebbe perchè dovrei reinstallare i programmi etc.
intanto potresti postare la soluzione, così ci do un'occhiata e valuto se ne vale la pena.
Grazie tante per l'aiuto.

Sergio Zanchetta (primes2h) said : #16

Il 27 novembre 2009 14.30, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino posted a new comment:
> in ubuntu non ho dati perchè li tengo tutti in windows, però reinstallare mi seccherebbe perchè dovrei reinstallare i programmi etc.
> intanto potresti postare la soluzione, così ci do un'occhiata e valuto se ne vale la pena.
> Grazie tante per l'aiuto.
>

Una domanda prima di scriverti i comandi.
Ma hai anche una partizione d: in windows?

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Antonio Marino (anto-marino) said : #17

si, ho la partizione di recovery dell'HP in D:

Sergio Zanchetta (primes2h) said : #18

È una configurazione un po' strana avere la partizione di recovery vista come D:
Inoltre quando dai ls ottieni
(loop0) (hd0) (hd0,2) (hd0,1)
Lasciando stare le prime due, vengono riconosciute due partizioni.
Per farti capire meglio

(hd0) corrisponde a /dev/sda

(hd0,1) corrisponde a /dev/sda2
(hd0,2) corrisponde a /dev/sda3

manca (hd0,0) che di solito corrisponde a /dev/sda1
È probabile che in questo caso sia una partizione di spazio non utilizzato o libero.
Le altre due, una è quella che corrisponde a c: (dove hai anche Ubuntu installato tramite wubi) e l'altra corrisponde a d: (dove mi dici che hai la partizione di ripristino).

Come ultima domanda prima di riportarti i comandi dammi il risultato di questi:
ls (hd0,1)
ls (hd0,2)

Scusami per la lentezza nelle risposte ma vedrò di essere molto veloce nella prossima.

Antonio Marino (anto-marino) said : #19

ecco il risultato:

Partition hd0,1: Filesystem type ntfs, UUID 9e0c5ec80c5e9adb

Partition hd0,2: Filesystem type ntfs, Label RECOVERY, UUID 2c88743c887

io ho windows 7 e ora che mi ci hai fatto pensare la partizione (hd0,0) potrebbe essere una parte di disco che windows 7 crea all'installazione e che non è visibile
per scrupolo ho eseguito ls (hd0,0) che mi ha restituito "error: no such partition"

ti chiedo di tenere conto (nel caso si vada a modificare il boot di win7) che, oltre a poter scegliere windows o ubuntu posso scegliere (anzi devo) il loader della 'cura' di win7

Grazie per l'aiuto

Sergio Zanchetta (primes2h) said : #20

Il 11 dicembre 2009 16.26, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino posted a new comment:
> ecco il risultato:
>
> Partition hd0,1: Filesystem type ntfs, UUID 9e0c5ec80c5e9adb
>
> Partition hd0,2: Filesystem type ntfs, Label RECOVERY, UUID 2c88743c887
>
>
> io ho windows 7 e ora che mi ci hai fatto pensare la partizione (hd0,0) potrebbe essere una parte di disco che windows 7 crea all'installazione e che non è visibile
> per scrupolo ho eseguito ls (hd0,0) che mi ha restituito "error: no such partition"
>

Penso che sia spazio libero, non risulta neanche partizionato.

> ti chiedo di tenere conto (nel caso si vada a modificare il boot di
> win7) che, oltre a poter scegliere windows o ubuntu posso scegliere
> (anzi devo) il loader della 'cura' di win7
>

il loader intendi la partizione di ripristino (il d:) immagino.
Quello solitamente lo fai partire con una combinazione di tasti ( o
un tasto funzione) al boot, è un parametro configurato nel bios.

Comunque questi sono i comandi

sh:grub> linux /boot/vmlinuz-2.6.31-14-generic root=/dev/sda2
loop=/ubuntu/disks/root.disk ro
sh:grub> initrd /boot/initrd.img-2.6.31-14-generic
sh:grub> boot

Dato che non so se hai il kernel 2.6.31-14 o il 2.6.31-15 fai cosi:
inizia a scrivere il primo comando, quando sei a
linux /boot/vmlinuz-2.6.31-
premi il tasto tab in maniera da completare automaticamente il nome
del file in base alla versione installata, e poi finisci di scrivere
la riga.
La seconda riga ovviamente seguirà lo stesso valore della prima riga.

Ciao.

> Grazie per l'aiuto
>
> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Antonio Marino (anto-marino) said : #21

ho fatto il tab quando mi hai detto tu e mi dava tutte e due le versioni di kernel, ho provato la 15 e mi ha dato 'error:invalid magic number' allora ho messo il 14 e i comandi si sono eseguiti senza errori.
Quando però do 'boot' esegue delle istruzioni e si ferma, sono riuscito a notare però, che esce scritto che non trova root.disk e avvia la busybox che mi fa vedere la lista delle periferiche collegate e si ferma.
Ho controllato in win che il file root.disk esiste.

Cosa si può fare?

Sergio Zanchetta (primes2h) said : #22

Il 11 dicembre 2009 18.36, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino posted a new comment:
> ho fatto il tab quando mi hai detto tu e mi dava tutte e due le versioni di kernel, ho provato la 15 e mi ha dato 'error:invalid magic number' allora ho messo il 14 e i comandi si sono eseguiti senza errori.
> Quando però do 'boot'  esegue delle istruzioni e si ferma, sono riuscito a notare però, che esce scritto che non trova root.disk e avvia la busybox che mi fa vedere la lista delle periferiche collegate e si ferma.
> Ho controllato in win che il file root.disk esiste.
>
> Cosa si può fare?

Vuoi dire che ora non ti da neanche la shell di grub?
Potresti riportarmi qui cosa ti esce?

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Sergio Zanchetta (primes2h) said : #23

Il 11 dicembre 2009 19.17, Sergio Zanchetta <email address hidden> ha scritto:
> Il 11 dicembre 2009 18.36, Antonio Marino
> <email address hidden> ha scritto:
>> Question #91579 on grub2 in ubuntu changed:
>> https://answers.edge.launchpad.net/ubuntu/+source/grub2/+question/91579
>>
>> Antonio Marino posted a new comment:
>> ho fatto il tab quando mi hai detto tu e mi dava tutte e due le versioni di kernel, ho provato la 15 e mi ha dato 'error:invalid magic number' allora ho messo il 14 e i comandi si sono eseguiti senza errori.

Dimenticavo, quando hai messo la 14 hai modificato anche la seconda
riga (sempre con 14) oltre alla prima?

>> Quando però do 'boot'  esegue delle istruzioni e si ferma, sono riuscito a notare però, che esce scritto che non trova root.disk e avvia la busybox che mi fa vedere la lista delle periferiche collegate e si ferma.
>> Ho controllato in win che il file root.disk esiste.
>>
>> Cosa si può fare?
>
> Vuoi dire che ora non ti da neanche la shell di grub?
> Potresti riportarmi qui cosa ti esce?
>
>
>> --
>> You received this question notification because you are an answer
>> contact for Ubuntu.
>>
>
>
>
> --
> Sergio Zanchetta <email address hidden>
>

--
Sergio Zanchetta <email address hidden>

Antonio Marino (anto-marino) said : #24

si, ho cambiato anche la seconda e il kernel si è caricato correttamente.
la shell di grub c'è ancora come prima.
il fatto è che dopo aver eseguito le due righe invio "boot" e inizia l'avvio (non so esattamente cosa faccia perchè è troppo veloce e non si riesce nemmeno a leggere), ad un certo punto rimango con (initframs) e non va avanti, io però ho notato che tra tutte le 'scritte veloci' c'era scritto "ALERT: root.disk not found" o qualcosa di simile.

Sergio Zanchetta (primes2h) said : #25

Il 11 dicembre 2009 19.29, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino posted a new comment:
> si, ho cambiato anche la seconda e il kernel si è caricato correttamente.
> la shell di grub c'è ancora come prima.
> il fatto è che dopo aver eseguito le due righe invio "boot" e inizia l'avvio (non so esattamente cosa faccia perchè è troppo veloce e non si riesce nemmeno a leggere), ad un certo punto rimango con (initframs) e non va avanti, io però ho notato che tra tutte le 'scritte veloci' c'era scritto "ALERT: root.disk not found" o qualcosa di simile.
>

Prova a lanciare un comando aggiuntivo prima degli altri.

Questa la sequenza completa (prova con il kernel -15 prima e se non
funziona usa il -14)

sh:grub>set root=(loop0)
sh:grub>linux /boot/vmlinuz-2.6.31-14-generic root=/dev/sda2
loop=/ubuntu/disks/root.disk ro
sh:grub>initrd /boot/initrd.img-2.6.31-14-generic
sh:grub>boot

Se il boot va a buon fine, ricordati di lanciare anche questo comando
da terminale per risolvere il problema alla radice:

sudo update-grub2

Ciao.

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Antonio Marino (anto-marino) said : #26

niente, stesso problema
"ALERT! /host/ubuntu/disks/root.disk does not exist. Dropping to a shell!"

Antonio Marino (anto-marino) said : #27

credo di aver capito perchè fa così.
nonostante root.disk esiste davvero, mi da quell'errore perchè in /ubuntu/disks/boot/grub non c'è nulla e a quanto ho capito dovrebbero esserci file di configurazione del grub. come potrei fare?

Sergio Zanchetta (primes2h) said : #28

Il 12 dicembre 2009 15.57, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino posted a new comment:
> credo di aver capito perchè fa così.
> nonostante root.disk esiste davvero, mi da quell'errore perchè in /ubuntu/disks/boot/grub non c'è nulla e a quanto ho capito dovrebbero esserci file di configurazione del grub. come potrei fare?

No, ho il forte sospetto che ti dia quell'errore perché non e' sda2 la
partizione giusta in cui deve andare a guardare.
Probabilmente, non essendo partizionata, la prima parte del tuo hard
disk (hd0,0) non viene vista come sda1 come dovrebbe comunemente
essere, e quindi il tuo c: è proprio sda1.

Prova a ridare tutti gli ultimi comandi cambiando sda2 con sda1.

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Antonio Marino (anto-marino) said : #29

grazie, sono riuscito ad avviare ubuntu, però nonostante dia
sudo update-grub2
quando riavvio ho lo stesso problema.

Sergio Zanchetta (primes2h) said : #30

Il 13 dicembre 2009 16.25, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino posted a new comment:
> grazie, sono riuscito ad avviare ubuntu, però nonostante dia
> sudo update-grub2
> quando riavvio ho lo stesso problema.
>

Prova a rifare la procedura, rientra, aggiorna il sistema con gli
ultimi pacchetti e quando ha finito, prima di riavviare, lancia il
"sudo update-grub2".

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Sergio Zanchetta (primes2h) said : #31

Giusto per chiarire, il sistema non ti riparte + perché tu la
procedura descritta l'hai fatta sul kernel -14.
Quando riavvi lui prende in automatico l'ultimo kernel disponibile il,
-15, da qui il problema.
Se aggiorni il sistema ti installa il kernel -16, se poi dai sudo
update-grub2 dovresti assicurarti di rendere definitive le modifiche.

Antonio Marino (anto-marino) said : #32

ho fatto così ma niente

Sergio Zanchetta (primes2h) said : #33

Hai installato tutti gli aggiornamenti e poi ridato "sudo update-grub2"?
Ti da qualche errore? Notato qualcosa di strano?

Con "niente" intendi che hai fatto tutto ma al riavvio ti ritorna alla
shell di grub?

Se hai fatto gli aggiornamenti e ti ha installato il kernel -16 come
ulteriore prova rifai la procedura usando il kernel -16.

Antonio Marino (anto-marino) said : #34

si, installato gli aggiornamenti update-grub2 va senza errori e poi mi torna alla shell grub.
se uso il kernel -16 mi dice invalid magic number

Sergio Zanchetta (primes2h) said : #35

Il 14 dicembre 2009 15.24, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino posted a new comment:
> si, installato gli aggiornamenti update-grub2 va senza errori e poi mi torna alla shell grub.
> se uso il kernel -16 mi dice invalid magic number
>

Prova a fare cosi, quando avvi appena selezioni Ubuntu dal menu, prova
a premere il tasto esc (mi sembra) per entrare nel menu di grub e
seleziona il kernel -14.
Dimmi se cosi riesci ad entrare.

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Antonio Marino (anto-marino) said : #36

ho provato, non esce il menu di grub, solo la shell

Best Sergio Zanchetta (primes2h) said : #37

C'è una patch disponibile nel bug report ed è da testare.

Scarica questo file
http://launchpadlibrarian.net/36920146/wubildr
e posizionalo in C:/ ricordandoti di rinominare prima il file già esistente all'interno in wubildr.OLD in modo da poter ripristinare, se necessario, la situazione originale.

Antonio Marino (anto-marino) said : #38

Funziona, tutto è stato risolto con quel file.
Grazie mille per l'aiuto.

Sergio Zanchetta (primes2h) said : #39

Il 18 dicembre 2009 15.42, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino proposed the following answer:
> Funziona, tutto è stato risolto con quel file.
> Grazie mille per l'aiuto.
>

Prego. :)
Puoi mettere la domanda come "solved" per favore?

Ciao

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Sergio Zanchetta (primes2h) said : #40

Il 18 dicembre 2009 16.19, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Summary changed to:
> [SOLVED]Dopo aggiornamento non parte più
>

No, non devi cambiare l'intestazione della domanda.
Da qualche parte dovrebbe esserci un pulsante con scritto "Solved".
Basta che fai clic sopra.

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Antonio Marino (anto-marino) said : #41

non ho nessun pulsante, credo lo abbia solo l'autore della domanda.

Sergio Zanchetta (primes2h) said : #42

Il 18 dicembre 2009 16.27, Antonio Marino
<email address hidden> ha scritto:
> Question #91579 on grub2 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/grub2/+question/91579
>
> Antonio Marino proposed the following answer:
> non ho nessun pulsante, credo lo abbia solo l'autore della domanda.
>

Ah, è vero, non sei tu.

Giuliano, per favore potresti metterla come "Solved"?

Grazie.

> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Sergio Zanchetta <email address hidden>

Giulianoc76 (giuliano) said : #43

Questa sera o al massimo domani provo a vedere se riesco a risolvere anch'io il problema, poi non mancherò di mettere Solved
Grazie

Giulianoc76 (giuliano) said : #44

Problema risolto.
Grazie mille a tutti

Giulianoc76 (giuliano) said : #45

Thanks Sergio Zanchetta, that solved my question.