wubi installation problem

Asked by Greg M on 2012-07-03

I installed wubi on my vista laptop so I could install/run Ubuntu from a usb flash drive. When I rebooted I saw the 2 selections, 1) windows vista and the 2nd for Ubuntu. When I select Ubuntu I get the following error;
 Status: 0xc000000e
File \ubuntu\winboot\wubildr.mbr

I checked the wubi-12.04-rev266 file but couldn't make any sense of what it said.
How can this be fixed?

Question information

Language:
English Edit question
Status:
Solved
For:
Wubi Edit question
Assignee:
No assignee Edit question
Solved by:
Greg M
Solved:
2012-07-07
Last query:
2012-07-07
Last reply:
2012-07-07
bcbc (bcbc) said : #1

If you can see the USB flash drive from the BIOS i.e. if you choose the BIOS Boot menu and it recognizes it, then generally you can boot from it. But if the BIOS cannot see it then Ubuntu won't be able to boot, or rather, Windows' boot manager will not be able to call the wubildr.mbr that boots Ubuntu.

That seems likely.

Also, some USB drives require some special software to mount (password protected ones), in which case they won't work even if your BIOS can see it.

Greg M (greg-magyar) said : #2

The BIOS can see the usb hard drive. I actually had fedoar loaded before and it would boot when I changed the bios to boot from the usb drive. Also when I boot to vista I can see the usb hd with ubuntu folders & files.

Any other thoughts?
Thanks

bcbc (bcbc) said : #3

The simplest explanation is that the wubildr.mbr is not in the location specified (but IMO the most common explanation is the first one I gave). You can verify very easily that the wubildr.mbr exists where it should.
Other than that, if you are sure the BIOS can see the drive, then there could be some issue with the bcd configuration that is causing the error.

Please output the result of "bcdedit" from a command prompt (select 'Run as administrator'). Also output the result of:
dir x:\ubuntu\winboot
(where x: is the USB drive)

You could also theoretically modify the bcd store to use the wubildr.mbr that's on the C: drive. That should at least fix the immediate issue to get the wubildr.mbr loaded, and then see if there are any more issues. For the commands to modify the bcd store, you'll have to refer to Microsoft's website.

Greg M (greg-magyar) said : #4

The BIOS does see the usb hd. I could confirm the hd name through the BIOS boot screen.
I tried setting the boot drive first to the usb hd through the BIOS and then through the BIOS boot manager but it would not boot to ubuntu.
In windows I can see the usb with the ubuntu dir and files. I opened the permissions for the one user (me) thru windows. The permissions were already opened for admin. This probably doesn’t matter since this is under windows, right?
The wubildr.mbr is in the \ubuntu\winboot dir. It is an 8KB file.
Directory of E:\ubuntu\winboot

07/04/2012 12:18 PM <DIR> .
07/04/2012 12:18 PM <DIR> ..
07/04/2012 12:18 PM 135,675 wubildr
07/04/2012 12:08 PM 29 wubildr-bootstrap.cfg
07/04/2012 12:08 PM 1,463 wubildr.cfg
07/04/2012 12:08 PM 8,192 wubildr.mbr
07/04/2012 12:08 PM 10,240 wubildr.tar
               5 File(s) 155,599 bytes
               2 Dir(s) 996,064,546,816 bytes free

I tried checking the current structure of my boot configuration data by running
Bcdedit /enum all from the windows\system32 dir but got the following message

The boot configuration data store could not be opened.
Access is denied.

I am logged in as admin. Is there a permissions problem?
Thanks

bcbc (bcbc) said : #5

You need to run the command prompt as an administrator. i.e. Hit the windows key, type 'cmd', look above to see CMD.EXE and right click it and select Run as Administrator. Then 'bcdedit' or 'bcdedit /enum' will output the results (both commands are equivalent as /enum active is the default).

Greg M (greg-magyar) said : #6

Good, I was able to run it as admin. Before I do post it are there any security issues with displaying the entire printout?

What specifically r u looking for?

bcbc (bcbc) said : #7

I don't think there's any security issue displaying that content. But you don't have to. This is what my Ubuntu entry looks like. I'm curious what your device entry looks like.

Real-mode Boot Sector
---------------------
identifier {c001df0c-5ec0-11e1-a466-005056c00008}
device partition=C:
path \ubuntu\winboot\wubildr.mbr
description Ubuntu

I've already mentioned the most common problems with booting from an external drive. Since these don't seem to apply I'm just digging for more information to see if something obvious pops up. The problem is one of Windows finding and loading wubildr.mbr (grub4dos).

The other option is to just install directly to that drive, not with wubi - since you can boot from it already, there's no advantage using wubi. This may be the simplest thing.

Greg M (greg-magyar) said : #8

Here is the real-mode boot sector;

Real-mode Boot Sector
---------------------
identifier {6195ce50-c316-11e1-ba77-001e336b0723}
device unknown
path \ubuntu\winboot\wubildr.mbr
description Ubuntu

Comparing to yours I see the device is not known.
The windows boot loader and boot manager both list device as partition=C:
Is this the cause of the problem? If so I did see help on correcting changes to partition/disk structure at http://www.pronetworks.org/forums/how-to-edit-the-windows-vista-boot-menu-options-t79102.html
What do you think?

bcbc (bcbc) said : #9

Yes that's likely the issue.

You could follow the instructions on that website - they look reasonable. If you're going to do that you could always just point it at C:\wubildr.mbr - it's always copied there and it doesn't matter where you run it from because wubildr.mbr checks on every partition for the file wubildr. But if you can get it pointing at the right partition that should work as well - I'm not sure why Windows didn't add that automatically though - maybe it doesn't consider the drive to be assigned permanently (e.g. if you inserted a different USB it would get assigned the same drive letter). There must be some reason that the device is empty?

What's strange is that Windows should probably have kicked out an error instead of adding a boot entry for an 'unknown' device.

Greg M (greg-magyar) said : #10

I did back up the BCD store.

So based on the directions I referenced above I should do the following at a cmd prompt;

e:\>e:\boot\fixntfs.exe -lh -all (Where e: is the drive/partition on which the folder "boot" is to be found)

bcdedit /set {6195ce50-c316-11e1-ba77-001e336b0723} device partition=e: Changes boot partition of the OS whose GUID is indicated. (Where e: is new drive/partition required). Must be used together with the osdevice command below

bcdedit /set {6195ce50-c316-11e1-ba77-001e336b0723} osdevice partition=e: Changes boot partition of the OS whose GUID is indicated. (Where e: is new drive/partition required). Must be used together with the device command above

where e: is my usb drive. I assume if I do this I'll need to make sure this drive shows up as e drive before booting?

Lastly I noticed the ubuntu dir on the usb drive only has a few files on it. Does the balance of the installation get downloaded after the wubi works correctly?

bcbc (bcbc) said : #11

The main file is the root.disk. This is a 'virtual partition' which gets loaded when Ubuntu boots. That's how you can install it within Windows. Otherwise you need a real partition to run Ubuntu. This makes Wubi good for testing out Ubuntu. But it's not ideal because it's more corruption prone e.g. if you hard power off while Ubuntu is running. That's why I suggested you just install direct to the USB stick.

So I don't know about that fixntfs bit - didn't notice that. As I said, you just have to get the windows boot manager to call wubildr.mbr. So you might as well just call it on the C: drive (C:\wubildr.mbr). But if you're comfortable doing those commands you should do whatever you want. This isn't a regular sort of thing one normally does with Wubi...

Greg M (greg-magyar) said : #12

Thanks for all your help. Since I was able to install and run Ubuntu from the usb hd I just went that route. So I won't pursue wubi.
Thx