Wubi broke windows and didn't even install Ubuntu.

Asked by Fydrenak Drenéa on 2012-06-12

I haven't ever used a different operating system other than windows before and I decided to give Ubuntu a try, so 'Wubi' the windows installer seemed perfect for an easy install. I created a 50gb partrition of my hard drive then ran wubi. All seemed to go well, I selected the partrition in the application and entered a username and password, then the app did its stuff and asked me to reboot. I clicked "Reboot Now".

Now this is where my problem is, when my computer loaded up I never got the screen that I was told I would get by the installation instructions which would allow me to choose which OS to boot my computer with, but instead I got an error message saying "Error: No such Device: <random letters and numbers go here>" and then below it, "grub recover>".
I had absolutely no idea what to do at this point so I restarted my computer and attempted to boot from my windows hard disk again using the Miltiboot selection menu which appears when I press F12. I then saw exactly the same error as I had the first time.
So then I learned how to put ubuntu onto a LiveUSB and run it from there, which got to the purple screen with the loading dots and then all the graphics completely broke and the PC froze.
So I then moved onto the third method of installing Ubuntu - using a CD. This gave exactly the same results as the Live USB. Having had all this fail I used one of my other computers to create a windows recovery disk and this allowed me to perform a system restore on my near-broken computer, but when I boot it I still get the "grub rescue>" error.
So my windows distribution is Unbootable & Ubuntu appears not to run on my computer, brilliant. I tried booting a different OS (Back|Track 5) using a live USB. This runs perfectly with no errors but is not suitable to fix my problems, but prooved that it is wubi that messed everything up.

I am now completely out of ideas and to be honest, don't really care about Ubuntu after all this, I would just like to be able to boot my windows installation and carry on as notmal. I know I definitely should have backed up all the data but it is quite a lot of stuff (almost 1tb) and I'm 14 so can't afford any good external hard drives to back things up onto. Sorry for this massive wall of text but it did say "Include as much detail as possible".
Thanks in advance...
          -Fydrenak
P.S The laptop spec is 8gb of Ram and a core i7 Q @ 1.6ghz. Can't get more info because I can't load an OS except Back|track 5R2 which I have no idea how to use.

Question information

Language:
English Edit question
Status:
Answered
For:
Wubi Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-12
Last reply:
2012-06-12

Wubi installs to NTFS so you didn't need to create any partitions at all. If you want, you can install to the partition you made and make a real dual boot. Wubi stores a disk file in your NTFS which is loop mounted at boot and used.

You can repair the Windows boot with the WIndows install media, you can then reboot to windows OK. If you install Ubunt to the space you made instead of Wubi you'll probably find it boots ok.

Fydrenak Drenéa (fydrenak) said : #2

My thanks for your quick reply! Unfortunately the laptop came with windows 7 pre-installed and I got no disks or anything with it so I have no instalation media to use for that. And I have no idea how to do anything like installing to the partrition that I made without a working OS. Is there a way to do this?

Not sure, there may be 3rd party apps, or you could borrow a friends CD as you are just using it to instate the boot loader.

bcbc (bcbc) said : #4

I'd recommend creating a bug report. There've been a few reports that the 'one-time' boot for Wubi doesn't get reset. If this is really happening (nothing conclusively shown yet) then this is likely a Windows bug (it's the Windows boot manager) that controls this and is supposed to reset following the first Ubuntu boot.
However, this one-time boot is not necessary for Wubi, so even though it's technically a windows bug (assuming that's what happened) it would be better to stop doing this in wubi if it saves people from your misery. (And if you look on ubuntuforums.org there's a case very similar to yours http://ubuntuforums.org/showthread.php?t=1996785 )

If it is a Wubi issue you should get a grub prompt> not a grub rescue> . The rescue means that you have grub in your MBR (master boot record) but this might have occurred when you were trying to 'repair' by reinstalling from CD/USB. It's hard to know what state you're in now and what would have been a factor in that.

I'd recommend following up with the developers - and the only way to do this is to file a bug report and or contact them through the IRC in #ubuntu-installer channel. This wubi answers section is not well supported (I used to monitor it, but won't be in the future).

You can get a Win7 repair CD from a running Win7 computer (maybe a friend's or in the store) or download an ISO from the net for $10 and burn it to a CD. This should allow you to reinstall the windows bootloader from a repair prompt:
bootrec /fixmbr

And manually tweak the bcd (boot manager) settings using the command:
bcdedit
For help:
bcdedit /?

Can you help with this problem?

Provide an answer of your own, or ask Fydrenak Drenéa for more information if necessary.

To post a message you must log in.