No root file is defined,dual boot with Windows 7 Ultimate

Asked by KentC on 2012-02-17

Hi everyone,

I installed Windows 7 Ultimate first on my Lenovo B570, then used wubi.exe install with Ubuntu 11.10.

Everyone works normally but after the laptop reboots, it says finishing installation then pops up a message

No root file system is defined. Please correct this from the partitioning menu.

At the boot Mgr screen, i do see both Window 7 and Ubuntu as choices,i select Windows 7 and it's fine.

Try Ubuntu and it only works with Demo Mode! I've read we need to tell it the partition is "/"

How do i do this,and how can i run,as i tried that using commands and got nowhere!

I need Win7 for work but would like to add Ubuntu as well, any help????

I want to be able to use both of these OS's on my HDD, I'm only using 1 HDD and not sure what else I need to do to fix this problem, I've attempted the boot repair in linux as recommended and that didn't seem to matter!

Need assistance please!!

Question information

English Edit question
Wubi Edit question
No assignee Edit question
Last query:
Last reply:
KentC (kentc13) said : #1

Please have a look at this link above, I guess was given on that from the Boot Repair GUI that I ran.

bcbc (bcbc) said : #2

You have some stray GUID partition table data present:
"GUID Partition Table detected, but does not seem to be used."

This causes the Ubuntu installer to reject the disk. Have a look at fixparts:

Can you help with this problem?

Provide an answer of your own, or ask KentC for more information if necessary.

To post a message you must log in.