'error: unknown command 'loadfont'

Asked by Alex Moisescu on 2011-01-09

   Hello:

 After some system updates after I restarted I got the black screen and:

    error: unknown command 'loadfont'
    error: file not found

  I do have an Ubuntu CD. My computer (Toshiba Satellite Pro) has double boot, so I can also use Windows 7.

   I installed Ubuntu on top on Windows 7 and I assigned the D: disk fully for Ubuntu.

  How to solve this issue?

  Thank you,

  Alex

Question information

Language:
English Edit question
Status:
Solved
For:
Wubi Edit question
Assignee:
No assignee Edit question
Solved by:
bcbc
Solved:
2011-01-09
Last query:
2011-01-09
Last reply:
2011-01-09
bcbc (bcbc) said : #1

See the wubi megathread http://ubuntuforums.org/showthread.php?t=1639198

I just want to confirm that you installed Ubuntu on D:. Usually this problem only happens when it's installed on C:. If you're unsure you can run the bootinfoscript (link in that thread) and post the result to http://pastebin.ubuntu.com and let me know the address - then I'll take a look.

Alex Moisescu (alexfitness) said : #2

   Hello again:

  Thank you again for helping (about 3 weeks ago you've helped me with a
similar problem - after the first update I could not access either Win 7 or
Ubuntu ).

  I ran the bootinfoscript and I pasted the results here
http://pastebin.ubuntu.com/552044/

  I do not know how to read the results.

   What exactly should I do next ?

  Thanks,

  Alex

On Sun, Jan 9, 2011 at 3:58 AM, bcbc
<email address hidden>wrote:

> Your question #140719 on Wubi changed:
> https://answers.launchpad.net/wubi/+question/140719
>
> Status: Open => Answered
>
> bcbc proposed the following answer:
> See the wubi megathread http://ubuntuforums.org/showthread.php?t=1639198
>
> I just want to confirm that you installed Ubuntu on D:. Usually this
> problem only happens when it's installed on C:. If you're unsure you can
> run the bootinfoscript (link in that thread) and post the result to
> http://pastebin.ubuntu.com and let me know the address - then I'll take
> a look.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/wubi/+question/140719/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/wubi/+question/140719
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Best bcbc (bcbc) said : #3

OK it's not typical to see this error when Wubi is not on the same partition as Windows. At least I haven't seen it yet. But likely it is the same problem - basically the grub.cfg is incompatible with the wubildr file.

To fix:
Follow the instructions for Problem #2, Solution #1 in the Wubi megathread http://ubuntuforums.org/showthread.php?t=1639198

where it says /dev/sda1 you should use /dev/sda5:
sudo mkdir /media/win
sudo mount /dev/sda5 /media/win
sudo mount -o loop /media/win/ubuntu/disks/root.disk /mnt
sudo cp /mnt/boot/grub/grub.cfg /mnt/boot/grub/grub.cfg.copy
sudo chmod +w /mnt/boot/grub/grub.cfg
gksu gedit /mnt/boot/grub/grub.cfg

And then edit the grub.cfg file as described.
Reboot and select Ubuntu and boot into your Wubi install.

Go back to the Wubi megathread and follow the instructions for the Permanent Fix.

Alex Moisescu (alexfitness) said : #4

  Thanks again bcbc:

  Your post helped me solve my problem; I also locked the Grub versions in the Package Manager.

   Before I asked for your help, I red the solution, I tried to apply it but I did not know that I was supposed to write dev/sda5,so I wrote dev/sda1, and it did not work.

  Regards,

  Alex Moisescu
  Shanghai, China

Alex Moisescu (alexfitness) said : #5

Thanks bcbc, that solved my question.

bcbc (bcbc) said : #6

You're welcome. Glad to hear you got it sorted!

Alex Moisescu (alexfitness) said : #7

Hello:

Sorry to bother you again.

 Do you know how can I adjust screen brightness ?

 I run Ubuntu 10.04 on Toshiba Satellite Pro L551.

  Fn key does not work for adjusting screen brightness.
  The brightness applet doesn't work either.

  Thank you,

  Alex

On Sun, Jan 9, 2011 at 11:58 AM, bcbc
<email address hidden>wrote:

> Your question #140719 on Wubi changed:
> https://answers.launchpad.net/wubi/+question/140719
>
> Status: Open => Answered
>
> bcbc proposed the following answer:
> See the wubi megathread http://ubuntuforums.org/showthread.php?t=1639198
>
> I just want to confirm that you installed Ubuntu on D:. Usually this
> problem only happens when it's installed on C:. If you're unsure you can
> run the bootinfoscript (link in that thread) and post the result to
> http://pastebin.ubuntu.com and let me know the address - then I'll take
> a look.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/wubi/+question/140719/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/wubi/+question/140719
>
> You received this question notification because you are a direct
> subscriber of the question.
>

bcbc (bcbc) said : #8

Try adding "acpi_backlight=vendor" to your boot options. That's based on this thread (http://ubuntuforums.org/showthread.php?t=1321403) that may not be specific to your hardware but it seems worth a try.

See http://ubuntuforums.org/showthread.php?t=1613132 for how to set boot options (the first thread says "not for wubi" but - after the initial install - wubi works the same way.

Alex Moisescu (alexfitness) said : #9

Thanks,

 I find the threads too complicated for me.

  I found a way to adjust screen brightness through Power Management.

  Thanks again,

  Alex

On Mon, Jan 10, 2011 at 10:09 AM, bcbc <<email address hidden>
> wrote:

> Your question #140719 on Wubi changed:
> https://answers.launchpad.net/wubi/+question/140719
>
> bcbc posted a new comment:
> Try adding "acpi_backlight=vendor" to your boot options. That's based on
> this thread (http://ubuntuforums.org/showthread.php?t=1321403) that may
> not be specific to your hardware but it seems worth a try.
>
> See http://ubuntuforums.org/showthread.php?t=1613132 for how to set boot
> options (the first thread says "not for wubi" but - after the initial
> install - wubi works the same way.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>