ubuntu, wubi, grub 'oh my gosh"!!!

Asked by Pj Jns on 2011-01-06

Helllllllllllllllllllllp!!!!
Installed Ubuntu using Wubi, on an XP machine. During install 186 updates were found, clicked yes to install all including Grub bootloader. During reboot is when problem occurs, have rebooted 20 times, all operations cease and it always gets stuck right there with a message stating-

error: no such device
d86ee270-f189-41b8-921f-7fb16f7bec60
grub rescue_

I can't get to either operating system, which means I don't have the ability to open a terminal window. Using Bart PE I can get to some files and tried to uninstall using Wubi and rebooted, same error message. Deleted entire Ubuntu file and rebooted, same error message. Can also open a terminal window with Barte PE so I typed "fdisk/mbr", nothing.
Don't mind erasing the hard drive and starting over but I can't even get the os cd to load, just glad I used a spare pc to do this with.
Ok I know it's not broke, just munged a bit. Still want to try Ubuntu, when I get out of this mess will reinstall without Wubi and click no to Grub!!!!

Any suggestions on how to get out?????

Thanks,

Question information

Language:
English Edit question
Status:
Answered
For:
Wubi Edit question
Assignee:
No assignee Edit question
Last query:
2011-02-02
Last reply:
2011-06-28
bcbc (bcbc) said : #1

Stop deleting things... you just have to fix the bootloader. Then both Windows and Ubuntu would have been fine.

See the Wubi megathread http://ubuntuforums.org/showthread.php?t=1639198 Problem #1 Solution #1 or #2.

bcbc (bcbc) said : #2

This is an unfortunate problem that has been around since April 2010. The grub developers haven't got around to fixing it.

Anyway, so as I was saying - deleting parts of Wubi or reinstalling won't fix it. You just need to replace the grub bootloader which is now in your drive master boot record with a Windows equivalent. That's the only problem, unfortunately the symptoms are rather disturbing.

Once Windows is booting again, you might find issues trying to reinstall Wubi if you've deleted bits of it manually. You might need to follow the manual uninstall instructions from the wubi guide: https://wiki.ubuntu.com/WubiGuide#How%20do%20I%20manually%20uninstall%20Wubi%3F

Pj Jns (pjjns28) said : #3

OOHoooooo, I am laughing as I type this because, the once Window's is booting again Is A Problem!!! Don't seem to be able to get there from here, still stuck in mid boot. Can boot into Bart PE, (don't know what to do), can open a terminal window but whatever I type has no effect....

Looking forward to a reply,

bcbc (bcbc) said : #4

You reinstalled the windows bootloader, and then what happens? It's hard to tell from your description.
Do you have an Ubuntu CD you can boot from?

Pj Jns (pjjns28) said : #5

Hi there,

Feeling better, think I'm getting there slowly.
Formatted and renamed both hard drives, however reboot still halts looking for grub boot loader. I can see something called Ram Disk along with both hard drives in my computer, is that where information about grub is stored? Would have formatted it also but was afraid things would really be un-fixable afterwards.
Still want to try Ubuntu so I decided to just get rid of XP for the moment. Computer still won't recognize the cd to which Ubuntu is burned despite repeated attempts of making it first booting option. Is there a pre-installation program I should be using???

Thank you for your reply,

pjjns28

bcbc (bcbc) said : #6

Grub is in the drive MBR - master boot record. It has a basic part there but looks for the rest of it on the disk partition containing Ubuntu. With Wubi it can't find this as there is no partition (Wubi uses a virtual disk which is a physical file mounted as a loop device).
So that's why you just needed to replace the bootloader with Windows' bootloader. Removing Windows or Wubi files doesn't change anything. There's still that little helpless bootloader sitting there. There is no "Ramdisk" containing Grub - I don't know what that is.

So... I'm not sure where you are right now with formatted disks etc. but you will need a working cd or a usb stick containing Ubuntu to install it.

If you can't boot from your CD then - odds are - you have a bad burn. This happens surprisingly often. Go to http://www.ubuntu.com/desktop/get-ubuntu/download and look at Step 2. Select "I want to create a CD or USB" and then click "SHOW ME HOW".

Hope this helps.

Pj Jns (pjjns28) said : #7

Wow!,
Thank goodness I used a computer I did't need to experiment with. It was down two months forcing me to wipe both hard drives and still looking for a damaged grub boot loader every time it rebooted, (100 times).
Anyway, finally proud to say that problem with the pesky grub boot loader is gone. After repeated attempts of nothing working except Bart PE with limited options. I remembered it listed an alternate method on the Ubuntu site so in a last ditch effort used the usb creater to put Ubuntu on flash drive, changed booting order in bios and in f8, computer recognized it. Non-stop since then with a feeling of "Oooo Mommie Like". Getting here was a hassle but well worth it. Oh yea, I have even Macbuntu'd it but had to uninstall cause I chose the wrong size for my screen. Will be reinstalling tonight.
Before this, didn't know what a distro was. After this, Long live Distros!!!

pjjns,

ps,
One problem is don't see second hard drive in my computer. Is there a way to make it so without doing an un/install of the os.

Pj Jns (pjjns28) said : #8

thanks

Pj Jns (pjjns28) said : #9

Dumb me, after I re-read reply big thanks to bcbc.

José Antonio Rey (jose) said : #10

If this question has been answered, please mark it as solved. If you have another question please open another ticket.

Can you help with this problem?

Provide an answer of your own, or ask Pj Jns for more information if necessary.

To post a message you must log in.