error : no such device

Asked by Ramaraj Ramasamy on 2010-12-22

Hi,

I have just installed 'ubuntu windows installer' on Windows 7 machine. After firsttime shutdown, The system is not booting and displaying the below error.

Error Message :
  error: no such device : fd20bcaf-424b-489c-bbf8-664703bf801b"
  grab rescus>

System Details:
   Sony vaio VPCEB34EN
   Processor : Intel 64 bit
   Windows 7 was already installed and I have installed ubuntu on top of Windows 7.
   Windows 7 is installed in C drive Ubuntu is installed in G drive
   Dual boot mode

After making few search in internet, I have executed the "boot_info_script055.sh" script file and generated the RESULTS.TXT file.

The below is the contents of RESULTS.txt file.

                Boot Info Script 0.55 dated February 15th, 2010

============================= Boot Info Summary: ==============================

 => Grub 2 is installed in the MBR of /dev/sda and looks on the same drive in
    partition #256 for /boot/grub.

sda1: _________________________________________________________________________

    File system: ntfs
    Boot sector type: Windows Vista/7
    Boot sector info: No errors found in the Boot Parameter Block.
    Operating System:
    Boot files/dirs: /bootmgr /boot/bcd

sda2: _________________________________________________________________________

    File system: ntfs
    Boot sector type: Windows Vista/7
    Boot sector info: No errors found in the Boot Parameter Block.
    Operating System:
    Boot files/dirs: /bootmgr /Boot/BCD

sda3: _________________________________________________________________________

    File system: ntfs
    Boot sector type: Windows Vista/7
    Boot sector info: No errors found in the Boot Parameter Block.
    Operating System: Windows 7
    Boot files/dirs: /Windows/System32/winload.exe /wubildr.mbr /wubildr

sda4: _________________________________________________________________________

    File system: Extended Partition
    Boot sector type: -
    Boot sector info:

sda5: _________________________________________________________________________

    File system: ntfs
    Boot sector type: Windows Vista/7
    Boot sector info: According to the info in the boot sector, sda5 starts
                       at sector 2048.
    Operating System:
    Boot files/dirs: /ubuntu/winboot/wubildr.mbr /ubuntu/winboot/wubildr
                       /ubuntu/disks/root.disk /ubuntu/disks/swap.disk

sda5/Wubi: _________________________________________________________________________

    File system: ext4
    Boot sector type: -
    Boot sector info:
    Mounting failed:
mount: wrong fs type, bad option, bad superblock on /dev/loop1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

=========================== Drive/Partition Info: =============================

Drive: sda ___________________ _____________________________________________________

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition Boot Start End Size Id System

/dev/sda1 2,048 26,990,591 26,988,544 27 Hidden HPFS/NTFS
/dev/sda2 * 26,990,592 27,195,391 204,800 7 HPFS/NTFS
/dev/sda3 27,195,392 415,425,199 388,229,808 7 HPFS/NTFS
/dev/sda4 415,426,560 625,139,711 209,713,152 f W95 Ext d (LBA)
/dev/sda5 415,428,608 625,139,711 209,711,104 7 HPFS/NTFS

blkid -c /dev/null: ____________________________________________________________

Device UUID TYPE LABEL

/dev/loop0 squashfs
/dev/loop1 fd20bcaf-424b-489c-bbf8-664703bf801b ext4
/dev/sda1 64FAC1EFFAC1BD94 ntfs Recovery
/dev/sda2 227E420C7E41D965 ntfs System Reserved
/dev/sda3 FA9443B094436DE7 ntfs
/dev/sda4: PTTYPE="dos"
/dev/sda5 C0804F41804F3D62 ntfs Data Volume
/dev/sda: PTTYPE="dos"

============================ "mount | grep ^/dev output: ===========================

Device Mount_Point Type Options

aufs / aufs (rw)
/dev/sr0 /cdrom iso9660 (ro,noatime)
/dev/loop0 /rofs squashfs (ro,noatime)

Please let me know if you need any other details about this problem. Kindly provide me the solution to fix this.

Regards,
Ramaraj

Question information

Language:
English Edit question
Status:
Solved
For:
Wubi Edit question
Assignee:
No assignee Edit question
Solved by:
bcbc
Solved:
2010-12-23
Last query:
2010-12-23
Last reply:
2010-12-23
Best bcbc (bcbc) said : #1

See the Wubi Megathread... http://ubuntuforums.org/showthread.php?t=1639198 Problem #1, Solution #1 or #2

To summarise, wubi requires the windows bootloader, not grub. A bug that affects wubi installs to a partition other than the main windows partition (C: ) prompts users to install the grub bootloader to the MBR, which you have done. The thread explains all this and how to avoid problems in the future.

Note: if you use Windows repair you only need to reinstall the bootloader. For vista/7: bootrec.exe /fixmbr

Also, bootinfoscript couldn't access your root.disk, but this does not always mean there is a problem with it. If you can't boot Ubuntu after fixing your MBR post back and there are some options to fix it.

Ramaraj Ramasamy (r-ramaraj) said : #2

Your answer fixed the problem. Ubuntu is working fine. Now, I am able to use windows7 as well in dual boot mode.

Thanks a lot!!!

Ramaraj Ramasamy (r-ramaraj) said : #3

Thanks bcbc, that solved my question.