Update today -> Lucid26 ; Now no boot (only 'grub-rescue >') - HELP !!!

Asked by David R Halliday on 2010-11-30

I used UpdateManager today. It appeared to install a new version of Lucid (v26). plus a change to grub. All seemed to go well - on the detailed install-window, grub reported that it had detected Ubuntu and WindowsXP. It then asked for a restart to complete the installation. I pressed the 'restart' button-gadget, Ubuntu exited, the machine rebooted, and I got a black screen, with a heading : 'error : no such device: : ce08c688-fc53-3684-ab25-93f8fd2e9687.' and (on the next line) 'grub rescue> ' with a flashing prompt. I now can't get into either WndowsXP nor Ubuntu.

My machine is an Asus1001HA, with WindowsXP-SP3 pre-installed, to which I've added Ubuntu via wubi.

As you can imagine, I'm rather concerned that I've lost my machine. (BTW, I'm using an old machine for this message, and can receive-&-send emails &c on it, although it's very slow.)

Please, can someone help ...

Question information

Language:
English Edit question
Status:
Solved
For:
Wubi Edit question
Assignee:
No assignee Edit question
Solved by:
bcbc
Solved:
2010-12-05
Last query:
2010-12-05
Last reply:
2010-12-03
delance (olivier-delance) said : #2

https://help.ubuntu.com/community/Grub2#Reinstalling%20from%20LiveCD 1st process could be easier.
If it fails please provide partition table.
--------------------------------------------------------
1-How to get partition table?

Please provide partition table.

If you can't boot from hard drive, boot en Ubuntu CD/USB stik and then choose "Try without install".

Open a terminal: you can either press Ctrl+Alt+T or Applications->Accessories->Terminal.

To copy/paste in a terminal, replace Ctrl+C by Ctrl+Maj+C and Ctrl+V by Ctrl+Maj+V (for historical reason, Ctrl+C is assigned another function).

Paste to terminal one of the following commands:

    sudo fdisk -l

    sudo parted -l

where "-l" is lower case "L".The two commands provide data in a slightly different format.

Copy/paste result into a new thread post.

bcbc (bcbc) said : #3

Reinstall the Windows bootloader (just the bootloader). e.g. on XP boot to a repair prompt and run: "fixmbr" ; on vista/7 run: "bootrec.exe /fixmbr"

When you run grub-pc or grub-common updates, do not select to install it to any devices.

David R Halliday (hallidaydr) said : #4

Thanks for taking the time to reply. Unfortunately, my mother (aged 94, blind - I look after her) was taken to hospital on the morning after the grub2 disaster arose, So I haven't been able to look into the suggestions yet. So, apologies for the delay.

Entering 'ls' at the 'grub rescue> ' prompt yields '(hd0)', and nothing else. I take it that this is the HDD device as a whole, rather than a partition. The command 'ls (hd0)' gets the response 'error: unknown filesystem.' . So I can't get started on a rescue, since there's no indication of the 'prefix', which seems to be needed to run most grub2 commands.

If I could only see the HDD, it might be easier - but grub2 won't let me in. Indeed, I don't know if the HDD is still valid, or has partitions or data on it.
(BTW, all my data on the machine was backed-up to usb-stick - thank heavens!) In particular, I can't boot into Windows (not even to a 'repair prompt' as suggested by bcbc). I've tried pressing all the F-keys during boot, and the only ones that work are Esc (choose boot-device - only HDD listed) and F2 (BIOS editor - BIOS look ok, BTW).

Being a netbook, the machine doesn't have a CD/DVD device, so I can't use a Live CD. I tried the 'unetbootin' web-site to try to install Ubuntu onto a usb-stick, but it needs the 'mtools' & '7z' packages, which I don't have have on my old machine (whose system is so mangled that it won't install anything). And I don't have access to a Windows machine.

It's all complicated by the fact that Ubuntu runs via wubi, rather than from its own partition (and I don't really understand the 'loop' system used by wubi). In fact, I don't understand too many of the technicalities - I used wubi just to try-out Ubuntu, and simply updated via Ubuntu's UpdateManager. All quite innocent. I hope the result isn't that the computer has to be thrown-away.

Anyway, I'll try to get a bootable usb-stick using a friend's Windows machine and unetbootin. Then I might be able to see what's happened to my HDD. Please bear with me - this hasn't been the best week of my life so far.

Best bcbc (bcbc) said : #5

I'm sorry to hear about your mother.

Regarding the computer... there is absolutely nothing wrong with it apart from grub2 being in the master boot record. Just be careful not to try random things to it. You can't boot it from the grub rescue prompt - it's not possible.

You can, however, fix it from an Ubuntu live USB. Get a 2GB memory stick and using a friend's computer, go to http://www.ubuntu.com/desktop/get-ubuntu/download - go to Step 2, and click on "I would like to create a USB stick" and then SHOW ME HOW.
It has full instructions and pictures showing how to create a bootable USB for Ubuntu.

Then stick it in your Netbook, turn on and hit your boot options key and select to boot from it.
After that, select "Try without installing".

Then go to a terminal command prompt (press CTRL-ALT-t) and install lilo and patch your bootloader:
sudo apt-get install lilo
#hit ENTER to bypass huge warning screen which is not a problem - it relates to booting linux
sudo lilo -M /dev/sda mbr

Note: lilo installed in this way is equivalent to the Windows bootloader.
Note: usually /dev/sda is your internal drive. Sometimes when you boot from USB the USB stick becomes /dev/sda and your internal drive is /dev/sdb. You need to check this before running the above command. Entering "sudo fdisk -l" (small L) or "sudo blkid" will list your partitions and the number and size will reveal which one you want.

If you don't want to use this method then you will have to create a Windows repair USB. I don't have instructions for that on hand, but let me know if you prefer this and I can find them.

David R Halliday (hallidaydr) said : #6

Thanks bcbc, that solved my question.

David R Halliday (hallidaydr) said : #7

Indeed, many thanks to **everybody** who tried to help. The procedure (once I convinced my nephew that making a Ubuntu usb-stick wouldn't crash his machine) couldn't be simpler. And, as predicted, everything was safe-&-sound on the HDD (both WindowsXP & Ubuntu). I'm actually using the 1001HA now to write this.

One detail I forgot to mention : I set-up wubi with the disk-file installed on the Windows D:\ drive, ie. on a different drive from the Windows C:\ boot-drive. In the release-notes for UbuntuV10.10, there's a mention that this arrangement can cause problems. As I said, the update looked to proceed fine, detecting XP & Ubuntu, but obviously something lost its way somewhere. Ironically, I was actually in the process of migrating Ubuntu from wubi to a usb-stick (actually, to an SD-Card, if possible) when the problem arose - I thought I'd just fully-update Ubuntu first, before making the bootable usb-stick and uninstalling wubi.

Another small detail : On the first boot after the cure (ie. without the usb-stick for the first time), the machine tried to do an Asus factory-restore. I cancelled this, switched the machine off, then rebooted - and the usual grub-wubi screen came-up, offering the choice of XP or Ubuntu. The factory-restore may be just a result of Asus's design, but anyone else in my position needs to know that they should cancel that factory-restore (which would. if uncancelled, lose all their data & the wubi-Ubuntu system).

BTW, my mother's ok - tests showed nothing wrong. It's been very cold here (UK) lately, and she piled-on the blankets. The hospital thinks she just overheated (at 94, I guess her bodily temperature-control system isn't perfect).

And Ubuntu now has a new trial-customer : my nephew, with the rescue usb-stick.

David R Halliday (hallidaydr) said : #8

I've just received some posts from bcbc, who's trying to consolidate the wubi-grub2 bug-reports. I'm posting this note here, since I can't get into the 'Wubi Megathread' forum (having no ID) at 'http://ubuntuforums.org/showthread.php?t=1639198'. So I hope it'll reach bcbc using this route.

Perhaps I wrote too soon when I said that bcbc's lilo-install worked for me. A few days after posting my 2010-12-05 note, I found I couldn't access wubi anymore. Although the windows-bootloader screen came-up ok (asking XP vs Ubuntu), selecting 'Ubuntu' just got me a reboot, and so on, round in circles. (Selecting XP worked ok.) This behaviour is described in the Megathread as applying to lots of users ('Problem #2').

By pure accident, I found an easy way around this. Here it is :
1 : Turn-on the machine, select Windows at the Windows-bootloader screen, start reading 'War & Peace' while Windows loads.
2 : At the Windows login-screen, DON'T LOG-IN. Instead, click on 'Turn off computer...' at the bottom left-hand corner.
3 : In the subsequent mini pop-up window, click on 'Restart'. Windows starts saving your settings - finish reading 'War & Peace' while the machine reboots.
4 : Select 'Ubuntu' at the Windows-bootloader screen. You should then be presented with grub's list of available Ubuntu versions - select the latest (which is the countdown-default, anyway).
5 : Wubi-Ubuntu should boot normally !!!
6 : Open a shell ('Applications/Accessories/Terminal' in Ubuntu's standard menus - or just press Ctl-Alt-t), and type-in 'sudo update-grub', press return, enter your (administrator) password if prompted, press return. You should get a list of identified OS's, as grub rewrites its 'grub.cfg' file.
7 : Thereafter, selecting 'Ubuntu' at the Windows-bootloader screen should take you to grub's list of installed Ubuntu-versions, as per normal.

I can't say that this will work for everybody, but it did for me - wubi now works exactly as it should on my machine. I have no idea why it worked, but it saves having to boot from a CD/USB and manually rewrite the 'grub.cfg' file (which, with the possible mis-identifications of disks & partitions, is a bit scary, besides being rather techy for us newbies).

Perhaps someone else could try it on another machine - bcbc seems to have reproduced the problem on two of his machines, so perhaps he could try my solution.

For the record, my machine is an Asus1001HA netbook (ie. no CD/DVD), with WindowsXP-Home-SP3 on C:\ plus wubi with its 'root.disk' file on D:\.

Good luck, and again - many thanks.

bcbc (bcbc) said : #9

Thanks for the feedback David. I've been noticing lately that those affected by bug 610898 then go on to be affected by bug 682337. I've started recommending they do the 'permanent fix' from the Wubi megathread proactively to prevent this. But the Problem#2 Solution#1 fix is definitely a pain so a solution as easy as yours would be great!

I tried it on my machine... but it didn't work, though it did get me thinking. I decided to run CHKDSK and it reported that it recovered some file fragments. The next time I rebooted, Ubuntu booted normally! So your method might have worked but for that. I'll do a fresh install when I have time and try it out again.

I had seen a report a while back from someone that their install spontaneously started working again - but they didn't have a clue as to what they had done to fix it, so I had no idea how to test it out.

I enjoyed your comment about War and Peace. I don't have a copy but maybe Crime and Punishment will do instead: yes, this testing takes forever!