Gub Rescue, WIN7,XP,Ubuntu

Asked by Henri H on 2010-11-25

I get error message error: no such device: fc841b... and computer do not boot anymore to any operating system.

Yesterday (25.11.2010) I updated Ubuntu as automatic update offered. Then I got Grub window where I selected all harddrives. Then I was offered to restart and I did so. Then I got that message and operating system selection list was gone.

Earlier I had a list like: older version of Windows, Windows 7, Ubuntu.

Ubuntu was installed with wubi from Win7 and installation harddrive was physically different than others.

What can I do now?

This is my first experience with Linux and I know nothing about it, except now I know what grub means. Yesterday I didn't...

I don't have any installation/rescue cd:s for Linux.

Question information

Language:
English Edit question
Status:
Solved
For:
Wubi Edit question
Assignee:
No assignee Edit question
Solved by:
bcbc
Solved:
2010-11-26
Last query:
2010-11-26
Last reply:
2010-11-25
Best bcbc (bcbc) said : #1

You need to reinstall the windows bootloader.

From an XP repair command prompt run: fixmbr
From a Vista/7 repair command prompt run: bootrec.exe /fixmbr

There is also an option to recover from an Ubuntu live CD using lilo entering the following in a terminal window (CTRL-ALT-t):
sudo apt-get install lilo
sudo lilo -M /dev/sda mbr

(note that you will see 'dire' warnings about lilo needing xxxx, but this is related to booting a linux OS. You can safely ignore these). Those commands are case sensitive.

The reason for the problem is that grub should never be installed to the internal hard drive master boot record (MBR) when you are using wubi. Wubi installs go through the windows boot manager, so they need the windows boot loader. (And the grub bootloader cannot boot a wubi install directly from the MBR).

There is a bug in the grub package (and the related lupin package for loop mounted installs such as wubi) that fails to identify wubi installs if you didn't install on the same partition as windows (e.g. you put wubi on 'drive' D:, not on 'drive' C:). This then prompts you to install grub, and if you select to do so, it leaves you in an unbootable state.

Henri H (henrih) said : #2

This solved problem, thanks!

I used Win7 installation cd and after some version incompatibility error found way to command prompt. What was needed for booting was F8 after start for selecting boot drive, DVD drive in this case. I used bootrec.exe /fixmbr and then everything was ok. Now normal boot operating system selection list is back and all OS:s starts normally.