Genius Mousepen with no mouse support.

Asked by Ranando King on 2010-05-22

I've upgraded from Ubuntu 9.10 to 10.04. Right out the box, my tablet failed to function. The driver that comes with the release is (for whatever reason) not compatible with the X server in the same release. That makes no sense. Someone should've caught that. Anyway, after getting an update from the DoctorMO website, I can get the the pen to work just by adding appropriate X, Y, & Z limits to /usr/lib/X11/xorg.conf.d/70-wizardpen.conf. But the mouse that comes with the tablet will not function properly no matter how much I change the file. My tablet mouse and pen were both working perfectly before the upgrade. So It's not the hardware. The closest I've come to getting functionality from the mouse was to alter the above file as such:

------ begin 70-wizardpen.conf.
Section "InputClass"
   Identifier "wizardpen"
   MatchIsTablet "on"
   MatchDevicePath "/dev/input/event*"
   MatchVendor "UC-LOGIC|KYE Systems|Ace Cad"
   Driver "wizardpen"
   Option "TopX" "1800"
   Option "TopY" "2300"
   Option "BottomX" "32100"
   Option "BottomY" "32700"
   Option "TopZ" "10"
   Option "BottomZ" "1000"
EndSection

Section "InputClass"
   Identifier "wizardpen mouse"
   MatchIsPointer "on"
   MatchDevicePath "/dev/input/mouse*"
   MatchVendor "UC-LOGIC|KYE Systems|Ace Cad"
   Driver "mouse"
EndSection

------ end 70-wizardpen.conf.

With this configuration I'd get limited response from the mouse. Buttons would work, and mouse motion caused the cursor to move a little, but always return to the same location. The output from xinput --test shows that the mouse is indeed triggering movement events, but it's as if relative positioning was being used based on the previous position of the cursor (as put by the pen), and then treated as an absolute coordinate.

Please tell me there's an easy solution to this that doesn't involve not using my tablet mouse.

Question information

Language:
English Edit question
Status:
Solved
For:
Wizardpen Edit question
Assignee:
No assignee Edit question
Solved by:
Ranando King
Solved:
2010-05-24
Last query:
2010-05-24
Last reply:
Ranando King (kingmph) said : #1

After reading up on how to write an X input driver, then studying and toying with the driver code (literally changing and testing new versions), I finally came across the problem. THERE'S NO DEFAULT FOR Option "MouseSpeed"!!! So when the driver loads, all relative events (mouse events) get multiplied by 0 and added to the current position. Adding 'Option "MouseSpeed" "16"' to the above configuration makes everything except the wheel work normally. I'll put something up here when I get around to figuring that out too.

Martin Owens (doctormo) said : #2

Does setting up the mouse still disable the pen?

Ranando King (kingmph) said : #3

No, Both the mouse and the pen work together as you would expect (for the most part). There are still a few small quirks though, but nothing that should keep you from using both the mouse and pen as expected.

nh2 (nh2) said : #4

Did adding Option "MouseSpeed" "16" make your mouse work just like you would expect a mouse to work?

We tried it and had a very strange experience: If you bring the mouse near the pad, the mouse pointer is moved to that (absolute) location just as you would expect it with the pen. If you then move the mouse, it moves 2-3 cm into that direction, but automatically moves back when you stop moving. It is like the pointer being fixed to that location with a rubber band.

Do you know what the cause of this issue could be or where the corresponding code is?

Ranando King (kingmph) said : #5

I get the effect you describe if I have both the mouse and the pen over the pad at the same time. It seems the system gets confused in that case and does't know which input to follow. Short of that, the only real problem I still have is that some XT-style programs don't correctly recognize the 1st mouse button.