How do I change the text color in the window-picker "title bar"?

Asked by Brandon Williams

I am using a theme with a dark colored title bar. I'm trying to figure out how to change the text color in the window picker applet "title bar" when a window is maximized. I've tried making modifications to this block in the theme's panel.rc:

style "titlebar"
  fg[NORMAL] = "#000"
  fg[ACTIVE] = "#fff"

widget "*PanelApplet*TaskTitle*" style "titlebar"

Changing the values for fg[NORMAL] and fg[ACTIVE], but it doesn't seem to have any effect.

Does anyone else know what I need to modify in gtkrc to impact the text color of the window picket applet?

Question information

English Edit question
window-picker-applet Edit question
No assignee Edit question
Solved by:
Brandon Williams
Last query:
Last reply:
Revision history for this message
Brandon Williams (opensource-subakutty) said :

Never mind ... I figured it out. The titlebar section above doesn't have any impact on the text color in the window-picker-applet. I had to change this section:
style "panel"

xthickness = 4
ythickness = 0

  fg[NORMAL] = "#666666"
  fg[ACTIVE] = "#E6E6E6"
  text[NORMAL] = "#ffffff"
  bg[NORMAL] = "#0a0a0a"
  bg[SELECTED] = "#0a0a0a"


widget "*PanelWidget*" style "panel"
widget "*PanelApplet*" style "panel"
class "*Panel*" style "panel"

In the original theme, fg[NORMAL] was set to "#ffffff" and fg[ACTIVE] was not set, making it the default value "#000000". The above fg[ACTIVE] settings make the text color in the window picker light enough that I can see it against a dark gray background. I didn't think to try fg[ACTIVE], since it wasn't in the block in the theme. I saw from the code that the title was being set ACTIVE, and so tried it out.

Revision history for this message
John Montgomery (blueyonder64) said :

You, my friend, are a genius. I've been wracking my brain over this issue with the Shiki Netbook theme for days now. Can't thank you enough, worked like a charm!

Revision history for this message
Necopinus (necopinus) said :

Anyone have an idea how to change this under 9.10? The suggested fix doesn't seem to do anything anymore...