Application not in RemoteApp List. Check help to fix this.

Asked by Mike Kongsiri on 2013-04-24

Hello, Im trying this application for the first time and Ive been unable to get it to work yet. Ive tried installing it on brand new, fresh installations of Mint 14 as Ubuntu 12.04. They both do the same thing. Whenever I try to log into my Windows 2008 RemoteAPP TS server, it fails with the error message "Application not in RemoteApp List. Check help to fix this". This is a production remoteapp server we currently use for our windows clients and I have no problem running remoteapp Iexplore, firefox, etc from my windows machine. I know the remoteapp server part is working. I tried using Thinomenon's Remote Desktop application on the Mint and Ubuntu vm's and it is able to launch Iexplore remoteapp. Have you seen this issue before? Is Winconn looking for a local remoteapp list? Thanks in advance for any help.

Question information

Language:
English Edit question
Status:
Solved
For:
WinConn Edit question
Assignee:
No assignee Edit question
Solved by:
Mike Kongsiri
Solved:
2013-04-25
Last query:
2013-04-25
Last reply:
Mike Kongsiri (mkongsiri) said : #1

I was able to resolve it. I had tried to initially add the registry entry to the server as per the windows 7 instructions for enabling remote app "fAllowUnlistedRemotePrograms", it still did not work. I fixed it by logging into the server's remoteapp manager=>RDP settings=>RD Session Host Server=>select "Allow users to start both listed and unlisted programs". Worked like a charm. Thanks for this invaluable app, it's opened new worlds!

Alex Stanev (realender) said : #2

Great it's working. Please keep in mind that this setting means your users can run every remote app and since this is production server, this setting can be dangerous from security point of view.

greg (xeon-greg) said : #3

>" I fixed it by logging into the server's remoteapp manager=>RDP settings=>RD Session Host Server=>select "Allow users to start both listed and unlisted programs". Worked like a charm. "
for production server it's not a solution.
 how make it work with only listed application ??? that is a big question

Andrew Olney (aolney) said : #4

There's another way to solve this apparently

I'm using Explorer (windows file explorer) as a *listed* remote app

To make this work in Winconn I make the "Application Name" as "||Explorer"

Also, I have successfully installed this on Debian Sid/Wheezy by installing gir1.2-appindicator3-0.1 libappindicator3-1 libdbusmenu-glib4

Building FreeRDP-1.0.2 from source:

cmake -DCMAKE_BUILD_TYPE=Debug -DWITH_SSE2=ON -DWITH_CUPS=OFF -DWITH_FFMPEG=OFF .

and building Winconn from source

python setup.py install