I can't connect to my Vista PC "Connection to server failed" with Xubuntu 12.04

Asked by Dandromb on 2012-07-19

I am trying to test/use the Winconn program to run anything I can remotely from Xubuntu. I have tried accessing "cmd" and "notepad.exe" so far to no avail.

I've installed Winconn through the Ubuntu Software center. I've updated all my packages. I've set up my Vista 64 Bit host computer as thoroughly as I know how, having installed an update for windows here to get remote functionality: http://www.microsoft.com/en-us/download/details.aspx?id=20414

I've followed the instructions using regedit to further set-up my Vista machine here: http://blog.stealthpuppy.com/virtualisation/remoteapp-for-windows-xp-and-windows-vista-the-missing-pieces/

I've set up a remote application (cmd) using the RemoteApp Tool by Kim Knight from here: https://sites.google.com/site/kimknight/remoteapptool

I have checked what version of the Microsoft .NET Framework I have, and it's both "3.5 SP1", and "4 Client Profile".

I'm trying unsuccessfully to remotely connect to my Vista computer's applications from Xubuntu on my laptop. Both computers are on. I am in the process of updating my Vista computer, and it's got SP1, which is not the most-recent; My system isn't up-to-date, so if You'd like me to try updating everything and trying again I can do so.

I'd like to use the application you've developed, but I'm having difficulty. Any assistance is appreciated.

Thanks, Dan D

Question information

Language:
English Edit question
Status:
Answered
For:
WinConn Edit question
Assignee:
No assignee Edit question
Last query:
2012-07-19
Last reply:
2013-05-17
Alex Stanev (realender) said : #1

Hi,
"Connection to server failed" means your linux box can't connect to windows one. This can be because of some network issue, firewall(on win or linux box) blocking connection or just remote desktop was not been configured correctly.
Maybe you cant first try to connect with regular remote desktop client like Remmina first, to make your your server is accessible.
.NET Framework is needed only for Kim's tool and not for accessing applications with WinConn itself.

Thomas Nys (thomas-nys) said : #2

I'm having the same problem on W7. I can rdp to my virtualbox vm from ubuntu to W7 but I keep getting the message, connection to server failed. Is there anything else I can check?

Alex Stanev (realender) said : #3

This is really strange, as this is still network error.
Please try to change Server filed with IP and make sure you are using the right port 3389 or if for some reason it is changed - change it in WinConn too.
Also, try to connect via telnet:
telnet [your_server_IP] 3389

Thomas Nys (thomas-nys) said : #4

I can telnet without any problem. No firewalls are involved. I'm using V-box as hyperviser.

Josué Piña (jabdhel) said : #5

Hi, I have tried to connect from Ubuntu 12.04.2 to a VM with Windows 7 and everything worked, but when I tried from a VM with Windows 8 and got the same error message: "Connection to server failed", I have verified and I can connect to the full desktop via Remmina, also added the registry key as described in the main page but I keep getting the same connection error. Then did a search about how to enable RemoteApps in Windows 8 and found an article for Windows 8 RT and the Surface (http://www.daveamenta.com/2012-11/using-remoteapps-on-surface-rt-windows-rt/), tried that as well and disabled the windows firewall as an extra precaution but still getting the same connection error. Any thoughts? Thanks.

Dmitry (email-xld) said : #6

I had the same problem with "Windows 7 Pro". FreeRDP also failed to connect with message "Unexpected licence packet".
I tried to install "Windows 7 Ultimate" and it worked for me.

Roberto (crbtov) said : #7

I have kind of the same problem; I'm returning to linux (Ubuntu 16.04) but i need some windows programs like CAD software, i was trying an MS Office 2013 on ubuntu tutorial for then try the same procedure for the CAD software. but i keep receiving the same problem: "Connection to server failed" I already verify the IP adress and the port, windows firewall from the virtual machine.

Can you help with this problem?

Provide an answer of your own, or ask Dandromb for more information if necessary.

To post a message you must log in.