recent persistant failure to read and write sd card

Asked by brian on 2018-01-29

Hi
I installed 1.0 on 4/1/18 and have used it several times to read and write to 32gb msd cards successfully.
however about a week ago i suddenly got a write to sd failure. since then i always get the same error message ( something about handle failure after about 4gb in)
but also i can no longer red the same cards that i sued to use back to my laptop, i get err disk not large enough for the specified image.

i have uninstalled and reinstalled, still same.

the sd contents are multipartition standard raspberry noobs/denbian install content.

the sd cards that i am trying to read from work fine in both the target machine using them ( raspberry pi) and displaying content in windows file explorer

i have windows 10 installed, there is tons of room on the laptop disk ( its an ssd). i dont believe i have installed anything else since the original install ( apart from the reinstall)

any ideas?

meanwhile i am going to dig out an old laptop and try that to see if its my windows laptop that is somehow causing the problem.

Question information

Language:
English Edit question
Status:
Answered
For:
Image Writer Edit question
Assignee:
No assignee Edit question
Last query:
2018-01-29
Last reply:
2018-02-10
brian (brianharding) said : #1

also, re other ideas - i have made sure no file explorer running, tried run as administrator and turned off avg briefly

Manfred Hampl (m-hampl) said : #2

Just an idea:
What file system does the device have? Do you see this failure when copying lots of small files, or with one very big file?
There are file systems that do not allow files bigger than 4gb, and the error message that you receive if you try copying a bigger file sometimes is misleading.

brian (brianharding) said : #3

hi
thanks

the sd card is the boot etc sd for the raspberry pi, so i am doing an image copy off the base drive letter onto my windows laptop file. ( when i get the read failure.

the opposite for the write failure ( ie image file onto sd card)

my instinct is something is causing the win32imager to fail when reading or writing to the sd card ( something locking it?) i have tried rebooting windows but it still fails

if i use windows explorer i can see files etc on the sd card

brian (brianharding) said : #4

so, interesting. i have installed win32di on to a different machine and its working fine so far with the same sd cards. which implies something config wise has happened to my main laptop over the past couple of weeks to cause the app not to work.

if anyone has any clues about the app that some config or something might cause it to misbehave in the way it is i'd be very grateful to know it.

thanks

brian (brianharding) said : #5

so, the read to disk problem was me being daft. a couple of failed attempts had eaten up space.

still dont know whats going on on the write img to sd though. it used to work now it fails on all 3 machines ive tried saying access denied, handle error 5

Tobin Davis (gruemaster) said : #6

The 'Error 5' issue is a fairly generic error, essentially saying that some other program has the device open for read/write and is blocking our exclusive access, likely after finishing writing the first partition (which I believe is a fat32 partition for the RPI). I only recently discovered that Windows has a whole new set of APIs for working with SD cards, so when I can get more development time, I have to sort through those to see what I need to do to lock SD cards during write operations.

Just don't ask for an ETA. My 'copious spare time' is preciously low. :)

brian (brianharding) said : #7

I have sort of solved the problem ( actually got around it). If it helps o dont think its a windows problem per se, unless i accidentally unlocked the api.

so the scenario was
i copied an image from ( a raspberry pi boot ) sd to my pc and then wrote it to an existing SD ( SD2) successfully. I made some changes to the master and successfully rewrote it.
but I then made some more changes to the master and re copied it to the pc and then tried to write it to the SD2 and it failed with the write rrror
i tried rebooting the pc , re copying etc and all to no avail.

I got a brnad new SD (sd3) and successfully r=wrote to it, but a subsequent attempt failed like before.

After googling around on the PI boards i deleted all partitions and volume off the SD2 card. it then successfully wrote, same with SD3.

again subsequent attempts to write failed unless i first deleted all partitions and the volume ( i am not sure if i needed to do such a total destruct, but like i dont have loads of time to really narrow it down at the moment i just needed the SD rewritten.

btw ALL of my SDs are 32gb

the apparent sizes of the partitions didnt change. I dont know much about SDs, but the display of the SD shows 2 headers and 2 partitions, the first partition being small.

But i have an unsubstantiated theory. i think the subsequent rewrite failed once the data content on the second partition once the data content size for that partition exceeded the size for the first partition? nb i cannot prove this, it was just a fleeting spot and thought.

Can you help with this problem?

Provide an answer of your own, or ask brian for more information if necessary.

To post a message you must log in.