Win32 Disk imager - 3 files on sd card

Asked by Bruce Williams on 2013-12-18

Hi,
I have downloaded Win32 Disk Imager to write a Kali Linux image onto a micro sdcard. Win32 seems to work fine, getting the image finding the sd card. The result is three files. The program says successful write. I have tried it both normal and run as administrator under Windows 8.

I tried a different adaptor for sd card to usb as it used a piggyback into a standard sd card. I replaced with special micro sd card to usb.
Result
Three files are MLO, u-boot and uEnv which are too small for the Kali 6.83G image. Image was 7zipped from Kali website download so image should be good.
I suspected cable to usb and inserted direct into usb port - no difference.
I suspected that the Windows could not see the files (hidden) but the boot up failed as no image transferred.
I suspected the micro sd card but new Class 10 San Disk 16G
I am running out of suspects....
Any ideas guys?
Thanks in advance

Question information

Language:
English Edit question
Status:
Solved
For:
Image Writer Edit question
Assignee:
No assignee Edit question
Solved by:
Bruce Williams
Solved:
2013-12-20
Last query:
2013-12-20
Last reply:
2013-12-19
Tobin Davis (gruemaster) said : #1

Could you provide a link to the image that you tried to write? I have not seen this particular issue, and it sounds like the image is maybe for just a partition, not an entire memory device.

Tobin Davis (gruemaster) said : #2

Another possibility is that the image has two partitions; 1 fat (boot) and 1 ext2/3/4 for the OS. Windows would only see the boot partition with MLO, uboot, and uEnv files needed for arm systems. This is how Ubuntu used to build their arm based preinstalled images.

Have you tried booting this SD in a system the image was created for?

Tobin,
I have tried booting but no luck. Therefore either no image or image in wrong partition.

I suspected that there are two partitions. One is the image which is hidden. The properties of the 16G changes to 120M so that would suggest a large partition.

The image is a Beagleboard Black arm at http://www.kali.org/downloads/.

I tried booting up the Beagleboard via a user boot switch S2. If the loading expects the image to be the only stuff on the 16G microsd and it gets a partition then I suspect it will not boot.

Thanks,
Bruce

Tobin,
I also checked with San to see if their microsd card had any special "features". They replied
Thanks for contacting SanDisk Technical Support. It is our goal to make sure you have all the resources you need to get the most from your product.

We would like to inform you that we do not support this usage. Please use the MicroSD card as a normal file storage device.
I thought that an image is file storage.
Thanks,
Bruce

Tobin,
I downloaded (http://www.chrysocome.net/explore2fs) Explore2fs which shows image is there
G (microsd card) 122M
G /storage/kali/images/beaglebone-black/root 6.72G
opened partition to find 12 folders
So the partition is there and working. Win32 image did its job. It then becomes a boot problem
Thanks,
Bruce

Tobin,
Correction: the above link was wrong http://www.diskinternals.com/download/Linux Reader. The Explore2fs did not support Windows 8.
Bruce

Tobin,
Thanks the boot problem seems to be the key. I have headed over to guys with similar problem:
https://groups.google.com/forum/#!topic/beagleboard/8qqxrNu9WVY

Thanks for the suggestions, knowing what the problem is the key.
Bruce

Tobin,
Another email from San Disk saying not suited for this type of use. The San microsd shows up as ok on list of compatible Sd cards
http://elinux.org/RPi_SD_cards
Section 3 working -non working cards
Quality sd card
Thanks,
Bruce

Tobin Davis (gruemaster) said : #9

None of the SD card manufacturers will list this as a supported use case, but there really should be no reason for it not to work. I suspect that it is an image issue though. Reading through the threads in the google group, I see your replies along with others indicating your uEnv file may be incorrect. Do you get any uboot prompt or any indicator on the serial console?

I'm looking at the image from http://cdimage.kali.org/kali-images/kali-1.0.5/kali-linux-1.0.5-armhf-bbb.img.xz . Is this the correct one? In tearing open the image on my Linux system (I don't have a bone to try on), the image appears ok, except the boot (vfat) partition probably needs to be flagged as bootable (can't remember from my Pandaboards if this makes a difference).

Tobin,
I looked over the sd cards for RPi and the San disk seems ok. I tried the uEnv correction but that was debate between John and William. They say that the user boot is from the uEnv.txt file and I tend to agree with them. The correction forces the sdcard to be the only choice.

I did find another group with the same problem
https://forums.kali.org/showthread.php?18331-BeagleBone-Black-image-not-working

I used the 1.0.5 image as you asked above. This group shows that it is a more wide spread problem than I first thought. I agree with you it sounds like the first partition does not boot even when asked.
I suspect that the Sandisk know more than they are saying as they wanted the serial number. I have read that to get higher speed they have done something funny with the interface. Trick is use lower speed card. Sandisk had problems with Ultra.
Bruce