Could not find disk image, now I can't even see my SD

Asked by Simon Fish

So I was writing a recent Wheezy Raspbian image to my 16gb SD, and then it said what's in the description. The light on my USB SD reader now doesn't even turn on...I'm worried... Help!

Question information

English Edit question
Image Writer Edit question
No assignee Edit question
Solved by:
Simon Fish
Last query:
Last reply:
Revision history for this message
Simon Fish (fishii10) said :

OK, so now I've tried putting my SD into my iMac. Formatted it. Will try on the SD reader later. I've got another computer with a built-in SD reader, so if this question doesn't get answered I'm fine. It'd still be best to solve it for the good of the community, though.

Revision history for this message
Tobin Davis (gruemaster) said :

First, this program is not tested on iMac. It is a Windows Only utility.

Second, it would be most helpful if you added more details to your question, i.e.:
1. Computer hardware model
2. SD Reader type
3. OS Version
4. Win32DiskImager version (if it isn't on the lower left corner of the main window, it is very outdated and unsupported).

There is an issue with some built-in SD readers on older laptops running XP/Vista (LP:1118217) that will (hopefully) be fixed with the next release (v0.9).

Revision history for this message
Simon Fish (fishii10) said :

I used one of the front ports of my Dell Dimension C521. Only modification I've made to that was an extra 2gb of RAM. I'm using WinXP Home, SP3, Disk Imager 0.7. And it's an Integral SD card reader.
Note: I've done what I need to do with the card now, I'd just like to get the reader working again.

Revision history for this message
Tobin Davis (gruemaster) said :

Nothing about my program should have affected your SD Reader. Use Device Manager to check the status of the device. There may be something else going on there.

Also, I am not familiar with all the RPI Images, so it could be that the image is using a non-standard partition table or simply that Windows can't figure it out.

Note that my program is not designed to expand a file system to fill the device. It does a simple read/write. If the image you have is for a 2G SD card, and you flash it to a 16G SD, it will look like a 2G SD until it is repartitioned properly.

Revision history for this message
Simon Fish (fishii10) said :

It was the latest Raspbian Wheezy image, I think. It doesn't seem to show up in Device Manager, and also the light is off on the reader.

Revision history for this message
Tobin Davis (gruemaster) said :

Have you tried a different SD Card? Have you tried reformatting your SD Card with a different utility, like the HPUSBDisk.exe format utility or some other utility (there are several out there)?

Unfortunately, I can't test my program on every system out there, so I can't always hit every single irregular issue (which this is turning into).

Based on the manual I found for your system (, there are a few troubleshooting steps you can follow to determine if your reader is functioning properly. Please try those as well.

As I said earlier, there is nothing in my code that would do physical harm to your SD Reader, and I have only had a few (1 personally, 3 reported) memory devices that were completely unusable after using Win32DiskImager, all of which proved to be faulty devices.

Please try the options I have posted here, and get back if none work. You may need to contact Dell support. If so, let them know what software you used, so they can test it in-house. If in fact there is an issue, I need to know (not that I would know how to fix it).

Revision history for this message
Simon Fish (fishii10) said :

Thanks for taking the time to research, but none of this seems to have worked. I've got a laptop kicking around somewhere that I used to image the SD Card again. Looks like I'm a special case... Maybe my reader was coincidentally damaged? It's happened before (not with DiskImager, though). Don't worry about it. Your work on the software is, while heavily taken for granted by most, very essential to any Raspberry Pi user, so be proud!