cannot write raspbian .img, warning about physical device as well as "error 5 cannot lock etc." if I continue

Asked by Arvind Kale on 2013-05-21

I am using win7 and downloaded win32diskimager-v0.7-binary, unzipped files and ran the .exe as administrator.
When trying to write the raspbian .img file to an SD card, first I get a warning about writing to a physical device. I tried two different SD cards, both are recognised by the program with the correct drive letter, but the same warning appears. If I continue to try and write anyway, I get an "error 5 cannot lock....etc."

I have tried formatting the card, but the same messages keep coming up. If I try copying an ordinary file(not .img) through normal Win7 methods the card works fine. I re-format the card showing full capacity and try writing the img file again but the problem remains as before.

What am I doing wrong ? I am very keen to get my RaspberryPi working. Please HELP

Question information

Language:
English Edit question
Status:
Solved
For:
Image Writer Edit question
Assignee:
No assignee Edit question
Solved by:
Jeff B
Solved:
2013-05-22
Last query:
2013-05-22
Last reply:
2013-05-21
Best Jeff B (skydiver38) said : #1

The warning about writing to a physical device will always come up. It's kind of an "Are you sure?" message that allows you to verify the device that you're about to write to, since it can't be undone once written.

The "cannot lock" usually means that some other process is using the device. Either an open windows explorer window to the drive, or a process that is doing something to/on the drive. In order to write to the device, ImageWriter needs be the only process using the device.

A nice-to-have would be a pop-up with some info about whatever is preventing the lock, but that's a long way off at this point.

Try to figure out what's using the device - shut that process down and try to write again....

Arvind Kale (arvindk671) said : #2

Thanks Jeff. Try as I might, I could not work out what process was the problem. Killed as many processes as I dared.

Finally formatted the SD cards again using FAT32 FS. For no particular reason also restarted the computer. Guess what, success this time. Since I did two things at the same time, I cannot say what was the real cure. Have not yet had the time to boot the Raspberry Pie !!

Hope to do it tonight. Thanks again for your prompt help.

Arvind Kale (arvindk671) said : #3

Thanks Jeff B, that solved my question.