Nothing happens when I click on 'Device'

Asked by phil Maynard on 2012-10-05

Just spent 2 hours downloading Raspberry pi image and your software. Now got the image, got my SD card in the slot, unzipped your program, run it, browsed to my image, but when I click on 'Device' absolutely nothing happens!
Frustrated to say the least.

Question information

Language:
English Edit question
Status:
Solved
For:
Image Writer Edit question
Assignee:
No assignee Edit question
Solved by:
phil Maynard
Solved:
2012-10-05
Last query:
2012-10-05
Last reply:
phil Maynard (3m) said : #1

It appears that the software has to 'see' the device being plugged in, ie. it can't see it if its already attached to the computer when the program starts up!!

Jeff B (skydiver38) said : #2

That's the *opposite* of how I've seen it work. There is a known issue with some memory card readers where they don't "notify" that a previously-empty slot has had a device inserted, so IW never knows about the device. But if IW is started with the device already in the slot, it can be seen.

Alexnco (alexnco) said : #3

In my case, whether the SD Card is plugged in and recognised by the OS before or after ImageWriter is started, IW still does not recognize any drives ("Device" is simply blank). IW recognizes the *.img file, but nothing else happens. Running on Windows Vista SP2, 32 bit.

Ken Stein (kstein3) said : #4

I have a similar issue using this program:

I'm using the SD slot in my laptop vs. an adaptor.

MyComputer sees the SD drive and can operate on it.

It doesn't matter if the device is there when I start Win32DiskImager.exe or the device is missing and added later.
I still get no option to select a drive in this application.

I don't happen to have a USB external reader handy at the moment to try that next.

Anybody have a solution or is this a known bug being worked on?

bob huntsman (bobhuntsman) said : #5

I have the same problem:

The OS recognizes the SD drive, but the DiskImager does not.

DI recognizes a USB flash drive, but not an SD card.

WTF?

Ken Stein (kstein3) said : #6

Bob, my problem turned out to be the internal laptop SD slot did not work but when I used an external USB SD reader, worked like a champ.

Ken.

Ken Paul (kenandgeri) said : #7

I had the same problem, using both the internal slot and an external/USB adapter. Finally got it to work by using the external adapter and rebooting the system with the SD card already in place. When I did that, the Win32DiskImager program showed my SD card as the [F:\] drive immediately. I'm using Vista (32-bit, SP1).

Are we actually confident that one of the suggested approaches solves everyone's problem, so that this topic should be marked "Solved"?