No translation file found

Asked by TerryG80 on 2010-01-05

After using wiithon flawlessly a few times I took my wii to my uncles and on returning home wiithon won't launch. When running through terminal this gets returned to me:

Traceback (most recent call last):
  File "/usr/games/wiithon", line 114, in <module>
  File "/usr/games/wiithon", line 48, in App
  File "/usr/share/wiithon/", line 519, in configurarLenguaje
  File "/usr/share/wiithon/", line 485, in setLanguage
    lang = gettext.translation(config.APP, languages=[locale])
  File "/usr/lib/python2.6/", line 484, in translation
    raise IOError(ENOENT, 'No translation file found for domain', domain)
IOError: [Errno 2] No translation file found for domain: 'wiithon'

As far as I know nothing has changed with my setup. Any ideas? I've tried running as su and running the command export LANGUAGE=en;wiithon with no luck.

Question information

English Edit question
wiithon Edit question
No assignee Edit question
Solved by:
Carlo Mandelli
Last query:
Last reply:
Best Carlo Mandelli (camandel) said : #1

I think that your translation file (/usr/share/locale/en/LC_MESSAGES/ has been deleted.
Try to reinstall wiithon deb package.

TerryG80 (terryg80) said : #2

Thanks Carlo Mandelli, that solved my question.

Hi Carlo Mandelli. I am also getting same error

Traceback (most recent call last):
  File "", line 501, in <module>
  File "C:\Users\vvmvdlm\AppData\Local\Programs\Python\Python37-32\lib\", line 524, in tra
    'No translation file found for domain', domain)
FileNotFoundError: [Errno 2] No translation file found for domain: 'messages'

Below is my code snap:


  _ = gettext.translation(

please advice

Carlo Mandelli (camandel) said : #4

I'm quite surprised (and proud) to see wiithon is still used after so many years :-)

It had been developed to run on linux with python 2.x and you're using python 3.7 on a Windows system. Better try to use it on a Virtual Machine with a Linux system and an older python version (like 2.7).