Wiithon only copies 0.34GB/4.4GB to the WBFS partition

Asked by Jeff Webster on 2009-12-13

I was very happy to find your Wiithon utility -- it looks great. However, I am having a problem where Wiithon does not seem to copy the whole game (ISO) to the external hard drive. I've tried stable 1.1 and development 1.21 versions -- both installed successfully. I successfully formatted an external hard drive connected to my laptop to WBFS. Wiithon recognized the ISO file, downloaded the appropriate cover art and information -- but ultimately only copied 0.34GB of 4.4GB (Super Mario Bros Wii) to the external hard drive with WBFS partition. I plugged the drive into the Wii and used USB Loader -- it recognized the drive and showed the Super Mario Bros Wii game entry -- but failed to load it (of course, since it was only 0.34GB). Am I missing something obvious? Any ideas?

EDIT: Was just playing around with the ISO and I noticed that it contains an "UPDATE". In other words, the ISO contains two "PARTITIONS"... 0 and 1. Partition 0 is the game/Wii update. Partition 1 is the game itself. Is it possible that Wiithon thinks Partition 0 is the game -- hence why it is only 0.34GB on the hard drive?

Thanks so much for a great program... it is always very exciting to see development like this for Linux users.

Best regards and thank you in advance for your help!

Jeff

System: Kubuntu Karmic 9.10, 32-bit

Question information

Language:
English Edit question
Status:
Solved
For:
wiithon Edit question
Assignee:
No assignee Edit question
Solved by:
Carlo Mandelli
Solved:
2009-12-13
Last query:
2009-12-13
Last reply:
2009-12-13
Best Carlo Mandelli (camandel) said : #1

Wiithon, as any other WBFS partition manager, stores on HD only needed bytes from ISO images.
So it is correct that "New Super Mario Bros" uses only 0.34 GB on your WBFS partition.
It is a "bit special" game, read on forums how to configure your USB loader to work with it.
But this isn't related with Wiithon....

bye

Jeff Webster (jjwebster) said : #2

Carlo, thanks so much. Got it to work. You guys have done some great work here. Cheers.