English?

Asked by Adrian on 2009-11-11

Probably very easy and daft, I have downloaded the 64bit build (1.12-338) deb file and installed to my ubuntu 9.10

However I can't get it to display in English correctly? I have been into the settings and changed caratulas tab I have changed the languages to both options to English but majority of thing's still display in Spanish.

I have managed to get the menu bars to show in English now, however when I hover over and icon to find out what it does it still displays in Spanish. I would also like to check out the settings to see what options I can change!

Any help apprecaited, even if it points me in the direction of an older version. It's not the end of the world. Great application.

Question information

Language:
English Edit question
Status:
Answered
For:
wiithon Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-11
Last reply:
2010-12-03
Carlo Mandelli (camandel) said : #1

Try last version (links in home page are not yet updated):

https://launchpad.net/~wii.sceners.linux/+archive/wiithon/+files/wiithon_1.12-361_amd64.deb

Wiithon uses system default language, to setup another one use "export LANGUAGE=<lang>" before run it.
Note: language options in settings tab are *only* for synopsis from WiiTDB.

bye

chris (nakoruru) said : #2

I had uninstall 1.16-387 and download 1.12-361 , but it still Spanish...
I'm using Chinese, how can I let it show at least English? Q.Q

Carlo Mandelli (camandel) said : #3

Install latest stable release (now is 1.16-387) and then from a shell:

export LANGUAGE=en;wiithon

chris (nakoruru) said : #4

Thanks that it can display in English when I type that in terminal.
How can I make a shortcut without type it?
May it has a option about chosing the language use?

However, when I run it, it shows a warning: You can not access the partitions because the user who launched wiithon not belong to the group "disk". Showing the games of the last session.
But I have add myself to the group disk.

I find that although I plugin the use harddisk (wdfs for wii) , ubuntu seems not find it... What's wrong?

chris (nakoruru) said : #5

I'd use "sudo /usr/share/wiithon/wiithon.py" and it find my wdfs harddisk success!
The only question I cannot solve is how to run directly in Application menu....
I tried "export LANGUAGE=en;sudo /usr/share/wiithon/wiithon.py" but it always not accept "export"

Carlo Mandelli (camandel) said : #6

From last developement release (r407) wiithon language can be chosen directly in preferencies.

To use wiithon without sudo check that your USB device is writable and readble by group:

brw-rw---- 1 root disk 8, 0 2009-11-23 08:23 /dev/sdc

and then verify that your user is really in that group ($ id).

youbonetu (armand-rock) said : #7

here's how i got it running in the application menu:

1. Right click on Wiithon under Applications->Games and select "Add this launcher to Panel"

2. gedit ~/wiithon.sh with the following 2 lines:
#! /bin/bash
sudo /usr/share/wiithon/wiithon.py

3. Give it execute permissions (chmod 777 wiithon.sh)

4. Right click the launcher in your panel and select Properties
Change the type to "Application in terminal"
Browse to wiithon.sh
Click close

you should now be able to run the application by clicking on it (it might request a password for your account once in a while as it runs as root). Note: this doesnt affect the launcher under Applications->Games only the one you added to the panel

mitch (mitch-embry) said : #8

I am having the same issue as the OP on version 1.16 rev 404. What is odd is that when I first launched the program after installation (and for several days after that) the program loaded in English by default. A few days later I launched Wiithon and it was suddenly in Spanish. As far as I know nothing changed on my system or within the program settings to cause this.

I tried setting the language by entering the export LANGUAGE command mentioned above but it still loads in Spanish. I looked through the preferences menu but the only place I see to choose a language (at least that I can determine from my limited understanding of Spanish) is in the WiiTDB tab and that is obviously for the database and not the program (also mentioned above). I completely removed and purged the program and reinstalled twice using the latest stable version from the repo listed on the Overview page but still cannot get the program to display in English. Any help is appreciated.

mitch (mitch-embry) said : #9

I got this problem sorted on my own but I wanted to post here to update my question and to try and understand why the issue occurred., I removed/purged wiithon and installed it manually by downloading the same version, only from the wii-sceners launchpad rather than the repo. Which happens to be the same source I used to install the very first time when it was in English so obviously there is either a difference between the package in the repo and the package on wii-sceners or a difference in the way it installs. That still doesn't explain why the program suddenly changed form English to Spanish after a few days of use.

Can you help with this problem?

Provide an answer of your own, or ask Adrian for more information if necessary.

To post a message you must log in.