Wiithon Fedora 12

Asked by Jim! on 2010-03-21

I am trying to compile the source on Fedora 12.

From what I understand, below are the debian package dependencies (I have it working on debian sid fine) and some of what I think are the Fedora equivalents;

Debian ------------------ Fedora

libc6 --------------------- glibc
libc6-dev --------------- glibc-devel
imagemagick ---------- ImageMagick
python ------------------ python
libgtk2 ------------------ <-- Unsure what the Fedora equivalent is!
python-gtk2 ----------- <-- Unsure what the Fedora equivalent is!
python-glade2 -------- <-- Unsure what the Fedora equivalent is!
python-sexy ----------- python-sexy
python-sqlalchemy --- python-sqlalchemy
gnome-icon-theme --- gnome-icon-theme
gcc-multilib ------------- <-- Unsure what the Fedora equivalent is!
python-libxml2 --------- <-- python-lxml MAYBE
unzip -------------------- unzip

Can anyone help me identify which are the required fedora dependecies. As the otput from "make" doesn't provide any hints;

# make
echo 486 > doc/REVISION
*** GETTEXT *** Extract strings from code
xgettext --language=Python --no-wrap --sort-by-file --keyword=_ --keyword=N_ --from-code=utf-8 --package-name="wiithon" --package-version="1.21-487" --<email address hidden>" -o po/plantilla.pot recursos/glade/wiithon.ui.h animar.py builder_wrapper.py cli.py config.py conversor.py core.py estadistica.py extraer.py fila_treeview.py gui.py informacion_gui.py loading.py pool.py preferencias.py selector_ficheros.py test.py textview_custom.py trabajo.py util.py wiitdb_schema.py wiitdb_xml.py wiithon.py 2> /dev/null
make: *** [po/plantilla.pot] Error 127

Jim!

Question information

Language:
English Edit question
Status:
Solved
For:
wiithon Edit question
Assignee:
No assignee Edit question
Solved by:
Jim!
Solved:
2010-03-23
Last query:
2010-03-23
Last reply:
2010-03-22
Carlo Mandelli (camandel) said : #1

Have you /usr/bin/xgettext file (gettext-0.17-16.fc12)?

Jim! (v7m9vc6ak2) said : #2

I have now. It's now coughing up about g++ command not found, hers the last past of the output;

==================================================================
wwt compile OK
==================================================================
make -C unrar-nonfree
make[1]: Entering directory `/var/hda/files/source/Wiithon/trunk/unrar-nonfree'
g++ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSILENT -DUNRAR -c rar.cpp
make[1]: g++: Command not found
make[1]: *** [rar.o] Error 127
make[1]: Leaving directory `/var/hda/files/source/Wiithon/trunk/unrar-nonfree'
make: *** [unrar-nonfree/wiithon_unrar] Error 2

Jim!

Jim! (v7m9vc6ak2) said : #3

OK I worked out that g++ was supplied by gcc-c++, so I'm now a bit further on but still ..................

==================================================================
UNRAR modified for wiithon compile OK
==================================================================
make -C wbfs_file_2.9
make[1]: Entering directory `/var/hda/files/source/Wiithon/trunk/wbfs_file_2.9'
gcc -DLARGE_FILES -D_FILE_OFFSET_BITS=64 -Ilibwbfs -O2 -Wall -Wno-unused-variable -Wno-unused-result -m32 -o libwbfs/libwbfs.o -c libwbfs/libwbfs.c
In file included from /usr/include/features.h:376,
                 from /usr/include/stdio.h:28,
                 from libwbfs/libwbfs_os.h:8,
                 from libwbfs/libwbfs.h:4,
                 from libwbfs/libwbfs.c:6:
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory
cc1: warning: unrecognized command line option "-Wno-unused-result"
make[1]: *** [libwbfs/libwbfs.o] Error 1
make[1]: Leaving directory `/var/hda/files/source/Wiithon/trunk/wbfs_file_2.9'
make: *** [wbfs_file_2.9/wiithon_wbfs_file] Error 2

Fixed this by installing glibc-headers, then a final error about a missing /usr/include/gnu/stubs-32.h file was fixed by installing glibc-devel.1686. Hopefully that's it fixed now all I need to do is plug in the USB drive and see if it works.

Jim!

Jim! (v7m9vc6ak2) said : #4

Well it seems to working, no probs.

Here I am answering my own question but without a start from Carlo I'd be nowhere, still lingering in a virtual twilight. Thank you Carlo!

So I think from my version of an installed Fedora 12 base, all I had to do was ............. and I wish it had been as easy as this ......;

yum install gcc gcc-c++ glibc glibc-devel glibc-headers glibc-devel.i686 ImageMagick python-gtk2 python-glade2 python-sexy python-sqlalchemy gnome-icon-theme gcc gettext

and I eventually built 1.21 (rev 487) from source. BTW excellent GUI tool to download source is bzr-gtk.

I hope this helps some one else to make the process simple(ish).

Jim!

Hi Jim!
I just want to thank you for your auto answers. it works for me too on Fedora15

Again thank you!