Wiican fails to run on ubuntu 10.04

Asked by Yoshi

I found wiican 0.3.0-1~getdeb1 at getdeb.net.
And I installed it on ubuntu 10.04.

But I had to do 2 more things to run wiican correctly.

1. I had to install "python-ply" separately using synaptic.
2. I have to "cd /usr/share/wiican" to manually change the current directory before running,
    otherwise get error saying:

          Traceback (most recent call last):
            File "/usr/bin/wiican", line 297, in <module>
              wiican = WiimoteStatusIcon()
            File "/usr/bin/wiican", line 62, in __init__
              if not builder.add_from_file(WIIMOTEMANAGER_UI):
          glib.GError: can't open './wiimotemanager.ui' : No such file or directory

After setting above two, it starts running.

But when I tried to create a new mapping file, I get an error saying:
          Traceback (most recent call last):
            File "/usr/lib/pymodules/python2.6/wiican/ui/managerdlg.py", line 84, in new_btn_clicked_cb
              mapping_editor_dlg = MappingEditorDialog(Mapping())
            File "/usr/lib/pymodules/python2.6/wiican/ui/editordlg.py", line 129, in __init__
              48, 48)
          glib.GError: failed to open file './wiican.svg' : No such file or directory

I still get some warnings saying:
          (wiican:3846): GConf-WARNING **: haven't implemented getting a specific locale in GConfClient
but this is not quite a problem.

Now, this is my question. If these are just about a path problem, then where or how to declare the path to the wiican?

I'm not sure if these could be called bug,
but I hope them to be fixed in the next release.

Question information

English Edit question
WiiCan Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
J. Félix Ontañón (fontanon) said :

Well the question it's that wiican 0.3.0 isn't packaged yet, so people from getdeb.net did it in advance and not quite well.

Can you please, Yoshi, add this question as comment in lp:501342 ??
That's the getdeb but to take care about wiican getdeb packaging.

Revision history for this message
Yoshi (akira44oka-regist) said :

Thanks for the quick reply!!

So, you are saying that the reason for the problem is all about packaging?

I'm not quite sure what lp:501342 is about. But is it ok to just copy&paste the same message to their page?
I'm quite new to this launchpad thing, and I don't know much about the system.

But I'll try!
Thanks anyways...
Best regards,

Revision history for this message
J. Félix Ontañón (fontanon) said :

Yoshi you did it quite well. Wiican team expects to provide an official package and ppa for wiican-0.3.0 soon, meanwhile you can download the tarball[1] and follow the INSTALL file instructions.

[1] http://launchpad.net/wiican/0.3/0.3.0/+download/wiican-0.3.0.tar.gz