New trainers don't seem to be created

Asked by Cynthia on 2019-04-30

It seems that after 4 trainers have been used, no more can be created. I have (Atlanteans) Labyrinth, Dungeon, and 3 Barracks. The last Barracks to be build remains unoccupied by trainer.
Build-28-rc1
Linux Mint 18.3 xfce

I tried building another dungeon & labyrinth, same result, no trainer though they were full of soldiers.

Question information

Language:
English Edit question
Status:
Answered
For:
widelands Edit question
Assignee:
No assignee Edit question
Last query:
2019-04-30
Last reply:
2019-06-05
GunChleoc (gunchleoc) said : #1

The trainers need 2 wares to be created, so make sure that those wares are available in the same warehouse.

Niektory (niektory) said : #2

The problem is that the same equipment is used to equip the trainers in headquarters/warehouses and the soldiers in barracks, so the equipment going to the barracks prevents the trainers from being equipped. You need to temporarily remove the equipment from the barracks (by using the left arrows in the building window) so it goes to the warehouse. Then, after the trainers get equipped you can send the equipment back to the barracks.

Can you help with this problem?

Provide an answer of your own, or ask Cynthia for more information if necessary.

To post a message you must log in.